poj3278--Catch That Cow(bfs)

  Catch That Cow

Time Limit: 2000MS   Memory Limit: 65536K
     

Description

Farmer John has been informed of the location of a fugitive(逃亡的;难以捉摸的;短暂的) cow and wants to catch her immediately. He starts at a pointN(0 ≤N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 orX+ 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit(追赶;工作), does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N andK

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题意:在一维坐标系中,给定John的位置,还有cow的位置,john有2种行动方式,(一)向前走一步(-1),想后走一步(+1);(二)跳到当前位置的2倍位置。

问:最少需要多少时间(分钟)可以抓到cow。

【用vis数组优化】:如果不加“代码中阴影”,会RE

【bfs搜索即可】:

#include<stdio.h>
#include<string.h>
int dx[3]={-1, 1, 2};
int vis[3000000];
int n, k;
struct node{
    int x, ans;
}q[3000000], t, f;

void bfs()
{
    memset(vis, 0, sizeof(vis));
    memset(q, 0, sizeof(q));
    int s=0, e=0;
    vis[n] = 1;
    q[s++].x = n;
    t.ans = 0;
    while(s>e)
    {
        t = q[e++];
        for(int i=0; i<3; i++)
        {
            if(i!=2)
                f.x = t.x+dx[i];
            else
                f.x = t.x*dx[i];
            f.ans = t.ans+1;
            if(f.x==k)
            {
                printf("%d\n", f.ans);
                return;
            }
            else{
                if(!vis[f.x] && (f.x>0 && f.x<100000) )
                {
                       vis[f.x] = 1;
                    q[s++] = f;
                }
            }
        }
    }
}
int main()
{
    while(~scanf("%d%d", &n, &k))
    {
        if(n>=k)
        {
            printf("%d\n", n-k);
            continue;
        }
        else
        {
            bfs();
        }
    }
    return 0;
}
时间: 2024-10-13 14:01:28

poj3278--Catch That Cow(bfs)的相关文章

HDU 2717 Catch That Cow (bfs)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2717 Catch That Cow Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 12615    Accepted Submission(s): 3902 Problem Description Farmer John has been

POJ 3278 Catch That Cow(bfs)

传送门 Catch That Cow Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 80273   Accepted: 25290 Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 10

POJ - 3278 - Catch That Cow (BFS)

题目传送:Catch That Cow 思路:BFS找最小步数,用一个结构体存下当前结点的数值以及当前步数 AC代码: #include <cstdio> #include <cstring> #include <string> #include <cstdlib> #include <iostream> #include <algorithm> #include <cmath> #include <queue>

POJ 题目Catch That Cow(BFS)

Catch That Cow Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 52537   Accepted: 16471 Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,00

Catch That Cow(BFS)

Catch That Cow Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 10166    Accepted Submission(s): 3179 Problem Description Farmer John has been informed of the location of a fugitive cow and wants

POJ3279 Catch That Cow(BFS)

本文出自:http://blog.csdn.net/svitter 题意:给你一个数字n, 一个数字k,分别代表主人的位置和奶牛的位置,主任可以移动的方案有x+1, x-1, 2*x,求主人找到奶牛的时间(奶牛不移动) 题解:最基础的BFS但是脑子犯抽WA了3遍- = 注意: 1.数组范围1~1<<5 2.visit去重.(BFS最基础的) 代码: #include <iostream> #include <stdio.h> #include <string.h&

POJ 3278 Catch That Cow(BFS 剪枝)

题目链接:http://poj.org/problem?id=3278 这几次都是每天的第一道题都挺顺利,然后第二道题一卡一天. = =,今天的这道题7点40就出来了,不知道第二道题在下午7点能不能出来.0 0 先说说这道题目,大意是有个农夫要抓牛,已知牛的坐标,和农夫位置.而且农夫有三种移动方式,X + 1,X - 1,X * 2,问最少几步抓到牛. 开始认为很简单的,三方向的BFS就能顺利解决,然后在忘开标记的情况下直接广搜,果然TLE,在你计算出最少位置之前,牛早跑了. 然后反应过来开标记

HDU2717:Catch That Cow(BFS 队列)

这是一道用队列实现的BFS基础搜索题,学长给我们加这道题主要是让我们联系数据结构里面的队列,话不多说看代码吧. #include <stdio.h> #include <string.h> #include <math.h> #include <algorithm> #include <queue> #include <stack> #define LL long long #define mem(a) memset(a,0,size

poj 3278 Catch That Cow(广搜)

Catch That Cow Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 45087   Accepted: 14116 Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,00