hdu 3714 Error Curves(三分)

Error Curves

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1198    Accepted Submission(s): 460

Problem Description

Josephina is a clever girl and addicted to Machine Learning recently. She
pays much attention to a method called Linear Discriminant Analysis, which
has many interesting properties.
In order to test the algorithm‘s efficiency, she collects many datasets.
What‘s more, each data is divided into two parts: training data and test
data. She gets the parameters of the model on training data and test the
model on test data. To her surprise, she finds each dataset‘s test error
curve is just a parabolic curve. A parabolic curve corresponds to a
quadratic function. In mathematics, a quadratic function is a polynomial
function of the form f(x) = ax2 + bx + c. The
quadratic will degrade to linear function if a = 0.

It‘s very easy to calculate the minimal error if there is only one test
error curve. However, there are several datasets, which means Josephina
will obtain many parabolic curves. Josephina wants to get the tuned
parameters that make the best performance on
all datasets. So she should take all error curves into account, i.e.,
she has to deal with many quadric functions and make a new error
definition to represent the total error. Now, she focuses on the
following new function‘s minimum which related to multiple
quadric functions. The new function F(x) is defined as follows: F(x) =
max(Si(x)), i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric
function. Josephina wonders the minimum of F(x). Unfortunately, it‘s too
hard for her to solve this problem. As a
super programmer, can you help her?

Input

The input contains multiple test cases. The first line is the number of
cases T (T < 100). Each case begins with a number n (n ≤ 10000).
Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b
(|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding
coefficients of a quadratic function.

Output

For each test case, output the answer in a line. Round to 4 digits after the decimal point.

Sample Input

2
1
2 0 0
2
2 0 0
2 -4 2

Sample Output

0.0000
0.5000

Author

LIN, Yue

Source

2010 Asia Chengdu Regional Contest

Recommend

zhouzeyong

该题欲求众多二次函数中当x为0-1000之间的每个值的时候函数最大值,

将所有最大值求出输出最小的一个便可以,

解决方法:三分,

中间更新区间的时候调换一下位置即可,因为本体求得是最小值

ps:esp取1e-8的时候过不去,为WA,当开到1e-9的时候就过去了,原因可能是本题答案要求输出4位小数点,而在计算二次函数的时候计算了x*x会生成8位小数,所有保留9位小数才能保证精度不受损失

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int n;
struct node{
  double a,b,c;
}que[10005];
double esp=1e-9;
double ff(double x){
     double tmax=que[0].a*x*x+que[0].b*x+que[0].c;
     for(int i=1;i<n;i++){
        tmax=max(tmax,que[i].a*x*x+que[i].b*x+que[i].c);
     }
   return tmax;
}

void calculate(){
    double l=0,r=1000.0;
    double ans1,ans2;
    while(l+esp<r){
       double mid=(l+r)/2.0;
       double midmid=(mid+r)/2.0;
        ans1=ff(mid);
        ans2=ff(midmid);
       if(ans1<ans2){
           r=midmid;
       }
       else
       l=mid;

    }
    printf("%.4lf\n",ans1);
}

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        memset(que,0,sizeof(que));
      scanf("%d",&n);
      for(int i=0;i<n;i++){
          scanf("%lf%lf%lf",&que[i].a,&que[i].b,&que[i].c);

      }
      calculate();
    }
    return 0;
}
时间: 2024-10-13 12:14:47

hdu 3714 Error Curves(三分)的相关文章

HDU 3714 Error Curves

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3714 Error Curves Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 4536    Accepted Submission(s): 1721 Problem Description Josephina is a clever g

LA 5009 (HDU 3714) Error Curves (三分)

A - Error Curves Time Limit:3000MS    Memory Limit:0KB    64bit IO Format:%lld & %llu SubmitStatusPracticeUVALive 5009 Appoint description: Description Josephina is a clever girl and addicted to Machine Learning recently. She pays much attention to a

HDU 3714 Error Curves(3分)

题意  求分段函数的最低点  每个点函数值为n个 a*x^2 + b*x +c (a>=0, |b|<5000, |c|<5000) 函数的最大值 由于a是不小于0的   所以此分段函数的函数图像只可能是类似'V'形的  可以画图观察出来  那么求最小值就可以用三分来解决了 #include <bits/stdc++.h> using namespace std; const int N = 10005; const double eps = 1e-9; int a[N],

三分 HDOJ 3714 Error Curves

题目传送门 1 /* 2 三分:凹(凸)函数求极值 3 */ 4 #include <cstdio> 5 #include <algorithm> 6 #include <cstring> 7 #include <cmath> 8 using namespace std; 9 10 const int MAXN = 1e4 + 10; 11 const int INF = 0x3f3f3f3f; 12 const double EPS = 0.0000000

UVALive 5009 Error Curves 三分

//#pragma comment(linker, "/STACK:1024000000,1024000000") #include<cstdio> #include<cstring> #include<cstdlib> #include<algorithm> #include<iostream> #include<sstream> #include<cmath> #include<climits

UVA - 1476 Error Curves 三分

                                       Error Curves Josephina is a clever girl and addicted to Machine Learning recently. She pays much attention to a method called Linear Discriminant Analysis, which has many interesting properties.In order to test

Error Curves HDU - 3714

Josephina is a clever girl and addicted to Machine Learning recently. She pays much attention to a method called Linear Discriminant Analysis, which has many interesting properties. In order to test the algorithm's efficiency, she collects many datas

UVA - 1476 Error Curves (三分搜索)

Description Josephina is a clever girl and addicted to Machine Learning recently. She pays much attention to a method called Linear Discriminant Analysis, which has many interesting properties. In order to test the algorithm's efficiency, she collect

HDU3714——三分——Error Curves

Josephina is a clever girl and addicted to Machine Learning recently. She pays much attention to a method called Linear Discriminant Analysis, which has many interesting properties. In order to test the algorithm's efficiency, she collects many datas