华为VRRP浮动路由配置实战

VRRP浮动路由

eNSP中拓扑:

LSW3:

[SW3]vlan batch 10 20
[SW3]int e0/0/1
[SW3-Ethernet0/0/1]port link-type access
[SW3-Ethernet0/0/1]port default vlan 10
[SW3-Ethernet0/0/1]un sh
Info: Interface Ethernet0/0/1 is not shutdown.
[SW3-Ethernet0/0/1]int e0/0/2
[SW3-Ethernet0/0/2]port link-type access
[SW3-Ethernet0/0/2]port default vlan 20
[SW3-Ethernet0/0/2]un sh
Info: Interface Ethernet0/0/2 is not shutdown.
[SW3-Ethernet0/0/2]int g0/0/1
[SW3-GigabitEthernet0/0/1]port link-type trunk
[SW3-GigabitEthernet0/0/1]port trunk allow-pass vlan all
[SW3-GigabitEthernet0/0/1]un sh
Info: Interface GigabitEthernet0/0/1 is not shutdown.
[SW3-GigabitEthernet0/0/1]int g0/0/2
[SW3-GigabitEthernet0/0/2]port link-type trunk
[SW3-GigabitEthernet0/0/2]port trunk allow-pass vlan all
[SW3-GigabitEthernet0/0/2]un sh
Info: Interface GigabitEthernet0/0/2 is not shutdown.

LSW1:

[Huawei]sysname RSW1
[RSW1]vlan batch 10 20 100
[RSW1]int g0/0/2
[RSW1-GigabitEthernet0/0/2]port link-type trunk
[RSW1-GigabitEthernet0/0/2]port trunk allow-pass vlan all
[RSW1-GigabitEthernet0/0/2]un sh
Info: Interface GigabitEthernet0/0/2 is not shutdown.
[RSW1-GigabitEthernet0/0/2]int g0/0/1
[RSW1-GigabitEthernet0/0/1]port link-type access
[RSW1-GigabitEthernet0/0/1]port default vlan 100
[RSW1-GigabitEthernet0/0/1]un sh
Info: Interface GigabitEthernet0/0/1 is not shutdown.
[RSW1-GigabitEthernet0/0/1]dis this
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 100
#
return
[RSW1-GigabitEthernet0/0/1]q
[RSW1]int vlanif10
[RSW1-Vlanif10]ip add 192.168.10.10 24
[RSW1-Vlanif10]vrrp vrid 1 virtual-ip 192.168.10.1
[RSW1-Vlanif10]vrrp vrid 1 priority 120
[RSW1-Vlanif10]vrrp vrid 1 track interface g0/0/1
[RSW1-Vlanif10]vrrp vrid 1 track interface g0/0/2
[RSW1-Vlanif10]dis this
#
interface Vlanif10
 ip address 192.168.10.10 255.255.255.0
 vrrp vrid 1 virtual-ip 192.168.10.1
 vrrp vrid 1 priority 120
 vrrp vrid 1 track interface GigabitEthernet0/0/1
 vrrp vrid 1 track interface GigabitEthernet0/0/2
#
return
[RSW1-Vlanif10]int vlanif 20
[RSW1-Vlanif20]ip add 192.168.20.10 24
[RSW1-Vlanif20]vrrp vrid 2 virtual-ip 192.168.20.1
[RSW1-Vlanif20]vrrp vrid 2 priority 115
[RSW1-Vlanif20]q
[RSW1]int vlanif 100
[RSW1-Vlanif100]ip add 11.0.0.2 30
[RSW1-Vlanif100]q
[RSW1]ip route-static 0.0.0.0 0.0.0.0 11.0.0.1

LSW2:

<Huawei>sys
[Huawei]sysname RSW2
[RSW2]vlan batch 10 20 100
Info: This operation may take a few seconds. Please wait for a moment...done.
[RSW2]int g0/0/2
[RSW2-GigabitEthernet0/0/2]port link-type trunk
[RSW2-GigabitEthernet0/0/2]port trunk allow-pass vlan all
[RSW2-GigabitEthernet0/0/2]un sh
Info: Interface GigabitEthernet0/0/2 is not shutdown.
[RSW2-GigabitEthernet0/0/2]int g0/0/1
[RSW2-GigabitEthernet0/0/1]port link-type access
[RSW2-GigabitEthernet0/0/1]port default vlan 100
[RSW2-GigabitEthernet0/0/1]un sh
Info: Interface GigabitEthernet0/0/1 is not shutdown.
[RSW2-GigabitEthernet0/0/1]int vlanif 10
[RSW2-Vlanif10]ip add 192.168.10.20 24
[RSW2-Vlanif10]vrrp vrid 1 virtual-ip 192.168.10.1
[RSW2-Vlanif10]vrrp vrid 1 priority 115
[RSW2-Vlanif10]int vlanif 20
[RSW2-Vlanif20]ip add 192.168.20.20 24
[RSW2-Vlanif20]vrrp vrid 2 virtual-ip 192.168.20.1
[RSW2-Vlanif20]vrrp vrid 2 priority 120
[RSW2-Vlanif20]vrrp vrid 2 track interface g0/0/1
[RSW2-Vlanif20]vrrp vrid 2 track interface g0/0/2
[RSW2-Vlanif20]q
[RSW2]int vlanif 100
[RSW2-Vlanif100]ip add 12.0.0.2 30
[RSW2-Vlanif100]q
[RSW2]ip route-static 0.0.0.0 0.0.0.0 12.0.0.1

R1:

<Huawei>sys
Enter system view, return user view with Ctrl+Z.
[Huawei]sys R1
[R1]int g 0/0/0
[R1-GigabitEthernet0/0/0]ip add 11.0.0.1 30
[R1-GigabitEthernet0/0/0]un sh
Info: Interface GigabitEthernet0/0/0 is not shutdown.
[R1-GigabitEthernet0/0/0]int g 0/0/1
[R1-GigabitEthernet0/0/1]ip add 12.0.0.1 30
[R1-GigabitEthernet0/0/1]un sh
Info: Interface GigabitEthernet0/0/1 is not shutdown.
[R1-GigabitEthernet0/0/0]int loo 0
[R1-LoopBack0]ip add 1.1.1.1 24
[R1-LoopBack0]q
[R1]ip route-static 192.168.10.0 24 11.0.0.2
[R1]ip route-static 192.168.10.0 24 12.0.0.2 preference 70
[R1]ip route-static 192.168.20.0 24 12.0.0.2
[R1]ip route-static 192.168.20.0 24 11.0.0.2 preference 70

验证:

此时试验成功,谢谢观看!

原文地址:https://blog.51cto.com/14464303/2448410

时间: 2024-09-27 17:23:48

华为VRRP浮动路由配置实战的相关文章

【基础】华为设备浮动路由配置实战

一.实验拓扑 使用ENSP模拟器(版本V100R002C00 1.2.00.350)                               二.实验需求: 实现当一条链路出现问题,另一条链路自动出现代替原来链路,起到备份作用 三.实验步骤: 1.Ip规划: R1的g0/0/2的ip地址是202.106.14.1 30 R 4的g0/0/2的ip地址是202.106.14.2 30 R4的g0/0/1的ip地址是202.106.34.2 30 R3的g0/0/1的ip地址是202.106.3

华为设备VRRP浮动路由实战

华为设备浮动路由实战 实验拓扑 sw3 <Huawei>sys Enter system view, return user view with Ctrl+Z. [Huawei]sys sw3 [sw3]vlan bat 10 20 [sw3]int e 0/0/1 [sw3-Ethernet0/0/1]p l a #创建access链路 [sw3-Ethernet0/0/1]p d v 10 [sw3-Ethernet0/0/1]un sh Info: Interface Ethernet0

浮动路由配置

实验报告 实验名称:浮动路由 实验拓扑: 实验步骤: 1.  设置PCip地址和默认网关 2.  配置路由器接口ip地址 3.  添加静态路由: 4.  添加接口.配置浮动路由 实验结果: 浮动路由配置

华为单臂路由配置

华为单臂路由配置 拓扑: 实现步骤: 1 先添加的交换机的vlan [SW1]display this sysname SW1 vlan batch 10 20 [SW2] vlan batch 10 20 2 进入交换机 接口配置接口所属vlan: [SW1: interface Ethernet0/0/10 port link-type access port default vlan 10 # interface Ethernet0/0/20 port link-type access p

企业浮动路由配置实例

浮动路由配置实验:企业浮动路由可以增加企业网络的可靠性,当一条线路出现故障时,隐藏的浮动路由便会出现在路由条目中,保证网络的可靠性.如上图所示R1上配置如下:[R1]interface g0/0/1 [R1-GigabitEthernet0/0/1]ip address 192.168.2.1 24[R1]interface g0/0/2 [R1-GigabitEthernet0/0/2]ip address 192.168.3.1 24[R1]interface g0/0/0 [R1-Giga

华为VRRP和浮动路由配置与应用

VRRP:虚拟 路由器 冗余 协议virtual router redundancy protocol VRRP :(公有协议)在多个路由器之间运行,可以虚拟出一个或者多个网关IP地址(虚拟路由器):从而实现内网不同网段之间的互通: VRRP的工作过程:1.运行VRRP的"多个"路由器之间通过 VRRP 报文的交互,从而选择出一个最牛的路由器,作为 Master 路由器 ,以后就用来这个设备来转发数据包:2.Master 路由器,仅仅只有一个:其他的路由器称之为 backup 路由器:

【中级】华为设备IS-IS协议配置实战

实验拓扑: 使用ENSP模拟器(版本V100R002C00 1.2.00.350) 实验要求: 1.通过IS-IS协议实现全网互通. 2.配置域间路由汇总. 3.配置不同协议间路由汇总. 4.配置IS-IS级别1和级别2之间路由重分发. 5.调整IS-IS的cost值. IS-IS基本原理: 1.IS-IS是链路状态路由协议,使用SPF算法计算出到达目的网络的最优路径生成路由表. 2.使用Hello包建立邻居关系,使用LSP交换链路状态信息,采用分层设计. 3.有两种路由选择级别,L1和L2,L

华为eNSP浮动路由实现不同vlan之间的通信

实验要求:为两个路由器之间配置浮动路由,两台主机互通AR9<Huawei>undo terminal monitor #关闭提示信息Info: Current terminal monitor is off.<Huawei>sys #进入系统视图Enter system view, return user view with Ctrl+Z.[Huawei]int g0/0/0 #进入端口视图[Huawei-GigabitEthernet0/0/0]ip add 192.168.1.

华为IPv4静态路由配置示例

IPv4静态路由配置示例 组网需求 如图1所示,属于不同网段的主机通过几台Switch相连,要求不配置动态路由协议,使不同网段的任意两台主机之间能够互通. 图1 配置IP静态路由组网图 配置思路 采用如下的思路配置IPv4静态路由: 创建VLAN并配置各接口所属VLAN,配置各VLANIF接口的IP地址,实现相邻设备网络互通. 在各主机上配置IP缺省网关,在各台Switch上配置IPv4静态路由或者静态缺省路由,实现不配置动态路由协议,使不同网段的任意两台主机之间能够互通. 操作步骤 1.配置各