hdu3746

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6861    Accepted Submission(s): 2987

Problem Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl‘s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls‘ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet‘s cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a‘ ~‘z‘ characters. The length of the string Len: ( 3 <= Len <= 100000 ).

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input

3
aaa
abca
abcde

Sample Output

0
2
5

Author

possessor WC

Source

HDU 3rd “Vegetable-Birds Cup” Programming Open Contest

Recommend

lcy   |   We have carefully selected several similar problems for you:  1358 1686 1711 2222 2087

题意:

求至少添加几个字符使其成为回文串;

误解:

读到这里,千万不要马上开始写manacher,没有半毛钱关系

正解:

kmp求出next数组根据len-next[len]的关系,直接算答案就好了

AC代码:

#include<cstdio>
#include<cstring>
using namespace std;
#define N 200010
char s[N];
int T,len,Next[N];
void get_next(){
    int i=0,j=-1;
    Next[i]=j;
    while(i<len){
        if(j==-1||s[i]==s[j]){
            i++;j++;
            Next[i]=j;
        }
        else j=Next[j];
    }
}
int main(){
    scanf("%d",&T);
    while(T--){
        scanf("%s",s);
        len=strlen(s);
        get_next();
        int t=len-Next[len];
        if(t==len) printf("%d\n",len);
        else if(len%t) printf("%d\n",t-len%t);
        else printf("0\n");
    }
    return 0;
}
时间: 2024-10-06 16:25:56

hdu3746的相关文章

HDU3746 Cyclic Nacklace 【KMP】

Cyclic Nacklace Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2538    Accepted Submission(s): 1154 Problem Description CC always becomes very depressed at the end of this month, he has checke

HDU3746 Cyclic Nacklace

题目链接:https://vjudge.net/problem/HDU-3746 知识点: KMP 解题思路: 论如何用 \(Next[]\) 数组求循环节. AC代码: 1 #include <bits/stdc++.h> 2 3 using namespace std; 4 const int maxn = 100000+5; 5 char inp[maxn]; 6 int Next[maxn]; 7 void init(int plen){ 8 memset(Next,0,sizeof(

HDU3746 Cyclic Nacklace KMP求循环节

HDU3746给定一个字符串,求:在该字符串末尾最少补充多少个字符,可以使得这个字符串获得周期性. 周期性指存在一个子串,使得该字符串可以正好分解成若干个这个子串(数量要大于1). Input 第一行是一个整数 T ( 0<T<=100 ) 代表测试数据的组数. 之后T行每行一个字符串,由小写字母组成,字符串的长度3<=L<=100000. Output 每组数据输出一行结果. Sample Input 3 AAA ABCA ABCDE Sample Output 0 2 5 本题

D - Cyclic Nacklace HDU3746 (kmp 计算字符串最小循环节 )

D - Cyclic Nacklace Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u Submit Status Description CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are on

D - Cyclic Nacklace HDU-3746

题目大意: 给一个t,接下来每个t,给一个串,求出最小循环节下还要增加多少个珠子才完美.(要是都没啥循环节,就输出长度) 解题思路: 求出最小循环节 cir:cir=len - next[len] (关于为什么是这个式子详见<KMP 专题知识>),然后拿len%cir得到的余数就是已经有的,那么拿循环节再减掉有的,就是需要增加的.即:cir-len%cir.如果len%cir == 0,而且cir!=len,就意味着一颗都不用增加,因为此时已经是完美的循环了,但是要是cir==len,就说明没

hdu3746 kmp求循环节

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the en

hdu-3746 Cyclic Nacklace 【kmp】

Cyclic Nacklace Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3253    Accepted Submission(s): 1488 Problem Description CC always becomes very depressed at the end of this month, he has checke

Cyclic Nacklace ---hdu3746(循环节,kmp)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3746 给你一个字符串,让你在后面加尽量少的字符,使得这个字符串成为一个重复串. abca---添加bc,成为abcabc abcd---添加abcd,成为abcdabcd aa---无需添加 经典的求最小循环节. 首先给出结论:一个字符串的最小循环节为:len-next[len] #include<stdio.h> #include<iostream> #include<algo

hdu3746 Cyclic Nacklace(kmp周期问题)

题目链接:点击打开链接 题意描述:给定一个字符串,求使这个字符串是循环字符串至少需要添加多少个字符?要求循环至少两次 解题思路:kmp(next[]数组性质:点击打开链接) 根据next[]数组的性质我们可以得到一个字符串最小循环节为n-next[n],所以我们可以得出结论 if((n%(n-next[n])==0)&&(n/(n-next[n])>1)) printf("0\n"); else printf("%d\n",n-next[n]-