poj3083 Children of the Candy Cor

Description

The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit.

One popular maze-walking strategy guarantees that the visitor will eventually find the exit. Simply choose either the right or left wall, and follow it. Of course, there‘s no guarantee which strategy (left or right) will be better, and the path taken is seldom
the most efficient. (It also doesn‘t work on mazes with exits that are not on the edge; those types of mazes are not represented in this problem.)

As the proprieter of a cornfield that is about to be converted into a maze, you‘d like to have a computer program that can determine the left and right-hand paths along with the shortest path so that you can figure out which layout has the best chance of confounding
visitors.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of mazes. Each maze will consist of one line with a width, w, and height, h (3 <= w, h <= 40), followed by h lines of w characters each that represent the maze
layout. Walls are represented by hash marks (‘#‘), empty space by periods (‘.‘), the start by an ‘S‘ and the exit by an ‘E‘.

Exactly one ‘S‘ and one ‘E‘ will be present in the maze, and they will always be located along one of the maze edges and never in a corner. The maze will be fully enclosed by walls (‘#‘), with the only openings being the ‘S‘ and ‘E‘. The ‘S‘ and ‘E‘ will also
be separated by at least one wall (‘#‘).

You may assume that the maze exit is always reachable from the start point.

Output

For each maze in the input, output on a single line the number of (not necessarily unique) squares that a person would visit (including the ‘S‘ and ‘E‘) for (in order) the left, right, and shortest paths, separated by a single space each. Movement from one
square to another is only allowed in the horizontal or vertical direction; movement along the diagonals is not allowed.

Sample Input

2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########

Sample Output

37 5 5
17 17 9
这道题求最短路可以用bfs,但是求绕墙走的时间时不用搜索,因为一定只有唯一的一条路,绕墙走有优先考虑左边和右边两种情况,考虑左边的时候,如果能往左走就往做,否则再考虑能不能向前走,即按原来的方向,如果也不行,再看能不能往右走,如果三种情况都不行,就往后走,这里要开一个数组记录方向。
#include<stdio.h>
#include<string.h>
#include<math.h>
char map[45][45];
int tab[8][2]={0,0,0,1,-1,0,0,-1,1,0},dir,b[45][45];
int q[1111111][2],x3,y3,x2,y2,n,m;

void bfs()
{
	memset(q,0,sizeof(q));
	memset(b,0,sizeof(b));
	b[x2][y2]=1;
	int front=1,rear=1,xx,yy,i,x,y;
	q[front][0]=x2;q[front][1]=y2;
	while(front<=rear){
		x=q[front][0];
		y=q[front][1];
		if(x==x3 && y==y3)break;
		front++;
		for(i=1;i<=4;i++){
			xx=x+tab[i][0];yy=y+tab[i][1];
			if(xx>=0 && xx<m && yy>=0 && yy<n && map[xx][yy]!=‘#‘){
				map[xx][yy]=‘#‘;
				b[xx][yy]=b[x][y]+1;
				rear++;
				q[rear][0]=xx;
				q[rear][1]=yy;
			}
		}
	}
	return ;
}

int main()
{
	int T,i,j,num1,num2,num3,x,y,dir1,xx,yy,dir2;
	scanf("%d",&T);
	while(T--)
    {
    	scanf("%d%d",&n,&m);
    	for(i=0;i<m;i++){
	    	scanf("%s",map[i]);
	    	for(j=0;j<n;j++){
	    		if(map[i][j]==‘S‘){
		    		x2=i;y2=j;
		    	}
		    	else if(map[i][j]==‘E‘){
	    			x3=i;y3=j;
	    		}
	    	}
	    }
	    if(y2==1)dir=1;
	    else if(x2==m)dir=2;
	    else if(y2==n)dir=3;
	    else if(x2==1)dir=4;
	    num1=0;
	    
	    
	    memset(b,0,sizeof(b));
	    x=x2,y=y2,num1=1,dir1=dir;
	    while(1)
	    {
			if(x==x3 && y==y3)break;
			num1++;
			//printf("%d %d\n",x+1,y+1);
    		xx=x+tab[dir1%4+1][0];
    		yy=y+tab[dir1%4+1][1];
			if(xx>=0 && xx<m && yy>=0 && yy<n && map[xx][yy]!=‘#‘){
    			x=xx;y=yy;
				dir1=dir1%4+1;continue;
		    }
		    
		    xx=x+tab[dir1][0];
		    yy=y+tab[dir1][1];
		    if(xx>=0 && xx<m && yy>=0 && yy<n && map[xx][yy]!=‘#‘){
    			x=xx;y=yy;continue;
    		}
   
    		xx=x+tab[(dir1==1)?4:(dir1-1)][0];
    		yy=y+tab[(dir1==1)?4:(dir1-1)][1];
    		if(xx>=0 && xx<m && yy>=0 && yy<n && map[xx][yy]!=‘#‘){
    			x=xx;y=yy;
				dir1=(dir1==1?4:(dir1-1));continue;
		    }
		    
		    
		    dir1=(dir1+1)%4+1;
		    x=x+tab[dir1][0];
		    y=y+tab[dir1][1];
		    
    	}
    	//printf("%d\n",num1);
   
    	memset(b,0,sizeof(b));
	    x=x2,y=y2,num2=1,dir2=dir;
	    while(1)
	    {
   
			if(x==x3 && y==y3)break;
			num2++;
			//printf("%d %d\n",x+1,y+1);

			xx=x+tab[(dir2==1)?4:(dir2-1)][0];
    		yy=y+tab[(dir2==1)?4:(dir2-1)][1];
    		if(xx>=0 && xx<m && yy>=0 && yy<n && map[xx][yy]!=‘#‘){
    			x=xx;y=yy;
				dir2=(dir2==1?4:(dir2-1));continue;
		    }
		    
    		xx=x+tab[dir2][0];
		    yy=y+tab[dir2][1];
		    if(xx>=0 && xx<m && yy>=0 && yy<n && map[xx][yy]!=‘#‘){
    			x=xx;y=yy;continue;
    		}
		    
			xx=x+tab[dir2%4+1][0];
    		yy=y+tab[dir2%4+1][1];
			if(xx>=0 && xx<m && yy>=0 && yy<n && map[xx][yy]!=‘#‘){
    			x=xx;y=yy;
				dir2=dir2%4+1;continue;
		    }
		    dir2=(dir2+1)%4+1;
		    x=x+tab[dir2][0];
		    y=y+tab[dir2][1];
		    
    	}
    	map[x2][y2]=‘#‘;
	    bfs();
	    num3=b[x3][y3];
	    printf("%d %d %d\n",num1,num2,num3);
    }
    return 0;
}
时间: 2024-08-26 08:00:38

poj3083 Children of the Candy Cor的相关文章

POJ3083——Children of the Candy Corn

Children of the Candy Corn DescriptionThe cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find t

poj3083 Children of the Candy Corn BFS&amp;&amp;DFS

Children of the Candy Corn Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 11215   Accepted: 4841 Description The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombie

dfs/poj3083 Children of the Candy Corn

1 #include<cstdio> 2 #include<cstring> 3 #include<queue> 4 5 using namespace std; 6 typedef pair<int,int>P; 7 const int dx[4]={1,0,-1,0}; 8 const int dy[4]={0,1,0,-1}; 9 const int INF=1e9; 10 int sx,sy,ex,ey,n,m; 11 char a[50][50];

poj3083 Children of the Candy Corn

这道题有深搜和广搜.深搜还有要求,靠左或靠右.下面以靠左为例,可以把简单分为上北,下南,左西,右东四个方向.向东就是横坐标i不变,纵坐标j加1(i与j其实就是下标).其他方向也可以这样确定.通过上一步方向可以确定下一步应该从哪个方向开始搜.比如说,是向北走的,就必须先搜西,西不可以走,再搜北,如果北还不可以走,再搜东,最后才是南.其他方向的情况也可以这样推出来.最后走到E点完成了.广搜就是最基础的广搜.这道题做了将近10个小时.中途曾几次准备放弃,但最后还是坚持做完了. #include<ios

POJ-3083 Children of the Candy Corn (BFS+DFS)

Description The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit. One popular maze-

POJ 3083 Children of the Candy Corn

Children of the Candy Corn Time Limit: 1000ms Memory Limit: 65536KB This problem will be judged on PKU. Original ID: 308364-bit integer IO format: %lld      Java class name: Main The cornfield maze is a popular Halloween treat. Visitors are shown the

K - Children of the Candy Corn

K - Children of the Candy Corn Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Description The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze fa

POJ 3083:Children of the Candy Corn(DFS+BFS)

Children of the Candy Corn Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 9311 Accepted: 4039 Description The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, ch

【POJ 3083】Children of the Candy Corn

POJ[3083]Children of the Candy Corn Dfs+Bfs 分别求沿左墙到达E 沿右墙到达E 还有S到E的最短步数 前两个Dfs实现 最后一个Bfs 耐心写很容易A 主要注意方向问题 dir四个方向 上右下左 刚开始我分别用下标0 1 2 3代表 开dirx diry两个移动数组 假设前一状态朝向0(上) 沿左墙移动即为3 0 1 2(左上右下<顺时针>) 沿右墙即为1 0 3 2(右上左下<逆时针>) 同理其余方向很容易遍历 略自豪的是不断精简代码从6