Problem Description
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.
There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word acm‘‘ can be followed by the word
motorola”. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will appear in the word. The same word may appear several times in the list.
Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence “Ordering is possible.”. Otherwise, output the sentence “The door cannot be opened.”.
Sample Input
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok
Sample Output
The door cannot be opened.
Ordering is possible.
The door cannot be opened.
题意:就不多说了,就是欧拉回路;
不过本题还是有点区别,因为这个题如果拿节点做,你会发现节点最多只有26个,爽!
所以本题可以这样:
欧拉回路和欧拉通路的判定可以总结为如下:
1)所有的点联通
2)欧拉回路中所有点的入度和出度一样。
3)欧拉通路中起点的入度 - 出度 = 1,终点的 初度 - 入度 = 1, 其他的所有点入度 = 出度;
无向图存在欧拉回路条件
一个无向图存在欧拉回路,当且仅当该图所有顶点度数都是偶数。
有向图存在欧拉回路条件
一个有向图存在欧拉回路,且所有顶点的入度等于出度
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=30;
char str[1005];
int out[maxn],in[maxn],f[maxn];
int vis[maxn],p[maxn];
int find(int x)
{
if(f[x]!=x)
f[x]=find(f[x]);
return f[x];
}
void merger(int x,int y)
{
int a=find(x);
int b=find(y);
if(a!=b)f[a]=b;
}
int main()
{
int t,i,j;
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
getchar();
memset(vis,0,sizeof(vis));
memset(in,0,sizeof(in));
memset(out,0,sizeof(out));
for(i=0;i<26;i++)
{
f[i]=i;
}
while(n--)
{
scanf("%s",str);
int len=strlen(str);
int u=str[0]-‘a‘;
int v=str[len-1]-‘a‘;
merger(u,v);
in[v]++;
out[u]++;
vis[u]=vis[v]=1;
}
int cnt=0;
for(i=0;i<26;i++)
f[i]=find(i);
for(i=0;i<26;i++)
{
if(vis[i]&&f[i]==i)
{
cnt++;
}
}
if(cnt>1) //图是否连通
{
printf("The door cannot be opened.\n");
// printf("hehe\n");
continue;
}
cnt=0;
for(i=0;i<26;i++)
if(vis[i]&&out[i]!=in[i])
{
p[cnt++]=i;
}
if(cnt==0)
{
printf("Ordering is possible.\n");
continue;
}
if(cnt==2)
{
if(out[p[0]]-in[p[0]]==1&&in[p[1]]-out[p[1]]==1||in[p[0]]-out[p[0]]==1&&out[p[1]]-in[p[1]]==1)
{
printf("Ordering is possible.\n");
continue;
}
}
printf("The door cannot be opened.\n");
}
return 0;
}