uva 315 Network(连通图求割点)

https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=251

 Network 

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N. No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at mostN lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0.

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

Sample Output

1
2

题目大意:

给你一个无向图,求其中割点的个数目。

输入数据

第一行一个 n 代表有 n 个点

接下来有多行,一直到读入一个 0,算整个地图的读入结束,再读入一个0,文件数据结束。

每行有第一个数字a,代表接下来的数字都 和 a 相连。

割点:无向连通图中,如果删除某点后,图变成不连通了,则称该点为割点。

这里割点 和 桥 都是无向图里的概念,大家在这里不要混淆了。

求割点

一个顶点u是割点,当且仅当满足(1)或(2)

(1) u为树根,且u有多于一个子树。

即代码中rootson >1

(2) u不为树根,且满足存在(u,v)为树枝边(或称 父子边,即u为v在搜索树中的父亲),使得 dfn(u)<=low(v)。(也就是说 V 没办法绕过 u 点到达比 u dfn要小的点)   即代码中  if(dfn[v] <= low[i])   Cut[i] = true;

注:这里所说的树是指,DFS下的搜索树。

求割点 Tarjan里 low  和  dfn

dfn[u]定义和前面类似,但是low[u]定义为u

或者u的子树中能够通过非父子边追溯到的

最早的节点的DFS开始时间

在Tarjan算法求割点我们要加一个数组 f[u], 判断两者是否是父子边

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<vector>
#define N 110
#define min(a, b)(a < b ? a : b)

using namespace std;

vector<vector<int> >G;
int low[N], dfn[N], f[N];
int n, Time, num;
bool Cut[N];

void Init()
{
    G.clear();
    G.resize(n + 1);
    memset(low, 0, sizeof(low));//最先到达该点的时间
    memset(dfn, 0, sizeof(dfn));//该点能到达之前点的最早时间
    memset(f, 0, sizeof(f));//保存一个点的父节点
    memset(Cut, false, sizeof(Cut));//判断该是否为割点
    Time = num = 0;
}

void Tarjan(int u, int fa)
{
    int len, v, i;
    low[u] = dfn[u] = ++Time;
    f[u] = fa;
    len = G[u].size();
    for(i = 0 ; i < len ; i++)
    {
        v = G[u][i];
        if(!dfn[v])
        {
            Tarjan(v, u);
            low[u] = min(low[u], low[v]);
        }
        else if(fa != v)
            low[u] = min(low[u], dfn[v]);
    }
}

void Solve()
{
    int rootson = 0, i, v;
    Tarjan(1, 0);
    for(i = 2 ; i<= n ; i++)
    {
        v = f[i];
        if(v == 1)//i的父节点为根节点
            rootson++;//子树
        else if(dfn[v] <= low[i])
            Cut[v] = true;
    }
    for(i = 2 ; i <= n ; i++)
        if(Cut[i])
            num++;
    if(rootson > 1)
        num++;
}

int main()
{
    int a, b;
    char ch;
    while(scanf("%d", &n), n)
    {
        Init();
        while(scanf("%d", &a), a)
        {
            while(scanf("%d%c", &b, &ch))
            {
                G[a].push_back(b);
                G[b].push_back(a);
                if(ch == ‘\n‘)
                    break;
            }
        }
        Solve();
        printf("%d\n", num);
    }
    return 0;
}
时间: 2024-08-02 23:06:42

uva 315 Network(连通图求割点)的相关文章

POJ 1144 &amp; Uva 315 Network 【求割点数目】

Network Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 10855   Accepted: 5020 链接:http://poj.org/problem?id=1144 Description A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places

UVA 315 Network

Description: A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N. No two places have the same number. The lines are bidirectional and always connect togethe

UVA 315 Network(无向图求割点)

题目大意 A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N. No two places have the same number. The lines are bidirectional and always connect together two pl

UVA - 315 Network(tarjan求割点的个数)

题目链接:https://vjudge.net/contest/67418#problem/B 题意:给一个无向连通图,求出割点的数量.首先输入一个N(多实例,0结束),下面有不超过N行的数,每行的第一个数字代表后面的都和它存在边,0表示行输入的结束. 题解:简单的求割点模版,所谓割点就是去掉这一个点还有于这个点链接的边之后使得原来的图连通块增加. 由于这是模版题代码会加上注释. #include <iostream> #include <cstring> using namesp

UVA - 315 Network 和 UVA - 10199 (求割顶)

链接 :  http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=20837 http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=21278 求割顶的裸题. UVA - 315 #include <algorithm> #include <iostream> #include <sstream> #include <cstrin

B - Network---UVA 315(无向图求割点)

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N. No two places have the same number. The lines are bidirectional and always connect together two places

poj 1144 Network 无向图求割点

Network Description A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect

无向图求割点 UVA 315 Network

输入数据处理正确其余的就是套强联通的模板了 #include <iostream> #include <cstdlib> #include <cstdio> #include <algorithm> #include <vector> #include <queue> #include <cmath> #include <stack> #include <cstring> using namespa

Network -UVa315(连通图求割点)

https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=5&page=show_problem&problem=251  Network  A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbe