POJ 2777-Count Color(线段树_区间染色)

Count Color

Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Submit Status Practice POJ
2777

Appoint description: 
System Crawler  (2015-04-10)

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment
with only one color. We can do following two operations on the board:

1. "C A B C" Color the board from segment A to segment B with color C.

2. "P A B" Output the number of different colors painted between segment A and segment B (including).

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the
beginning, the board was painted in color 1. Now the rest of problem is left to your.

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation
defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

利用二进制表示颜色。T只有30种,所以妥妥的。

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
using namespace std;
typedef long long LL;
const int inf=0x3f3f3f3f;
const double pi= acos(-1.0);
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
const int MAXN=100010;
int sum[MAXN<<3];
int lazy[MAXN<<3];
void PushUp(int rt)
{
    sum[rt]=sum[rt<<1]|sum[rt<<1|1];
}

void PushDown(int rt)
{
    if(lazy[rt]) {
        lazy[rt<<1]=lazy[rt];
        lazy[rt<<1|1]=lazy[rt];
        sum[rt<<1]=lazy[rt];
        sum[rt<<1|1]=lazy[rt];
        lazy[rt]=0;
    }
}

void Update(int ll, int rr, int x, int l, int r, int rt)
{
    if(ll<=l&&rr>=r) {
        sum[rt]=x;
        lazy[rt]=x;
        return ;
    }
    PushDown(rt);
    int mid=l+r>>1;
    if(ll<=mid)
        Update(ll,rr,x,lson);
    if(rr>mid)
        Update(ll,rr,x,rson);
    PushUp(rt);
}
int Query(int ll, int rr, int l, int r, int rt)
{
    if(ll<=l&&rr>=r) {
        return sum[rt];
    }
    PushDown(rt);
    int ans=0;
    int mid=l+r>>1;
    if(ll<=mid)
        ans=ans|Query(ll,rr,lson);
    if(rr>mid)
        ans=ans|Query(ll,rr,rson);
    return ans;
}
int get(int x)
{
    int ans=0;
    int y;
    while(x) {
        y=x%2;
        if(y)
            ans++;
        x/=2;
    }
    return ans;
}
int main()
{
    int n, i,t, q;
    int a,b,c;
    char ch;
    scanf("%d %d %d",&n,&t,&q);
    memset(lazy,0,sizeof(lazy));
    for(i=1; i<=4*n; i++) {
        sum[i]=1;
    }
    while(q--) {
        getchar();
        scanf("%c",&ch);
        if(ch=='C') {
            scanf("%d %d %d",&a,&b,&c);
            if(a>b)
                swap(a,b);
            Update(a,b,1<<(c-1),1,n,1);
        } else {
            scanf("%d %d",&a,&b);
            if(a>b)
                swap(a,b);
            int ans=get(Query(a,b,1,n,1));
            printf("%d\n",ans);
        }
    }
    return 0;
}
时间: 2024-11-08 23:09:32

POJ 2777-Count Color(线段树_区间染色)的相关文章

POJ 2777 Count Color(线段树)

题目地址:POJ 2777 我去..延迟标记写错了.标记到了叶子节点上....这根本就没延迟嘛...怪不得一直TLE... 这题就是利用二进制来标记颜色的种类.然后利用或|这个符号来统计每个区间不同颜色种数. 代码如下: #include <iostream> #include <cstdio> #include <string> #include <cstring> #include <stdlib.h> #include <math.h

POJ 2777 Count Color (线段树+位运算)

题意很简单了,对一个区间有两种操作: 1. "C A B C" Color the board from segment A to segment B with color C. //A~B涂上颜色C 2. "P A B" Output the number of different colors painted between segment A and segment B (including). //输出A~B间颜色的种类数 题目链接:http://poj.o

poj 2777 Count Color(线段树、状态压缩、位运算)

Count Color Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 38921   Accepted: 11696 Description Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

POJ 2777 Count Color (线段树成段更新+二进制思维)

题目链接:http://poj.org/problem?id=2777 题意是有L个单位长的画板,T种颜色,O个操作.画板初始化为颜色1.操作C讲l到r单位之间的颜色变为c,操作P查询l到r单位之间的颜色有几种. 很明显的线段树成段更新,但是查询却不好弄.经过提醒,发现颜色的种类最多不超过30种,所以我们用二进制的思维解决这个问题,颜色1可以用二进制的1表示,同理,颜色2用二进制的10表示,3用100,....假设有一个区间有颜色2和颜色3,那么区间的值为二进制的110(十进制为6).那我们就把

POJ 2777 count color(线段树,lazy标记)

这里有一个思想:我们在更新的时候不必要更新到叶子节点,只要更新到当前区间包含线段树区间即可. 设计一个标志位,更新到此. A Simple Problem with Integers 也是一个类似的题目 设计两个函数 push_down 将结点信息传递到下层节点(inc, sub,) push_up      将下层节点信息反馈到上层(max,min,count) #include <map> #include <set> #include <queue> #inclu

poj 2777 count color 线段树

Description Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. There is a very long board with length L centimeter, L is a positive integer, so we can evenly d

POJ P2777 Count Color——线段树状态压缩

Description Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. There is a very long board with length L centimeter, L is a positive integer, so we can evenly d

poj 2777 Count Color (成段更新+区间求和)

Count Color Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 36646   Accepted: 11053 Description Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

POJ 2777 Count Color (线段树区间更新加查询)

Description Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. There is a very long board with length L centimeter, L is a positive integer, so we can evenly d