POJ - 1679 The Unique MST (次小生成树)

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V‘, E‘), with the following properties:

1. V‘ = V.

2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E‘) of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all
the edges in E‘.

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the
following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string ‘Not Unique!‘.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

题意:求最小生成树是否唯一

思路:次小生成树的应用,先求出最小生成树,然后枚举删除的边,再求最小生成树,如果值一样,代表不唯一

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <vector>
using namespace std;
const int maxn = 105;
const int inf = 0x3f3f3f3f;

struct Edge {
	int from, to, dist;
} edge[maxn*maxn];
int n, m;
int mst, fa[maxn];
int uni;

int cmp(Edge a, Edge b) {
	return a.dist < b.dist;
}

int find(int x) {
	if (x != fa[x])
		fa[x] = find(fa[x]);
	return fa[x];
}

void init() {
	for (int i = 1; i <= n; i++)
		fa[i] = i;
}

void kruskal(){
	int num[maxn], cnt = 0;
	init();
	sort(edge, edge+m, cmp);
	mst = 0;
	for (int i = 0; i < m; i++) {
		int x = find(edge[i].from);
		int y = find(edge[i].to);
		if (x != y) {
			fa[y] = x;
			mst += edge[i].dist;
			num[cnt++] = i;
		}
	}
	uni = 1;
	int ans, tmp;
	for (int k = 0; k < cnt; k++) {
		init();
		ans = 0;
		tmp = 0;
		for (int i = 0; i < m; i++) {
			if (i == num[k])
				continue;
			int x = find(edge[i].from);
			int y = find(edge[i].to);
			if (x != y) {
				fa[y] = x;
				ans += edge[i].dist;
				tmp++;
			}
		}
		if (tmp != cnt)
			continue;
		if (ans == mst) {
			uni = 0;
			return;
		}
	}
}

int main() {
	int t, i, j;
	scanf("%d", &t);
	while(t --){
		scanf("%d%d", &n, &m);
		for(i = 0; i < m; i ++)
			scanf("%d%d%d", &edge[i].from, &edge[i].to, &edge[i].dist);
		kruskal();
		if(!uni)
			printf("Not Unique!\n");
		else printf("%d\n", mst);
	}
	return 0;
}

POJ - 1679 The Unique MST (次小生成树),布布扣,bubuko.com

时间: 2024-11-06 16:21:47

POJ - 1679 The Unique MST (次小生成树)的相关文章

poj 1679 The Unique MST (次小生成树)

The Unique MST Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 20293   Accepted: 7124 Description Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spanning Tree): Consider a connected, undire

poj 1679 The Unique MST (次小生成树(sec_mst)【kruskal】)

The Unique MST Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 35999   Accepted: 13145 Description Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spanning Tree): Consider a connected, undir

POJ - 1679 The Unique MST(次小生成树)

版权声明:本文为博主原创文章,未经博主允许不得转载.

hdu 1679 The Unique MST 次小生成树 简单题

The Unique MST Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 21737   Accepted: 7692 Description Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spanning Tree): Consider a connected, undire

poj 1679 The Unique MST 【次小生成树】【模板】

题目:poj 1679 The Unique MST 题意:给你一颗树,让你求最小生成树和次小生成树值是否相等. 分析:这个题目关键在于求解次小生成树. 方法是,依次枚举不在最小生成树上的边,然后添加到最小生成树上,然后把原树上添加了之后形成环的最长的边删去,知道一个最小的.就是次小生成树. 这些需要的都可以在求解最小生成树的时候处理出来. AC代码: #include <cstdio> #include <cstring> #include <iostream> #i

poj 1679 The Unique MST (判断最小生成树是否唯一)

The Unique MST Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 20679   Accepted: 7255 Description Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spanning Tree): Consider a connected, undire

POJ 1679 The Unique MST(求最小生成树是否唯一)

The Unique MST Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 20430   Accepted: 7186 Description Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spanning Tree): Consider a connected, undire

POJ 1679 The Unique MST 【最小生成树/次小生成树】

The Unique MST Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 22668   Accepted: 8038 Description Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spanning Tree): Consider a connected, undire

poj 1679 The Unique MST (判定最小生成树是否唯一)

题目链接:http://poj.org/problem?id=1679 The Unique MST Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 29408   Accepted: 10520 Description Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spannin