HDOJ 1297 Children’s Queue

JAVA大数....

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 10390    Accepted Submission(s): 3333

Problem Description

There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side.
The case n=4 (n is the number of children) is like

FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM

Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?

Input

There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)

Output

For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.

Sample Input

1
2
3

Sample Output

1
2
4

Author

SmallBeer (CML)

Source

杭电ACM集训队训练赛(VIII)

import java.util.*;
import java.math.*;

public class Main
{
	public static void main(String[] args)
	{
		Scanner cin=new Scanner(System.in);

		BigInteger[] a=new BigInteger[1100];
		a[1]=BigInteger.valueOf(1);
		a[2]=BigInteger.valueOf(2);
		a[3]=BigInteger.valueOf(4);
		a[4]=BigInteger.valueOf(7);
		for(int i=5;i<=1000;i++)
		{
			a[i]=a[i-4].add(a[i-2].add(a[i-1]));
		}

		while(cin.hasNextInt())
		{
			int n=cin.nextInt();
			System.out.println(a[n]);
		}
	}
}

HDOJ 1297 Children’s Queue,布布扣,bubuko.com

时间: 2024-08-06 16:06:19

HDOJ 1297 Children’s Queue的相关文章

hdoj 1297 Children’s Queue 【高精度】【递推】

题意:有n个人,每一个人可以是男孩也可以是女孩,要求每个女孩不能单独一个,也就是一个女孩的左右紧挨的位置至少要有一个女孩.问这样的队列有几个. 分析:设f(n)是n的排列的数目,这时候来一个人: 一:如果是男孩,那么f(n ) = f(n-1) 二:如果是女孩,如果前n-2是合法的,那么f(n) = f(n-2):如果前n-2不合法的,那么n-2队列的末尾两个同学肯定是男+女,那么再加上后来的女孩,又合法了,此时f(n) = f(n-4); 综上:f(n) = f(n-1)+f(n-2)+f(n

hdu 1297 Children’s Queue

Children's Queue Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 10540    Accepted Submission(s): 3390 Problem Description There are many students in PHT School. One day, the headmaster whose n

HDU 1297 Children’s Queue (递推、大数相加)

Children’s Queue Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 17918    Accepted Submission(s): 5976 Problem Description There are many students in PHT School. One day, the headmaster whose na

HDOJ/HDU 1297 Children’s Queue(推导~大数)

Problem Description There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one

Children’s Queue(递推)

Children's Queue Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 12101    Accepted Submission(s): 3953 Problem Description There are many students in PHT School. One day, the headmaster whose n

Children’s Queue(hdu1297+递推)

Children’s Queue Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 12101 Accepted Submission(s): 3953 Problem Description There are many students in PHT School. One day, the headmaster whose name is

(hdu step 3.1.7)Children’s Queue(求n个人站在一起有m个人必须是连在一起的方案数)

在写题解之前给自己打一下广告哈~..抱歉了,希望大家多多支持我在CSDN的视频课程,地址如下: http://edu.csdn.net/course/detail/209 题目: Children's Queue Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 853 Accepted Submission(s): 479   Problem

(递推 大整数) Children’s Queue hdu1297

Children's Queue Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 16006    Accepted Submission(s): 5337 Problem Description There are many students in PHT School. One day, the headmaster whose n

hdoj 1509 Windows Message Queue(优先队列)

Windows Message Queue 点击打开链接 Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4309 Accepted Submission(s): 1701 Problem Description Message queue is the basic fundamental of windows system. For eac