hdu 1379 DNA Sorting

DNA Sorting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1924    Accepted Submission(s): 949

Problem Description

One measure of ``unsortedness‘‘ in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC‘‘, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG‘‘ has only one inversion (E and D)--it is nearly sorted--while the sequence ``ZWQM‘‘ has 6 inversions (it is as unsorted as can be--exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness‘‘, from ``most sorted‘‘ to ``least sorted‘‘. All the strings are of the same length.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (1 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted‘‘ to ``least sorted‘‘. If two or more strings are equally sorted, list them in the same order they are in the input file.

Sample Input

1

10 6

AACATGAAGG

TTTTGGCCAA

TTTGGCCAAA

GATCAGATTT

CCCGGGGGGA

ATCGATGCAT

Sample Output

CCCGGGGGGA

AACATGAAGG

GATCAGATTT

ATCGATGCAT

TTTTGGCCAA

TTTGGCCAAA

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;

struct DNA
{
    string s;
    int d;
};

int cmp(DNA a,DNA b){
    if(a.d!=b.d)return a.d<b.d;
    else return 0;
}

int main(){

    int t;
    int n,m;
    DNA dna[80];
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        int i,j;
        for(i = 0; i < m; ++i){
            cin>>dna[i].s;
            dna[i].d = 0;
            for(j = 1; j < n; ++j)
            {
                for(int k = 0; k < j ;++k)
                {
                    if(dna[i].s[j] < dna[i].s[k])
                        dna[i].d++;
                }
            }
        }
        sort(dna,dna+m,cmp);
        for(i = 0; i < m; ++i)
            cout<<dna[i].s<<endl;
    }
    return 0;
}

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;

struct DNA
{
    string s;
    int d;
};

int cmp(DNA a,DNA b){
    if(a.d!=b.d)return a.d<b.d;
    else return 0;
}

int main(){
   
    int t;
    int n,m;
    DNA dna[80];
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        int i,j;
        for(i = 0; i < m; ++i){
            cin>>dna[i].s;
            dna[i].d = 0;
            for(j = 1; j < n; ++j)
            {
                for(int k = 0; k < j ;++k)
                {
                    if(dna[i].s[j] < dna[i].s[k])
                        dna[i].d++;
                }
            }
        }
        sort(dna,dna+m,cmp);
        for(i = 0; i < m; ++i)
            cout<<dna[i].s<<endl;
    }
    return 0;
}

hdu 1379 DNA Sorting

时间: 2024-12-09 12:47:12

hdu 1379 DNA Sorting的相关文章

HDU 1379 DNA sorting(求逆序数)

DNA Sorting Problem Description One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater t

hdoj 1379 DNA Sorting

DNA Sorting Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 2231    Accepted Submission(s): 1096 Problem Description One measure of ``unsortedness'' in a sequence is the number of pairs of entr

poj 1007 DNA Sorting (求逆序数)

DNA Sorting Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 83069   Accepted: 33428 Description One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instanc

zju 1188 DNA Sorting

#include<stdio.h> #include<string.h> #include<algorithm> using namespace std; struct node { int a; char s[105]; }p[105]; int cmp(node c,node b) { return c.a<b.a; } int main() { int m,n; int t; scanf("%d",&t); //printf(&q

HDU 1560 DNA sequence(DNA序列)

p.MsoNormal { margin: 0pt; margin-bottom: .0001pt; text-align: justify; font-family: Calibri; font-size: 10.5000pt } h1 { margin-top: 5.0000pt; margin-bottom: 5.0000pt; text-align: center; font-family: 宋体; color: rgb(26,92,200); font-weight: bold; fo

算法:POJ1007 DNA sorting

这题比较简单,重点应该在如何减少循环次数. package practice; import java.io.BufferedInputStream; import java.util.Map; import java.util.Scanner; import java.util.TreeMap; /** * DNA sorting * * @author caiyu * @date 2014-11-5 */ public class POJ1007 { public static void m

DNA Sorting(排序)

欢迎参加——BestCoder周年纪念赛(高质量题目+多重奖励) DNA Sorting Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 2182    Accepted Submission(s): 1062 Problem Description One measure of ``unsortedness'' in a sequenc

POJ_1007:DNA Sorting解题报告

[大致题意]排列多个DNA序列,按照每个序列的"有序程度".如果一个序列已经按照字母顺序排好了,那么这个序列有序程度最高,如AACCGGTT.反之,如果一个序列越无序,那么它的有序程度越低,如TGTCAA. [解题思路]计算每个序列的"逆序数",即反序字母对的个数,如ATGC的逆序数是3,因为TG,TC,GC都是逆序的.然后按照每个序列的逆序数排序,逆序数越大说明这个序列越无序. #include <iostream> #include <algo

HDU - 2838 Cow Sorting (树状数组 + 逆序对)

HDU - 2838 Cow Sorting Time Limit: 1000MS   Memory Limit: 32768KB   64bit IO Format: %I64d & %I64u Submit Status Description Sherlock's N (1 ≤ N ≤ 100,000) cows are lined up to be milked in the evening. Each cow has a unique "grumpiness" lev