Til the Cows Come Home(求最短路径)

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John‘s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

题目大意:一个人想从自己所在的点(N)以最快的方式走到1点,每组案例给出T个关系,(1 2 5)即代表1点和2点距离是5。一共有T组这样的关系。下面让我们求出从N点到1点的最短距离。

大致想法:用Dijkstra算法,说这个你也并不认识他。我觉得这种算法就是在求最小生成树的基础上稍稍改动了一下下。就是再更新的时候有点区别。求最小生成树的时候是拿新的边(其它点到新找出的节点的距离,不包括已经确定的节点)与之前节点的边进行比较。而最短路径是拿新边加上之前的构成最小生成树的所有边与之前的边的和比较,保留较小的到达指定地点即可跳出循环,输出结果。

代码如下:(重点的地方有解释哟)

#include<cstdio>
int map[10000][10000],d[10000],n,maxx=100000;
void dijkstra(int v)
{
       int i,j;
       bool s[10000]={false};
       for(i=1;i<=n;i++)
                d[i]=map[v][i];
        d[v]=0;s[v]=true;
        for(i=1;i<n;i++)
       {
          int temp=maxx;
          int u=v;
          for(j=1;j<=n;j++)
           if((!s[j])&&(d[j]<temp))//找出最小的那条边
               {
                    u=j;
                    temp=d[j];
                }
           s[u]=true;
           for(j=1;j<=n;j++)
            if((!s[j])&&(map[u][j]<maxx)&&(d[u]+map[u][j])<d[j])//没访问过那个节点并且找到的最新的路径比原先的小就要进行更新
             d[j]=d[u]+map[u][j];
        }
}
int main()
{
       int t,a,b,c;
       scanf("%d%d",&t,&n);
        for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                        map[i][j]=maxx;
         while(t--)
          {
                scanf("%d%d%d",&a,&b,&c);
                if(map[a][b]&&c>=map[a][b])continue;//为避免重边,就是两个点之间可能不止一条边,我们应当取最小的那条并保存
                map[a][b]=map[b][a]=c;
           }
        dijkstra(n);
        printf("%d\n",d[1]);
        return 0;
}

时间: 2024-08-05 19:12:46

Til the Cows Come Home(求最短路径)的相关文章

【POJ - 2387】Til the Cows Come Home(最短路径 Dijkstra算法)

Til the Cows Come Home 大奶牛很热爱加班,他和朋友在凌晨一点吃完海底捞后又一个人回公司加班,为了多加班他希望可以找最短的距离回到公司.深圳市里有N个(2 <= N <= 1000)个公交站,编号分别为1..N.深圳是大城市,公交车整天跑跑跑.公交站1是大奶牛的位置,公司所在的位置是N.所有公交站中共有T (1 <= T <= 2000)条双向通道.大奶牛对自己的导航能力不太自信,所以一旦开始,他总是沿着一条路线走到底.大奶牛为了锻炼未来的ACMer,决定让你帮

POJ 2387 Til the Cows Come Home Dijkstra求最短路径

Til the Cows Come Home Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

poj 2387 Til the Cows Come Home(dijkstra算法)

题目链接:http://poj.org/problem?id=2387 题目大意:起点一定是1,终点给出,然后求出1到所给点的最短路径. 注意的是先输入边,在输入的顶点数,不要弄反哦~~~ 1 #include <iostream> 2 #include <cstdio> 3 using namespace std; 4 int map[2010][2010],Min,node[2010],vis[2010],t,q; 5 const int INF=9999999; 6 7 vo

最短路问题--Bellman-Ford Til the Cows Come Home

Til the Cows Come Home Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

POJ 2387 Til the Cows Come Home dijkstra算法 用邻接表和邻接矩阵

题目如下: Til the Cows Come Home Time Limit: 1000MS        Memory Limit: 65536K Total Submissions: 27726        Accepted: 9353 Description Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wa

[2016-04-02][POJ][2387][Til the Cows Come Home]

时间:2016-04-02 10:34:36 星期六 题目编号:[2016-04-02][POJ][2387][Til the Cows Come Home] 题目大意:给定n个节点和t条路,求n到1的最短路长度 分析:跑一次最短路即可 遇到的问题: 据说是多重边,如果是用邻接矩阵的就要更新最小值, 此题是先输入t,再输入n,输入的时候读错,无限WA- #include <queue> #include <cstring> #include <cstdio> using

[POJ - 2387] L - Til the Cows Come Home(图论)

L - Til the Cows Come Home POJ - 2387 Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quick

POJ 2387 Til the Cows Come Home (最短路+Dijkstra)

Til the Cows Come Home Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 29550   Accepted: 9935 Description Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the

POJ2387 Til the Cows Come Home(SPFA + dijkstra + BallemFord 模板)

Til the Cows Come Home Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 37662   Accepted: 12836 Description Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the

bfs:求最短路径的长度

*/--> pre.src {background-color: Black; color: White;} pre.src {background-color: Black; color: White;} pre.src {background-color: Black; color: White;} pre.src {background-color: Black; color: White;} pre.src {background-color: Black; color: White;}