PAT Advanced 1043 Is It a Binary Search Tree (25分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node‘s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node‘s key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

这道题目考察了二叉排序树。二叉排序树一个性质,已知先序就可以求后序。

1.我们可以直接使用sort进行排序,然后根据先序中序求后序。

2.我们可以用i,j进行把二叉树划分2个子树,进行递归求解。(参考柳神)

#include <iostream>
#include <vector>
using namespace std;
int N;
bool mirror = false;
vector<int> pre, post;
void getPost(int root, int tail){
    if(root > tail) return ;
    int i = root + 1, j = tail;
    if(!mirror) {
        while(i <= tail && pre[i] < pre[root]) i++;//右子树最小的
        while(j > root && pre[j] >= pre[root]) j--;//左子树最大的
    }else {
        while(i <= tail && pre[i] >= pre[root]) i++;//右子树最小的
        while(j > root && pre[j] < pre[root]) j--;//左子树最大的
    }
    if(i - j != 1) return ; // 此时相差必为1, 否则不符合
    getPost(root + 1, j);
    getPost(i, tail);
    post.push_back(pre[root]);
}
int main() {
    cin >> N;
    pre.resize(N);
    for(int i = 0; i < N; i++)
        cin >> pre[i];
    getPost(0, N-1);
    if(post.size() != N) {
        post.clear();
        mirror = true;
        getPost(0, N-1);
    }
    if(post.size() != N) cout << "NO";
    else {
        cout << "YES" << endl;
        for(int i = 0; i < N; i++)
            if(i != N-1) cout << post[i] <<" ";
            else cout << post[i];
    }
    system("pause");
    return 0;
}

原文地址:https://www.cnblogs.com/littlepage/p/12230017.html

时间: 2024-10-09 02:38:27

PAT Advanced 1043 Is It a Binary Search Tree (25分)的相关文章

1043 Is It a Binary Search Tree (25 分)

1043 Is It a Binary Search Tree (25 分) A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a no

1043 Is It a Binary Search Tree (25分)(树的插入)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a node contains only nodes with keys greate

【PAT甲级】1043 Is It a Binary Search Tree (25 分)(判断是否为BST的先序遍历并输出后序遍历)

题意: 输入一个正整数N(<=1000),接下来输入N个点的序号.如果刚才输入的序列是一颗二叉搜索树或它的镜像(中心翻转180°)的先序遍历,那么输出YES并输出它的后序遍历,否则输出NO. trick: for(auto it:post) cout<<it<<((it!=post[n-1])?" ":""); 这样输出会使第0,1数据点格式错误...原因未知 cout<<post[0]; for(int i=1;i<

1043 Is It a Binary Search Tree (25分)

1. 题目 2. 思路 如下图 发现规律,对于最左边来说,后面所有的集合都是先小后大或者先大后小,如果小大交错那么不符合 使用1中规律确定是否为镜像,结合二叉排序树的特点,用递归建立树 输出树的后序遍历 3. 注意点 发现规律比较困难 树的题目一般都要用递归 4. 代码 #include<cstdio> #include<algorithm> #include<vector> using namespace std; #define null NULL struct n

1043. Is It a Binary Search Tree (25)【二叉树】——PAT (Advanced Level) Practise

题目信息 1043. Is It a Binary Search Tree (25) 时间限制400 ms 内存限制65536 kB 代码长度限制16000 B A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than

PAT 1043. Is It a Binary Search Tree (25)

1043. Is It a Binary Search Tree (25) A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a nod

1043. Is It a Binary Search Tree (25)

时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue (二叉树建立方法) A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than th

7-20 Binary Search Tree (25分)

A binary search tree is uniquely determined by a given ordered insertions of a sequence of positive integers. On the other hand, a given binary search tree may correspond to several different insertion sequences. Now given several insertion sequences

PAT (Advanced Level) 1099. Build A Binary Search Tree (30)

预处理每个节点左子树有多少个点. 然后确定值得时候递归下去就可以了. #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<map> #include<queue> #include<stack> #include<algorithm> using namespace std; struct Node { int