CISCO router 做VPN

NAT(config)#username velino password 0 123456      //设置用户名密码(vpn client连接后提示的用户名和密码)
!
NAT(config)#aaa new-model        //启用AAA认证
!
NAT(config)#aaa authentication login vpn-authen local     //设置AAA认证组vpn-authen为本地认证
NAT(config)#crypto isakmp xauth timeout 20      //设置扩展策略认证超时时间(秒)
NAT(config)#crypto map cisco client authentication list vpn-authen   //设置VPN模板cisco为认证组vpn-authen
!
NAT(config)#aaa authorization network vpn-author local     //设置认证网络组vpn-author为本地地址池
!
NAT(config)#ip local pool vpn-pool 172.16.0.1 172.16.0.3    //设置本地地址池vpn-pool的地址范围为172.16.0.1到172.16.0.2
!
NAT(config)#crypto map cisco client configuration address respond   //响应来自VPN策略cisco的地址请求
!
NAT(config)#access-list 100 permit ip 10.10.246.0 0.0.0.255 any    //设置内网的ACL
!
NAT(config)#crypto isakmp client configuration group mobile    //设置VPN客户组mobile(vpn client中需要的)
NAT(config-isakmp-group)#key velino       //设置VPN客户组密钥为velino(vpn client中需要的)
NAT(config-isakmp-group)#pool vpn-pool       //设置地址池为vpn-pool
!
NAT(config-isakmp-group)#acl 100       //应用ACL,不设置这个只能拨入不能访问内部网络
!
NAT(config-isakmp-group)#exit
!
NAT(config)#crypto map cisco isakmp authorization list vpn-author   //设置VPN策略cisco到AAA认证地址池
!
NAT(config)#crypto isakmp policy 1      //建立ISAKMP策略
NAT(config-isakmp)#encryption 3des      //设置加密算法
NAT(config-isakmp)#authentication pre-share      //设置共享密钥
NAT(config-isakmp)#group 2        //设置密钥长度为1024
NAT(config-isakmp)#hash md5        //设置为MD5认证
!
NAT(config-isakmp)#exit
!
NAT(config)#crypto ipsec transform-set vpn-set esp-3des esp-md5-hmac   //设置转换集vpn-set
!
NAT(cfg-crypto-trans)#exit
!
NAT(config)#crypto dynamic-map vpn-dyn 1      //建立动态模板映射
NAT(config-crypto-map)#set transform-set vpn-set     //设置转换集vpn-set      
!
NAT(config-crypto-map)#exit
!
NAT(config)#crypto map cisco 1 ipsec-isakmp dynamic vpn-dyn    //将组策略、Xauth应用到动态映射
!
NAT(config)#interface fastEthernet 0/0
NAT(config-if)#crypto map cisco        //加载MAP cisco
NAT(config-if)#exit
!

设置NAT的时候

access-list 101 deny ip 10.10.0.0 0.0.255.255 host 172.16.0.1
access-list 101 deny ip 10.10.0.0 0.0.255.255 host172.16.0.2
access-list 101 deny ip 10.10.0.0 0.0.255.255 host 172.16.0.3
access-list 101 permit ip 10.10.0.0 0.0.255.255 any    //设置内部网络阻止访问VPN客户端

access-list 1 permit 10.10.246.0 0.0.0.255

route-map ADSL permit 1
match ip address 101
exit

ip nat inside source route-map ADSL interface Dialer0 overload
interface
FastEthernet0/0
ip nat inside
exit
interface
Dialer0
ip nat outside
exit

时间: 2024-12-27 23:27:39

CISCO router 做VPN的相关文章

PPTP VPN在Cisco Router上的应用三:PPTP综合实验

本博文关于PPTP的实验包括以下内容: 实验1:基本的PPTP Server配置和Client配置(WinXP和Win7) 实验2:使用不加密的PPTP配置 实验3:使用PAP或CHAP认证的PPTP配置 实验4:PPTP问题1:TCP1723被阻止导致无法拨通 实验5:GRE防火墙检测和PAT转换问题 实验6:综合实验1:PPTP在实际工程的应用(结合radius实现多用户部署) 在实际项目工程中,如果做VPN的话,很少使用PPTP技术.思科的IPSEC和SSL VPN技术已经十分成熟和先进了

cisco 5505 与cisco路由器做ipsecVPN遇到的问题解决

cisco 路由器做ipsecVPN的时候 能建立起来 但是双方内网不通,这个问题一般都是nat的问题  你想让一个网段不走nat 走vpn的话 你要先deny这个网段到对端网段  然后在permit这个网段到对端网段 先拒绝再允许 目的地是any的放到后面 这样acl匹配的时候从上往下 只要去往vpn的流量自然被拒绝不走nat转换了 access-list 101 deny ip 10.70.1.0 0.0.0.255  192.168.70.0 0.0.0.255          acce

映射-外网访问内网服务-ngrok和cisco路由做映射

一:软件解决 软件下载地址: https://ngrok.com/download ngrok-stable-windows-amd64.zip 使用: cmd ---CD..切换到软件目录 ngrok.exe 在弹出框输入:ngrok http 80   (80或者其他端口号,根据实际情况) 二:cisco路由做映射 步骤如下 登陆cisco en ,config 查看配置   show run 固定IP: ip nat inside source static tcp 10.10.1.253

Error 56: The Cisco Systems, Inc. VPN Service has not been started(Cisco VPN在Vista下出现Error 56的解决办法)

Error 56: The Cisco Systems, Inc. VPN Service has not been started(Cisco VPN在Vista下出现Error 56的解决办法) 似乎,自从我的Vista自动升级安装了SP1后,我的Cisco VPN就出现问题了,根本就无法运行.总是提示Error 56: The Cisco Systems, Inc. VPN Service has not been started. Please start this service an

Operating Cisco Router

Operating Cisco Router consider the hardware on the ends of the serial link, in particular where the channel service unit/data service unit (CSU/DSU) hardware resides on each end of the serial link. It sits either outside the router as a separate dev

Cisco网络设备搭建VPN服务器的全过程

Cisco网络设备搭建VPN服务器的全过程 环境:在公司的南京办事处与上海办事处之间建立VPN联接. 南京办事处网络设置: 内网IP 10.1.1.0/24 外网IP 202.102.1.5/24 上海办事处网络设置: 内网IP 10.1.2.0/24 外网IP 202.102.1.6/24 南京路由器配置 ! service timestamps debug uptime service timestamps log uptime no service password-encryption

PPTP VPN在Cisco Router上的应用二:PPTP扩展实验

本文继续上一篇关于PPTP VPN的实验. 拓扑图依旧使用上次的拓扑,配置不变.读者需要在上一篇博文的基础上来阅读本文. 拓扑图如下: 本博文关于PPTP的实验包括以下内容: 实验1:基本的PPTP Server配置和Client配置(WinXP和Win7) 实验2:使用不加密的PPTP配置 实验3:使用PAP或CHAP认证的PPTP配置 实验4:PPTP问题1:TCP1723被阻止导致无法拨通 实验5:GRE防火墙检测和PAT转换问题 实验6:综合实验1:PPTP在实际工程的应用 实验7:综合

实验L2TP VPN over Cisco Router

说明:拓扑图如下.R1模拟公司边界路由器,R3模拟远端用户的家用路由器,并分别在这两台路由器上启用PAT:R2模拟ISP,并启用一个Loopback接口来充当公网上的服务器:R4模拟公司内网的主机,来充当WEB服务器. 要求:1.在R1上配置L2TP VPN,使远端的C1能够拨号到该路由器,让C1可以直接使用私有地址来访问公司总部10.1.1.0/24和4.4.4.4/32. 服务器端配置命令: R1: conf t int e0/1  ip add 10.1.1.1 255.255.255.0

基于cisco路由器做IPSec VPN隧道

实验要求:拓扑图如下所示,R1和R5作为internet中两端内部局域网,通过在网关设备R2和R4上设置IPsec VPN,使两端的局域网之间建立一种逻辑上的虚拟隧道. 实验步骤:首先配置所有理由器接口的IP地址(略),并指定默认路由(因为是末梢网络). R1上面的默认路由如下所示. R2上面的默认路由如下所示. ISP是运营商,在这里用来模拟外部网络,只需要配置IP地址就行. R4上面的默认路由如下所示. R5上面的默认路由如下所示. 此时配置完成两个局域网是不能够通信的.下面就需要分别在R2