基础命令实验

拓扑图:

题目要求:

(1)Configure S1 with the following initial settings:

-       Hostname

-       Banner that includes the word warning

-       Console port login and password cisco

-       Encrypted enable password of class

-       Encrypt plain text passwords

-       Management interface addressing

(2)Configure SSH to secure remote access with the following settings:

-       Domain name of cisco.com

-       RSA key-pair parameters to support SSH version 2

-       Set SSH version 2

-       User admin with password ccna

-       VTY lines only accept SSH connections and use local login for authentication

(3)Configure the port security feature to restrict network access.

-       Disable all unused ports.

-       Set the interface mode to access.

-       Enable port security to allow only two hosts per port.

-       Record the MAC address in the running configuration.

-       Ensure that port violations disable ports.

S1上的配置命令:

(1)Switch>enable

Switch#configure terminal

Switch(config)#hostname S1

S1(config)#banner motd ‘warning‘

S1(config)#line console 0

S1(config-line)#password cisco

S1(config-line)#login

S1(config-line)#exit

S1(config)#enable secret class

S1(config)#service password-encryption

S1(config)#interface vlan 1

S1(config-if)#ip address 10.10.10.2 255.255.255.0

(2)S1(config-if)#no shutdown

S1(config-if)#exit

S1(config)#ip domain-name cisco.com

S1(config)#crypto key generate rsa

The name for the keys will be: S1.cisco.com

How many bits in the modulus [512]: 1024

% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

S1(config)#ip ssh version 2

S1(config)#username admin password ccna

S1(config)#line vty 0 15

S1(config-line)#transport input ssh

S1(config-line)#login local

S1(config-line)#exit

(3)S1(config)#interface range gigabitEthernet 0/1-2

S1(config-if-range)#sh

S1(config-if-range)#shutdown

S1(config-if-range)#exit

S1(config)#interface range fastEthernet 0/1-24

S1(config-if-range)#sh

S1(config-if-range)#shutdown

S1(config-if-range)#switchport mode access

S1(config-if-range)#switchport port-security

S1(config-if-range)#switchport port-security maximum 2

S1(config-if-range)#switchport port-security violation shutdown

S1(config-if-range)#switchport port-security mac-address sticky

时间: 2024-10-10 20:12:03

基础命令实验的相关文章

Linux上命令的使用格式和基础命令详解

一.Linux上命令的使用格式 命令行提示符详解: 用户通过终端的命令行接口来控制操作系统,登陆后如下: [[email protected] ~]# root: 当前登录的用户 @:分隔符 localhost: 当前主机的主机名,非完整格式:此处的完整格式为:localhost.localdomain [[email protected] ~]# hostname localhost.localdomain ~:用户当前所在的目录(current directory),也称为工作目录(work

Linux基础命令快速入门

Linux基础命令 write by Booboo Wei [email protected] 摘要: 常用的命令 ls cd pwd 符号 * ? { } | 帮助命令 --help help type man info /usr/share/doc 针对文件的的基本操作 touch mkdir rmdir cp rm mv 针对文件内容的基本操作 cat tac head tail more less 文件的查看.编辑.过滤vi vim echo grep cut wc file 关于时间的

4、linux基础命令详解

linux基础命令 Linux图形界面和命令行界面的切换 进入Linux桌面环境后,可以使用键盘上的"Ctrl+Alt+F1~F6"组合键来切换不同的tty界面,Linux默认提供了6个命令行界面(F1-F6),比如"Ctrl+Alt+F1"就是切换到tty1: 在命令行模式下,想要切换回图形界面可以使用组合键"Ctrl+Alt+F7":另外,如果不是从图形界面切换到tty模式,而是系统启动时候直接进入了命令行模式,在登陆后可以使用"s

linux基础命令汇总

说明 本文仅仅对一些基础命令做演示,不涉及过多的原理性,以及概念性的东西, 示例中仅仅列出常用的选项,对于不常用的选项不做介绍以及演示. 其中部分帮助信息是来源于man查寻结果,未作翻译,请谅解. enable(内置命令) 命令示例 enable -a 显示所有激活和禁用的内置命令 enable -n 显示所有已经禁用的内置命令 enable -n echo 禁用内置命令 echo 命令演示 禁用命令 [[email protected] ~]#enable -n echo [[email pr

【系统知识点】linux入门基础命令

大概总结了一下一些基础命令,仅仅是帮助基础使用linux文件系统,如果还有相关基础命令,希望大家留言一起补充汇总一下! 命令的基本格式: 格式:command [-options] parameter1 parameter2 - ps:第一个被输入的数据绝对是命令或者是可执行文件 cat /etc/redhat-release//查看系统版本 uname -r//查看内核版本 uname -m//查看系统位数 pwd: print working directory,显示用户当前所在目录 ls 

Gi之(二)Git基础命令

三个工作区域 使用Git之前,首先要弄清Git的三个管理区域,有助于理解Git的运行原理,以及每个Git命令对文件造成的影响. 对于任何一个文件,在本地的Git内部都有三种状态: l   已修改(modified) 表示修改了某个文件,但还没有提交保存.包括新增.删除了一个文件,也属于已修改状态的一种. l   已暂存(staged) 表示把已修改的文件放到了暂存区,也就是放到了下次提交时的清单中. l   已提交(committed) 表示该文件已经被安全地保存在本地数据库中了. 三种状态对应

Linux下的基础命令介绍(一)

一.基础命令 1.type命令----查看命令的类型 a.内置命令(内部命令)shell内置 b.外部命令----在文件系统的某个路径下有一个与命令名称一致的可执行文件 用法:type 命令名 根据返回的值判断,如果值为 is a shell builtin 那么它是内置命令,如果不是这个值而是一个路径 那么它是外部命令 2.printenv命令---查看环境变量 echo $PATH ----输出环境变量的值,使用冒号分割的路径 3.set命令--查看所有的系统变量 4.echo命令--输出变

Linux基础命令(之一)详解

Linux基础命令(之一)详解 学习linux的朋友都知道,系统大多数操作都是命令行的操作方式,当然如今也有图形化界面的操作方式,但是多数情况下仍然使用命令的操作模式,所以命令的作用与用法是成为学好.学会Linux系统的必备前提,也是重点之一,所以今天来聊一聊一些基础命令的用法与其作用. 1.系统关机或重启命令(小白也必须要会的) shutdown (win 系统也有) 常用参数:shutdown -h (halt) 直接关机(关闭电源) shutdown -h  now[+10]    现在关

linux基础命令——tree

Linux基础命令--tree 编辑文章 -d :只显示目录,不显示其目录下的子文件 -L level:显示第几级 图片描述 显示以rc开头的 备份: 创建多级目录: -v:可以看过程