B - Euler theorem 数学

直接打表找规律

HazelFan is given two positive integers a,ba,b, and he wants to calculate amodbamodb. But now he forgets the value of bb and only remember the value of aa, please tell him the number of different possible results.

InputThe first line contains a positive integer T(1≤T≤5)T(1≤T≤5), denoting the number of test cases. 
For each test case: 
A single line contains a positive integer a(1≤a≤109)a(1≤a≤109).OutputFor each test case: 
A single line contains a nonnegative integer, denoting the answer. 
Sample Input

2
1
3

Sample Output

2
3
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<sstream>
#include<algorithm>
#include<queue>
#include<deque>
#include<iomanip>
#include<vector>
#include<cmath>
#include<map>
#include<stack>
#include<set>
#include<memory>
#include<list>
#include<string>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
#define MAXN  1009
#define L 31
#define INF 1000000009
#define eps 0.00000001

LL n;
int main()
{
    int T;
    scanf("%d", &T);
    while (T--)
    {
        scanf("%lld", &n);
        if (n & 1)
            n++;
        printf("%lld\n", n / 2 + 1);
    }
}
时间: 2024-10-14 04:21:26

B - Euler theorem 数学的相关文章

HDU 6124 17多校7 Euler theorem(简单思维题)

Problem Description HazelFan is given two positive integers a,b, and he wants to calculate amodb. But now he forgets the value of b and only remember the value of a, please tell him the number of different possible results. Input The first line conta

A - Euler theorem

2017-09-22 21:59:43 writer:pprp HazelFan is given two positive integers a,ba,b, and he wants to calculate amodbamodb. But now he forgets the value of bb and only remember the value of aa, please tell him the number of different possible results. Inpu

数学故事

发信人: ukim (我没有理想), 信区: Mathematics 标 题: Heroes in My Heart ( 序 ) 发信站: 北大未名站 (2002年04月06日14:23:24 星期六), 转信 --------------------------------- To Music For the Encouragement and Smiles She Gave Me --------------------------------- 序 废话几句. 多年以前,我有一个很宏伟的计

数学知识小结#1

PREFACE 时隔数月尝试拾起以往的OI知识发现异常的艰难,于是准备慢慢的填坑,可能比较简略并且穿插不少英文(万一面试的时候问起OI还能说几句pao),但是我英语太菜了,如果您发现了错误或是需要改进的地方,欢迎联系我或是在下方评论 小结#1主要是数论部分,小结#2到时看情况在更吧 update:里面的除法都是指下取整 质数与约数Prime Number&Divisors 质数筛法Sieve 埃拉托斯特尼筛法Sieve of Eratosthenes 主要思想是任意整数x的倍数2x,3x...都

GitHub上史上最全的iOS开源项目分类汇总

学了这么久,还是抽时间把github上比较好用的第三方总结了一下: Category/Util sstoolkit 一套Category类型的库,附带很多自定义控件 功能不错-       BFKit 又一套Category类型的 Kit,还有几个工具类       APUtils 又一套Category类型的 Kit       QSKit 又一套Category类型的 Kit       iOS-Categories 又一套Category类型的 Kit       BlocksKit 将B

HDU6124

Euler theorem Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)Total Submission(s): 742    Accepted Submission(s): 584 Problem Description HazelFan is given two positive integers a,b, and he wants to calculate amod

模板 - 数学 - 同余 - 扩展Euler定理

费马(Fermat)小定理 当 \(p\) 为质数,则 \(a^{p-1}\equiv 1 \mod p\) 反之,费马小定理的逆定理不成立,这样的数叫做伪质数,最小的伪质数是341. 欧拉(Euler)定理 扩展欧拉(Euler)定理 根据扩展欧拉定理,不管a和p是不是互质,都可以缩小到 \([\varphi(p),2\varphi(p)]\) 之间,然后暴力用快速幂求解. 原文地址:https://www.cnblogs.com/KisekiPurin2019/p/11956991.html

[数学]Euler‘s Method 欧拉方法

1-思想原理 求解一阶的常微分方程ODE,欧拉想出一种数值方法,得到一种线性近似Linear approximation 他并非求解出具体的y的方程,而是根据给定的初始值\((x_0,y_0=f(x_0)\)求得下个想要求得的点\(x_n\)的函数值\(y_n=f(x_0)\),当然这样就得到了想要的点的坐标\((x_n,y_n=f(x_n)\). 那么他是怎么做的呢? 欧拉是利用倒数的几何意义即斜率来求得下个点的坐标值 欧拉说 下个点的函数值近似等于 \[y_n = y_0 + \frac{d

一些对数学领域及数学研究的个人看法(转载自博士论坛wcboy)

转自:http://www.math.org.cn/forum.php?mod=viewthread&tid=14819&extra=&page=1 原作者: wcboy 现在的论坛质量比以前差了,大部分都是来解题问答的,而且层次较低.以前论坛中,Qullien很令人印象深刻,但愿他能在国外闯出一片天空.现在 基础数学版代数&数论子版中那几个讨论代数几何的还不错.不期望目前论坛出现很多高层次高手,高层次高手应该站在好课题上高观点讨论数学,出 现这样的网友,看他们的言论非常过