POJ 1287:Networking(最小生成树Kruskal)

Networking

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 5976   Accepted: 3231

Description

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are
given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the
area.

Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.

Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points.
The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only
one number P=0 denotes the end of the input. The data sets are separated with an empty line.

The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j
i.

Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.

Sample Input

1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0

Sample Output

0
17
16
26

题意:

P个点,R对边,找出最小通路和

分析:

长度为边权的最小生成树问题

kruskal & 并查集

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<vector>
#include<queue>
#define INF 0x3f3f3f3f

using namespace std;

const int maxn=5100;

int r[maxn];
int n, m;

struct node
{
    int x;
    int y;
    int cost;
};
node a[maxn];

bool cmp ( node a, node b )
{
    return a.cost<b.cost;
}

void init()
{
    for( int i=0; i<n; i++ )
        scanf( "%d%d%d", &a[i].x, &a[i].y, &a[i].cost );
    sort( a, a+n, cmp );
    for( int i=0; i<n; i++ )
        r[i] = i;
}

int find( int x )
{
    return r[x]==x? x : r[x] = find( r[x] );
}

void kruskal()
{
    int cnt = 0;
    int ans = 0;
    int x; int y;
    for( int i=0; i<n; i++ )
    {
        x = find( a[i].x );
        y = find( a[i].y );
        if( x!=y )
        {
            cnt++;
            ans += a[i].cost;
            if( cnt == m-1 )
                break;
            r[y] = x;
        }
    }
    printf( "%d\n", ans );
}

int main()
{
    while( scanf( "%d", &m )==1 &&m )
    {
        scanf( "%d", &n );
        init();
        kruskal();
    }
    return 0;
}
时间: 2024-07-30 13:50:34

POJ 1287:Networking(最小生成树Kruskal)的相关文章

POJ 1287 Networking (最小生成树)

Networking Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 1287 Appoint description:  System Crawler  (2015-06-02) Description You are assigned to design network connections between certain poin

POJ 1287 Networking (最小生成树模板题)

Description You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between

ZOJ1372 POJ 1287 Networking 网络设计 Kruskal算法

题目链接:ZOJ1372 POJ 1287 Networking 网络设计 Networking Time Limit: 2 Seconds      Memory Limit: 65536 KB You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible

[2016-04-14][POJ][1287][Networking]

时间:2016-04-14 14:48:44 星期四 题目编号:[2016-04-14][POJ][1287][Networking] 题目大意:求最小生成树 分析:直接prim算法,更新边的时候,重边取最小值 #include<cstdio> #include<cstring> #include<algorithm> using namespace std; const int maxn = 50 + 10; const int inf = 0x3f3f3f3f; i

POJ 1287 Networking(最小生成树)

题意  给你n个点 m条边  求最小生成树的权 这是最裸的最小生成树了 #include<cstdio> #include<cstring> #include<algorithm> using namespace std; const int N = 55, M = 3000; int par[N], n, m, ans; struct edge{int u, v, w;} e[M]; bool cmp(edge a, edge b){return a.w < b

POJ - 1287 Networking

题目链接:http://poj.org/problem?id=1287 Sample Input 1 0 2 3 1 2 37 2 1 17 1 2 68 3 7 1 2 19 2 3 11 3 1 7 1 3 5 2 3 89 3 1 91 1 2 32 5 7 1 2 5 2 3 7 2 4 8 4 5 11 3 5 10 1 5 6 4 2 12 0 Sample Output 0 17 16 26 分析:最小生成树纯模板 1 #include <cstdio> 2 #include &

POJ 1258【最小生成树 &amp;&amp; Kruskal &amp;&amp; 水题】

Agri-Net Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 45145   Accepted: 18534 Description Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He nee

POJ 1287 Networking【MST模板题】

Networking Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 8214 Accepted: 4528 Description You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possib

poj 3723 Conscription(最小生成树拓展)

Conscription Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 7702   Accepted: 2667 Description Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be

POJ 1258 Agri-Net (最小生成树+Prim)

Agri-Net Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 39820   Accepted: 16192 Description Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He nee