POJ 3268 双向Dijkstra

Silver Cow Party

Time Limit: 2000MS Memory Limit: 65536K

Total Submissions: 13020 Accepted: 5832

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤
100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow‘s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X

Lines 2..M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2

1 2 4

1 3 2

1 4 7

2 1 1

2 3 5

3 1 2

3 4 4

4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

Source

USACO 2007 February Silver

/*****************************
  author   : Grant Yuan
  time     : 2014/10/4 23:07
  source   : POJ 3268
  algorithm: Dijkstra
******************************/

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
#define MAX 1007
#define INF 0x7ffffff

struct point{int x,y;};
int n,m,x;
int ans;
point v[MAX];
int cost[MAX][MAX];
bool used[MAX];
int mincost[MAX];
int start,final;
int sum[MAX];

void Dijkstra_Go()
{
    for(int i=1;i<=n;i++)
    {
        used[i]=false;
        mincost[i]=cost[i][x];
    }
    for(int i=1;i<=n;i++)
    {
        int temp=INF;
        int k=-1;
        for(int j=1;j<=n;j++)
        {
            if(!used[j]&&mincost[j]<temp)
            {
                temp=mincost[j];
                k=j;
            }
        }
        if(k==-1) break;
        used[k]=true;
        for(int j=1;j<=n;j++)
        {
            if(!used[j]) mincost[j]=min(mincost[j],mincost[k]+cost[j][k]);
        }
    }
}
void Dijkstra_Back()
{
    for(int i=1;i<=n;i++)
    {
        used[i]=false;
        mincost[i]=cost[x][i];
    }
    for(int i=1;i<=n;i++)
    {
        int temp=INF;int k=-1;
        for(int j=1;j<=n;j++)
        {
            if(!used[j]&&mincost[j]<temp)
            {
                temp=mincost[j];
                k=j;
            }

        }
        if(k==-1) break;
        used[k]=true;
        for(int j=1;j<=n;j++)
        {
            if(!used[j]) mincost[j]=min(mincost[j],mincost[k]+cost[k][j]);
        }
    }
}
int main()
{
   while(~scanf("%d%d%d",&n,&m,&x)){
    ans=0;
    memset(sum,0,sizeof(sum));
    for(int i=1;i<=n;i++)
      for(int j=1;j<=n;j++)
        cost[i][j]=INF;
    for(int i=1;i<=n;i++) cost[i][i]=0;
    for(int i=1;i<=m;i++)
    {
        int a,b,c;
        scanf("%d%d%d",&a,&b,&c);
        cost[a][b]=c;
    }
    Dijkstra_Go();
    for(int i=1;i<=n;i++)
    {
        sum[i]=mincost[i];
    }
    Dijkstra_Back();
    for(int i=1;i<=n;i++)
    {
        sum[i]+=mincost[i];
    }
    for(int i=1;i<=n;i++) ans=max(ans,sum[i]);
    printf("%d\n",ans);}
    return 0;
}
时间: 2024-12-15 10:00:02

POJ 3268 双向Dijkstra的相关文章

DIjkstra(反向边) POJ 3268 Silver Cow Party || POJ 1511 Invitation Cards

题目传送门 1 2 题意:有向图,所有点先走到x点,在从x点返回,问其中最大的某点最短路程 分析:对图正反都跑一次最短路,开两个数组记录x到其余点的距离,这样就能求出来的最短路以及回去的最短路. POJ 3268 //#include <bits/stdc++.h> #include <cstdio> #include <queue> #include <algorithm> #include <cstring> using namespace

POJ 3268 Silver Cow Party 最短路—dijkstra算法的优化。

POJ 3268 Silver Cow Party Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects

POJ 3268 Silver Cow Party dijkstra单源最短路

裸dijkstra 思路:以x为源点,求到其他点的最短路,之后把邻接矩阵转置,再求一次x源 点的最短路,这样就一次是来的,一次是走的,相加迭代最大值即可 代码: /* poj 3268 8108K 47MS */ #include<cstdio> #include<iostream> #define MAXN 1005 #define MAX_INT 2147483647 using namespace std; int gra_in[MAXN][MAXN],gra_out[MAX

poj 3268 Silver Cow Party , spfa , dijkstra

点击打开链接 两次求最短路(第二次把边反向求) 1.spfa //poj 3268 Silver Cow Party //SPFA #include <cstdio> #include <cstring> #include <queue> using namespace std; const int M = 100000 + 100; const int N = 1000 + 100; const int inf = 1<<25; struct Graph

POJ 3268 Silver Cow Party (Dijkstra)

题目链接:POJ 3268 Description One cow from each of \(N\) farms \((1 ≤ N ≤ 1000)\) conveniently numbered \(1..N\) is going to attend the big cow party to be held at farm #\(X (1 ≤ X ≤ N)\). A total of \(M (1 ≤ M ≤ 100,000)\) unidirectional (one-way roads

POJ 3268 Silver Cow Party(SPFA)

Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i re

图论 ---- spfa + 链式向前星 ---- poj 3268 : Silver Cow Party

Silver Cow Party Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 12674   Accepted: 5651 Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X 

poj 3268 Silver Cow Party(最短路)

poj 3268 Silver Cow Party Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects

poj 1915 双向 BFS 利用数组 a[x][y] = a[cp.x][cp.y] + 1; b[x][y] = b[cp.x][cp.y] + 1;保留步数

#include<iostream>#include<queue> using namespace std; struct point{    int x, y;};point bufa[8] ={    {-2, 1}, {-1, 2}, {1, 2}, {2, 1},    {2, -1}, {1, -2}, {-1, -2}, {-2, -1}}; int n, a[305][305], b[305][305]; int rule(int x,int y)//判断是否符合棋盘