南阳acm-206-矩形的个数(水题)

矩形的个数

时间限制:1000 ms  |  内存限制:65535 KB

难度:1

描述
在一个3*2的矩形中,可以找到6个1*1的矩形,4个2*1的矩形3个1*2的矩形,2个2*2的矩形,2个3*1的矩形和1个3*2的矩形,总共18个矩形。

给出A,B,计算可以从中找到多少个矩形。

输入
本题有多组输入数据(<10000),你必须处理到EOF为止

输入2个整数A,B(1<=A,B<=1000)

输出
输出找到的矩形数。 
样例输入
1 2
3 2
样例输出
3
18

AC代码:

#include<stdio.h> //第一:赋值A B S 必都用long long ,否则不能通过!
int main() //第二:此题必须用到一个数学公式:(A+1)*A/2*(B+1)*B/2=(A+1)*(B+1)*A*B/4
{
long long A,B;
long long s=0;
while(scanf("%lld %lld",&A,&B)!=EOF)
{
s=(A+1)*A/2*(B+1)*B/2;
printf("%lld\n",s);
}
return 0;
}
#include <stdio.h>//最优代码
main()
{
float a,b;
while(scanf("%f%f",&a,&b)+1)
printf("%.0f\n",(a+1)*a*(b+1)*b/4);
}


 
时间: 2024-10-13 12:54:11

南阳acm-206-矩形的个数(水题)的相关文章

2015南阳CCPC L - Huatuo&#39;s Medicine 水题

L - Huatuo's Medicine Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 无 Description Huatuo was a famous doctor. He use identical bottles to carry the medicine. There are different types of medicine. Huatuo put medicines into the bottles and chain these b

(南阳理工 acm)题目206 矩形的个数

矩形的个数 时间限制:1000 ms  |  内存限制:65535 KB 难度:1 描述 在一个3*2的矩形中,可以找到6个1*1的矩形,4个2*1的矩形3个1*2的矩形,2个2*2的矩形,2个3*1的矩形和1个3*2的矩形,总共18个矩形. 给出A,B,计算可以从中找到多少个矩形. 输入 本题有多组输入数据(<10000),你必须处理到EOF为止 输入2个整数A,B(1<=A,B<=1000) 输出 输出找到的矩形数.  样例输入 1 2 3 2 样例输出 3 18 #include&

HDU ACM 1017 A Mathematical Curiosity 水题

分析:水题,但要注意格式. #include<iostream> using namespace std; int core(int n,int m) { int i,j,ans=0; for(i=1;i<n;i++) for(j=i+1;j<n;j++) if((i*i+j*j+m)%(i*j)==0) ans++; return ans; } int main() { int T,t,n,m; bool fg=false; scanf("%d",&T

nyoj 206——矩形的个数——————【dp或公式】

矩形的个数 时间限制:1000 ms  |  内存限制:65535 KB 难度:1 描述 在一个3*2的矩形中,可以找到6个1*1的矩形,4个2*1的矩形3个1*2的矩形,2个2*2的矩形,2个3*1的矩形和1个3*2的矩形,总共18个矩形. 给出A,B,计算可以从中找到多少个矩形. 输入 本题有多组输入数据(<10000),你必须处理到EOF为止 输入2个整数A,B(1<=A,B<=1000) 输出 输出找到的矩形数.  样例输入 1 2 3 2 样例输出 3 18 dp: #incl

HDU ACM 1073 Online Judge -&gt;字符串水题

分析:水题. #include<iostream> using namespace std; #define N 5050 char a[N],b[N],tmp[N]; void Read(char p[]) { getchar(); gets(tmp); while(gets(tmp)) { if(strcmp(tmp,"END")==0) break; if(strlen(tmp)!=0) strcat(p,tmp); strcat(p,"\n");

2015南阳CCPC A - Secrete Master Plan 水题

D. Duff in Beach Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 无 Description Master Mind KongMing gave Fei Zhang a secrete master plan stashed in a pocket. The plan instructs how to deploy soldiers on the four corners of the city wall. Unfortunately, w

NYOJ 206 矩形的个数

#include<stdio.h>int main(){ long long m,n,t; while(~scanf("%lld%lld",&m,&n)) { t=m*(m+1)/2*n*(n+1)/2; printf("%lld\n",t); }}

[ACM] ZOJ 3819 Average Score (水题)

Average Score Time Limit: 2 Seconds      Memory Limit: 65536 KB Bob is a freshman in Marjar University. He is clever and diligent. However, he is not good at math, especially in Mathematical Analysis. After a mid-term exam, Bob was anxious about his

南阳acm-97-兄弟郊游问题(水题)

兄弟郊游问题 时间限制:3000 ms  |  内存限制:65535 KB 难度:2 描述 兄弟俩骑车郊游,弟弟先出发,每分钟X米,M分钟后,哥哥带一条狗出发.以每分钟Y米的速度去追弟弟,而狗则以每分钟Z米的速度向弟弟跑去,追上弟弟后又立即返回,直到哥哥追上弟弟时,狗跑了多少米? 输入 第一行输入一个整数N,表示测试数据的组数(N<100)每组测试数据占一行,是四个正整数,分别为M,X,Y,Z(数据保证X<Y<Z) 输出 输出狗跑的路径,结果保留小数点后两位. 样例输入 1 5 10 1

HDU ACM 5224 Tom and paper 水题+暴力枚举

分析:因为长和宽都是整数,所以枚举判断是不是整数,再取最小的即可. #include<iostream> #include<cmath> using namespace std; int main() { int min; int a,i,T; ios::sync_with_stdio(false); cin>>T; while(T--) { cin>>a; min=1000000000; for(i=1;i<=sqrt(a);i++) if(a%i=