【BZOJ1803】Spoj1487 Query on a tree III 主席树+DFS序

【BZOJ1803】Spoj1487 Query on a tree III

Description

You are given a node-labeled rooted tree with n nodes. Define the query (x, k): Find the node whose label is k-th largest in the subtree of the node x. Assume no two nodes have the same labels.

Input

The first line contains one integer n (1 <= n <= 10^5). The next line contains n integers li (0 <= li <= 109) which denotes the label of the i-th node. Each line of the following n - 1 lines contains two integers u, v. They denote there is an edge between node u and node v. Node 1 is the root of the tree. The next line contains one integer m (1 <= m <= 10^4) which denotes the number of the queries. Each line of the next m contains two integers x, k. (k <= the total node number in the subtree of x)

Output

For each query (x, k), output the index of the node whose label is the k-th largest in the subtree of the node x.

Sample Input

5
1 3 5 2 7
1 2
2 3
1 4
3 5
4
2
3
4 1
3 2
3 2

Sample Output

5 4 5 5

题解:这样例你告诉我是求子树第k大?(the k_th largest)分明是第k小啊!

直接主席树+DFS序搞定。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn=100010;
int n,m,cnt,tot;
int to[maxn<<1],next[maxn<<1],head[maxn],v[maxn],p[maxn],q[maxn],rt[maxn];
int ls[maxn*30],rs[maxn*30],siz[maxn*30],s[maxn*30];
struct number
{
    int val,org;
}num[maxn];
bool cmp(number a,number b)
{
    return a.val<b.val;
}
void insert(int x,int &y,int l,int r,int a,int b)
{
    if(l>r)  return ;
    y=++tot,siz[y]=siz[x]+1;
    if(l==r)
    {
        s[y]=b;
        return ;
    }
    int mid=l+r>>1;
    if(a<=mid)   rs[y]=rs[x],insert(ls[x],ls[y],l,mid,a,b);
    else    ls[y]=ls[x],insert(rs[x],rs[y],mid+1,r,a,b);
}
int query(int a,int b,int l,int r,int c)
{
    if(l==r)    return s[a];
    int mid=l+r>>1,sm=siz[ls[a]]-siz[ls[b]];
    if(c<=sm)    return query(ls[a],ls[b],l,mid,c);
    else    return query(rs[a],rs[b],mid+1,r,c-sm);
}
void dfs(int x,int fa)
{
    p[x]=++p[0];
    insert(rt[p[0]-1],rt[p[0]],1,n,v[x],x);
    for(int i=head[x];i!=-1;i=next[i])  if(to[i]!=fa)   dfs(to[i],x);
    q[x]=p[0];
}
void add(int a,int b)
{
    to[cnt]=b,next[cnt]=head[a],head[a]=cnt++;
}
int main()
{
    scanf("%d",&n);
    int i,a,b;
    for(i=1;i<=n;i++)    scanf("%d",&num[i].val),num[i].org=i;
    sort(num+1,num+n+1,cmp);
    for(i=1;i<=n;i++)    v[num[i].org]=i;
    memset(head,-1,sizeof(head));
    for(i=1;i<n;i++)
    {
        scanf("%d%d",&a,&b);
        add(a,b),add(b,a);
    }
    dfs(1,0);
    scanf("%d",&m);
    for(i=1;i<=m;i++)
    {
        scanf("%d%d",&a,&b);
        printf("%d\n",query(rt[q[a]],rt[p[a]-1],1,n,b));
    }
    return 0;
}
时间: 2024-11-08 21:24:36

【BZOJ1803】Spoj1487 Query on a tree III 主席树+DFS序的相关文章

BZOJ_1803_Spoj1487 Query on a tree III_主席树+dfs序

BZOJ_1803_Spoj1487 Query on a tree III_主席树 Description You are given a node-labeled rooted tree with n nodes. Define the query (x, k): Find the node whose label is k-th largest in the subtree of the node x. Assume no two nodes have the same labels. I

bzoj 1803: Spoj1487 Query on a tree III(主席树)

题意 你被给定一棵带点权的n个点的有根数,点从1到n编号. 定义查询 query(x,k): 寻找以x为根的k大点的编号(从小到大排序第k个点) 假设没有两个相同的点权. 输入格式: 第一行为整数n,第二行为点权,接下来n-1行为树边,接下来一行为整数m,下面m行为两个整数x,k,代表query(x,k) 输出格式: m行,输出每次查询的结果. 题解 先一遍dfs,然后建个主席树,带上去直接跑一跑就好了 我忘了注意dfs序的位置和原来的编号……结果调了半天啥都调不出来…… 1 //minamot

BZOJ1803: Spoj1487 Query on a tree III

1803: Spoj1487 Query on a tree III Time Limit: 1 Sec  Memory Limit: 64 MBSubmit: 286  Solved: 125[Submit][Status] Description You are given a node-labeled rooted tree with n nodes. Define the query (x, k): Find the node whose label is k-th largest in

【DFS序】【莫队算法】【权值分块】bzoj1803 Spoj1487 Query on a tree III

基本等同这个,只是询问的东西不大一样而已. http://www.cnblogs.com/autsky-jadek/p/4159897.html #include<cstdio> #include<algorithm> #include<cmath> using namespace std; int Num,CH[12],f,c; inline void R(int &x){ c=0;f=1; for(;c<'0'||c>'9';c=getchar(

51 nod 1681 公共祖先 (主席树+dfs序)

1681 公共祖先 基准时间限制:1 秒 空间限制:131072 KB 分值: 80 难度:5级算法题 有一个庞大的家族,共n人.已知这n个人的祖辈关系正好形成树形结构(即父亲向儿子连边). 在另一个未知的平行宇宙,这n人的祖辈关系仍然是树形结构,但他们相互之间的关系却完全不同了,原来的祖先可能变成了后代,后代变成的同辈…… 两个人的亲密度定义为在这两个平行宇宙有多少人一直是他们的公共祖先. 整个家族的亲密度定义为任意两个人亲密度的总和. Input 第一行一个数n(1<=n<=100000)

【bzoj1803】Spoj1487 Query on a tree III DFS序+主席树

题目描述 You are given a node-labeled rooted tree with n nodes. Define the query (x, k): Find the node whose label is k-th largest in the subtree of the node x. Assume no two nodes have the same labels. 输入 The first line contains one integer n (1 <= n <

bzoj 3772 精神污染 主席树+dfs序

精神污染 Time Limit: 10 Sec  Memory Limit: 64 MBSubmit: 637  Solved: 177[Submit][Status][Discuss] Description 兵库县位于日本列岛的中央位置,北临日本海,南面濑户内海直通太平洋,中央部位是森林和山地,与拥有关西机场的大阪府比邻而居,是关西地区面积最大的县,是集经济和文化于一体的一大地区,是日本西部门户,海陆空交通设施发达.濑户内海沿岸气候温暖,多晴天,有日本少见的贸易良港神户港所在的神户市和曾是豪

P3899|主席树+dfs序

理解题意后分两种情况: 1.b在a的上方: min(dep[p]-1,k)*(ll)siz[p] 因为(p点上方肯定有父亲结点b,我们不用管b是谁) 2.b在a的下方: (dep(p)+1 ~ dep(p)+k矩形框内的所有点子树个数和 所以思路:主席树维护同一深度下的各个结点子树个数和:下标是深度,权值维护的是子树个数和:在dfs序in和out时间戳上建立主席树,把树上问题转变为区间序列问题,利用dfs序时间戳的性质(子树编号在入时间戳和出时间戳的区间内),查询以p为根子树:所以问题就转变为了

BZOJ 2809: [Apio2012]dispatching [主席树 DFS序]

传送门 题意:查询树上根节点值*子树中权值和$\le m$的最大数量 最大值是多少 求$DFS$序,然后变成区间中和$\le m$最多有几个元素,建主席树,然后权值线段树上二分就行了 $WA$:又把边表开小了..... 好吧我$zz$了有根树加无向边干什么.... #include<iostream> #include<cstdio> #include<cstring> #include<algorithm> using namespace std; #de