[POJ3096]Surprising Strings

试题描述

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

输入

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

输出

For each string of letters, output whether or not it is surprising using the exact output format shown below.

输入示例

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

输出示例

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.

数据规模及约定

见“输入

题解

n2 枚举一下长度和字母对,然后把字母对哈希一下,看是否出现重复。打个时间戳可以节省时间。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <stack>
#include <vector>
#include <queue>
#include <cstring>
#include <string>
#include <map>
#include <set>
using namespace std;

#define maxn 85
#define maxm 800
char S[maxn];
int has[maxm];

int main() {
	while(scanf("%s", S + 1) == 1) {
		int n = strlen(S + 1);
		if(n == 1 && S[1] == ‘*‘) break;
		bool ok = 1;
		memset(has, 0, sizeof(has));
		for(int l = 1; l < n; l++) {
			for(int i = 1; i + l <= n; i++) {
				int x = (S[i] - ‘A‘) * 26 + S[i+l] - ‘A‘;
				if(has[x] == l){ ok = 0; break; }
				has[x] = l;
			}
			if(!ok) break;
		}
		printf("%s%s\n", S + 1, ok ? " is surprising." : " is NOT surprising.");
	}

	return 0;
}
时间: 2024-08-06 07:57:17

[POJ3096]Surprising Strings的相关文章

Surprising Strings

Surprising Strings Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 7403 Accepted: 4735 Description The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its

POJ 3096 Surprising Strings

Surprising Strings Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 7225   Accepted: 4663 Description The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of

[ACM] POJ 3096 Surprising Strings (map的使用)

Surprising Strings Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 5783   Accepted: 3792 Description The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of

C - Surprising Strings

                               C - Surprising Strings 题意:输入一段字符串,假设在同一距离下有两个字符串同样输出Not surprising ,否则输出surprising. Description The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-uniq

HDU 2736 Surprising Strings

Surprising Strings Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Description The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-

[ACM] POJ 3096 Surprising Strings (map使用)

Surprising Strings Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 5783   Accepted: 3792 Description The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of

【TOJ 2176】Surprising Strings

描述 The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D. Consider the

POJ 3096-Surprising Strings(set)

Surprising Strings Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 5940   Accepted: 3894 Description The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of

poj-3096-Suprising Strings

poj-3096-Suprising Strings Surprising Strings Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 7456   Accepted: 4765 Description The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A st