TOJ-1307 Crashing Balloon

On every June 1st, the Children‘s Day, there will be a game named "crashing balloon" on TV. The rule is very simple. On the ground there are 100 labeled balloons, with the numbers 1 to 100. After the referee shouts "Let‘s go!" the two players, who each starts with a score of "1", race to crash the balloons by their feet and, at the same time, multiply their scores by the numbers written on the balloons they crash. After a minute, the little audiences are allowed to take the remaining balloons away, and each contestant reports his/her score, the product of the numbers on the balloons he/she‘s crashed. The unofficial winner is the player who announced the highest score.

Inevitably, though, disputes arise, and so the official winner is not determined until the disputes are resolved. The player who claims the lower score is entitled to challenge his/her opponent‘s score. The player with the lower score is presumed to have told the truth, because if he/she were to lie about his/her score, he/she would surely come up with a bigger better lie. The challenge is upheld if the player with the higher score has a score that cannot be achieved with balloons not crashed by the challenging player. So, if the challenge is successful, the player claiming the lower score wins.

So, for example, if one player claims 343 points and the other claims 49, then clearly the first player is lying; the only way to score 343 is by crashing balloons labeled 7 and 49, and the only way to score 49 is by crashing a balloon labeled 49. Since each of two scores requires crashing the balloon labeled 49, the one claiming 343 points is presumed to be lying.

On the other hand, if one player claims 162 points and the other claims 81, it is possible for both to be telling the truth (e.g. one crashes balloons 2, 3 and 27, while the other crashes balloon 81), so the challenge would not be upheld.

By the way, if the challenger made a mistake on calculating his/her score, then the challenge would not be upheld. For example, if one player claims 10001 points and the other claims 10003, then clearly none of them are telling the truth. In this case, the challenge would not be upheld.

Unfortunately, anyone who is willing to referee a game of crashing balloon is likely to get over-excited in the hot atmosphere that he/she could not reasonably be expected to perform the intricate calculations that refereeing requires. Hence the need for you, sober programmer, to provide a software solution.

Input

Pairs of unequal, positive numbers, with each pair on a single line, that are claimed scores from a game of crashing balloon.

Output

Numbers, one to a line, that are the winning scores, assuming that the player with the lower score always challenges the outcome.

Sample Input

343 49
3599 610
62 36

Sample Output

49
610
62

Source: South Central USA
1998

给两个数,m>n,若n可被100内的数分解,且m不可被100内其他数分解,输出n,否则输出m。

#include <stdio.h>
bool bf,lf;
void dfs(int m,int n,int factor){
    if(m==1 && n==1){//两个都被完全因式分解
        bf = lf = true;
        return;
    }
    if(n==1)//小数被分解完,大数还未被分解完
        lf = true;
    while(factor>1){
        if(m%factor==0) dfs(m/factor,n,factor-1);
        if(n%factor==0) dfs(m,n/factor,factor-1);
        factor--;
    }
}
int main(){
    int m,n;
    while(~scanf("%d%d",&m,&n)){
        if(m<n){
            int t = m;
            m = n;
            n = t;
        }
        bf = lf = false;
        dfs(m,n,100);
        if(!bf && lf)
            printf("%d\n",n);
        else
            printf("%d\n",m);
    }
    return 0;
}
时间: 2024-08-05 12:36:23

TOJ-1307 Crashing Balloon的相关文章

ZOJ1003 Crashing Balloon

Crashing Balloon Time Limit: 2 Seconds      Memory Limit: 65536 KB On every June 1st, the Children's Day, there will be a game named "crashing balloon" on TV.   The rule is very simple.  On the ground there are 100 labeled balloons, with the num

【ZOJ1003】Crashing Balloon(DFS)

Crashing Balloon Time Limit: 2 Seconds      Memory Limit: 65536 KB On every June 1st, the Children's Day, there will be a game named "crashing balloon" on TV.   The rule is very simple.  On the ground there are 100 labeled balloons, with the num

ZOJ1003: Crashing Balloon

Time Limit: 2 Seconds Memory Limit: 65536 KB On every June 1st, the Children's Day, there will be a game named "crashing balloon" on TV.   The rule is very simple.  On the ground there are 100 labeled balloons, with the numbers 1 to 100.  After

1003 Crashing Balloon

考察DFS的应用,判断两个数的因子. 1 #include <stdio.h> 2 3 int f1,f2; 4 5 void DFS(int m,int n,int k){ 6 if(n==1){ 7 f2=1; 8 if(m==1) 9 f1=1; 10 } 11 if(f1&&f2||k==1) 12 return; 13 if(m%k==0) 14 DFS(m/k,n,k-1); 15 if(n%k==0) 16 DFS(m,n/k,k-1); 17 DFS(m,n,k

zoj 1003 Crashing Balloon

#include<stdio.h> #include<algorithm> using namespace std; int fa,fb; void dfs(int a,int b,int k) { if(b==1) { fb=1; if(a==1) fa=1; } if(k==1||(fa&&fb)) return ; if(a%k==0) dfs(a/k,b,k-1); if(b%k==0) dfs(a,b/k,k-1); dfs(a,b,k-1); } int

ZJU-1003 Crashing Balloon dfs,

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3 题意(难以描述):A,B两个人从1~100选数乘起来比谁的大(不能选重复的或者对方选的).数小的人如果发现数大的人在撒谎,则他可以获胜.(当然都没撒谎大数赢,都撒谎了也是大数赢233)而他判断大数撒谎的方法就是找到自己选的一个数,是构成大数所必须的./*给你两个数,由1~100选取不重复的数乘起来得到的.如果小的那个数包含了某个大数必须包含的因子,则*/ 题解:从1到100

杭电ACM分类

杭电ACM分类: 1001 整数求和 水题1002 C语言实验题——两个数比较 水题1003 1.2.3.4.5... 简单题1004 渊子赛马 排序+贪心的方法归并1005 Hero In Maze 广度搜索1006 Redraiment猜想 数论:容斥定理1007 童年生活二三事 递推题1008 University 简单hash1009 目标柏林 简单模拟题1010 Rails 模拟题(堆栈)1011 Box of Bricks 简单题1012 IMMEDIATE DECODABILITY

POJ百道水题列表

以下是poj百道水题,新手可以考虑从这里刷起 搜索1002 Fire Net1004 Anagrams by Stack1005 Jugs1008 Gnome Tetravex1091 Knight Moves1101 Gamblers1204 Additive equations 1221 Risk1230 Legendary Pokemon1249 Pushing Boxes 1364 Machine Schedule1368 BOAT1406 Jungle Roads1411 Annive

【转】对于杭电OJ题目的分类

[好像博客园不能直接转载,所以我复制过来了..] 1001 整数求和 水题1002 C语言实验题——两个数比较 水题1003 1.2.3.4.5... 简单题1004 渊子赛马 排序+贪心的方法归并1005 Hero In Maze 广度搜索1006 Redraiment猜想 数论:容斥定理1007 童年生活二三事 递推题1008 University 简单hash1009 目标柏林 简单模拟题1010 Rails 模拟题(堆栈)1011 Box of Bricks 简单题1012 IMMEDI