杭电 HDU ACM 5186 zhx's submissions

zhx‘s submissions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1892    Accepted Submission(s): 507

Problem Description

As one of the most powerful brushes, zhx submits a lot of code on many oj and most of them got AC.

One day, zhx wants to count how many submissions he made on
n
ojs. He knows that on the ith
oj, he made ai
submissions. And what you should do is to add them up.

To make the problem more complex, zhx gives you n
B?base
numbers and you should also return a B?base
number to him.

What‘s more, zhx is so naive that he doesn‘t carry a number while adding. That means, his answer to
5+6
in 10?base
is 1.
And he also asked you to calculate in his way.

Input

Multiply test cases(less than
1000).
Seek EOF
as the end of the file.

For each test, there are two integers n
and B
separated by a space. (1≤n≤100,
2≤B≤36)

Then come n lines. In each line there is a B?base
number(may contain leading zeros). The digits are from
0
to 9
then from a
to z(lowercase).
The length of a number will not execeed 200.

Output

For each test case, output a single line indicating the answer in
B?base(no
leading zero).

Sample Input

2 3
2
2
1 4
233
3 16
ab
bc
cd

Sample Output

1
233
14

Source

BestCoder Round #33

浪费了好几个小时 从理解题意,题目意思是b进制数相加,每位相加结果不进位。只保留sum mod b的结果,且保证最后结果没有前置0;可以采用倒叙相加。看了看网上的代码,

感觉写的还挺简单了!

#include<iostream>
#include<string.h>
using namespace std;
int main()
{
	int n,b ;char ls[250][250],gq[250][250];

	while(cin>>n>>b)
	{
		int len, L=-1;
	memset(ls,0,sizeof(ls));
	memset(gq,0,sizeof(gq));
		for(int i=0;i<n;i++)
		{
			scanf("%s",ls[i]);
			 len=strlen(ls[i]);
			if(len>L)
				L=len;
			for(int j=0;j<len;j++)
			{
				gq[i][len-1-j]=ls[i][j];
			}
		}
		int sum=0;int flag=0;
		for(int k=L-1;k>=0;k--)
		{
			sum=0;
			for(int m=0;m<n;m++)
			{
				if(gq[m][k]<='9'&&gq[m][k]>='0')
					sum+=gq[m][k]-48;
				else if(gq[m][k]>=65&&gq[m][k]<='z')
					sum+=gq[m][k]+10-'a';
			}

			sum%=b;
			if(sum>9)
			{
				printf("%c",sum-10+'a');
				flag=1;
			}
			else
			{
				if(sum)
					flag=1;//注意只要在尚未发现第一个不为0得数之前都不能输出!!!不能有前置0!wa至少五次!
				if(flag)
					printf("%d",sum);
			}
		}
			if(!flag)
				cout<<0;

		cout<<endl;

	}
return 0;
}

杭电 HDU ACM 5186 zhx's submissions

时间: 2024-10-11 01:41:07

杭电 HDU ACM 5186 zhx's submissions的相关文章

杭电 HDU ACM 1397 Goldbach&#39;s Conjecture

Goldbach's Conjecture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4976    Accepted Submission(s): 1901 Problem Description Goldbach's Conjecture: For any even number n greater than or equal

杭电 HDU ACM 1025 Constructing Roads In JGShining&#39;s Kingdom

Constructing Roads In JGShining's Kingdom Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 17732    Accepted Submission(s): 5023 Problem Description JGShining's kingdom consists of 2n(n is no mo

杭电HDU ACM Uncle Tom&#39;s Inherited Land*(二分图匹配 建模)

Uncle Tom's Inherited Land* Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 2496    Accepted Submission(s): 1028 Special Judge Problem Description Your old uncle Tom inherited a piece of land f

杭电 HDU ACM 圆桌会议

圆桌会议 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3356    Accepted Submission(s): 2351 Problem Description HDU ACM集训队的队员在暑假集训时经常要讨论自己在做题中遇到的问题.每当面临自己解决不了的问题时,他们就会围坐在一张圆形的桌子旁进行交流,经过大家的讨论后一般没有

杭电 HDU ACM 1046 Tempter of the Bone

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 83458    Accepted Submission(s): 22740 Problem Description The doggie found a bone in an ancient maze, which fascinated him a

杭电 HDU ACM 1496 Equations

Equations Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 6065    Accepted Submission(s): 2455 Problem Description Consider equations having the following form: a*x1^2+b*x2^2+c*x3^2+d*x4^2=0 a,

杭电 HDU ACM 1283 最简单的计算机

最简单的计算机 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5238    Accepted Submission(s): 2967 Problem Description 一个名叫是PigHeadThree的研究组织设计了一台实验用的计算机,命名为PpMm.PpMm只能执行简单的六种命令A,B,C,D,E,F:只有二个内存M1,M

杭电 HDU ACM 1213 How Many Tables

How Many Tables Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 17049    Accepted Submission(s): 8349 Problem Description Today is Ignatius' birthday. He invites a lot of friends. Now it's dinn

杭电 HDU ACM 1407 测试你是否和LTC水平一样高

测试你是否和LTC水平一样高 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 14276    Accepted Submission(s): 4701 Problem Description 大家提到LTC都佩服的不行,不过,如果竞赛只有这一个题目,我敢保证你和他绝对在一个水平线上! 你的任务是: 计算方程x^2+y^2+z^2= n