133 - The Dole Queue

The Dole Queue

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1’s left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3

0 0 0

Sample output

4 8, 9 5, 3 1, 2 6, 10, 7

where represents a space.

n(n<20)个人站成一圈,逆时针编号为1~n。有两个官员,A从1开始逆时针数,B从n开始顺时针数。在每一轮中,官员A数k个就停下来,官员B数m个就停下来(注意有可能两个官员停在同一个人上)。接下来被官员选中的人(1个或者2个)离开队伍。输入n,k,m输出每轮里被选中的人的编号(如果有两个人,先输出被A选中的)。例如,n=10,k=4,m=3,输出为4 8, 9 5, 3 1, 2 6, 10, 7。注意:输出的每个数应当恰好占3列。

#include <stdio.h>
#include <string.h>
#define maxNum 25
// N为人数,k为军官1数的间隔人数
// m为军官2数的间隔人数
int N,k,m;
// 标记数组
int mark[maxNum];
// 剩余人数
int num;
// 军官1和军官2的当前位置
int kpos;
int mpos;
void choice() {
    int kt = k - 1;
    int mt = m - 1;
    while(kt || mark[kpos]) {
        if(!mark[kpos]) {
            kt--;
        }
        kpos++;
        if(kpos >= N + 1) {
            kpos = 1;
        }
    }
    while(mt || mark[mpos]) {
        if(!mark[mpos]) {
            mt--;
        }
        mpos--;
        if(mpos <= 0) {
            mpos = N;
        }
    }
    if (kpos == mpos && !mark[kpos]) {
        printf(" %c%c", (kpos) / 10 ? (kpos) / 10 + ‘0‘ : ‘ ‘, (kpos) % 10 + ‘0‘);
        mark[kpos] = 1;
        num--;
    } else if (kpos != mpos) {
        if(!mark[kpos]) {
            printf(" %c%c", (kpos) / 10 ? (kpos) / 10 + ‘0‘ : ‘ ‘, (kpos) % 10 + ‘0‘);
            mark[kpos] = 1;
            num--;
        }
        if(!mark[mpos]) {
            printf(" %c%c", (mpos) / 10 ? (mpos) / 10 + ‘0‘ : ‘ ‘, (mpos) % 10 + ‘0‘);
            mark[mpos] = 1;
            num--;
        }
    }
    if(num) {
        printf(",");
    } else {
        printf("\n");
    }
}

int main() {
    while(scanf("%d%d%d", &N, &k, &m) == 3 && N != 0) {
        // 每回合都重置标记数组
        memset(mark, 0, sizeof(mark));
        kpos = 1;
        mpos = N;
        num = N;
        while(num) {
            choice();
        }
    }

    return 0;
}
时间: 2024-08-24 04:09:42

133 - The Dole Queue的相关文章

UVa 133 The Dole Queue

 The Dole Queue  In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone i

UVA - 133 The Dole Queue(模拟链表)

点击打开链接 n的人围成一个环,然后按逆时针编号1-n,一个人从1开始逆时针数k个数,另一个人从N开始顺时针数m个数,然后 数出来的两个人出列(两个人可能一样)出列,然后继续此过程,直到全部人都出列为止. 思路是用循环链表来模拟,注意 要分情况来讨论. #include <iostream> #include <cstdio> #include <cmath> #include <vector> #include <cstring> #inclu

uva - 133 The Dole Queue(成环状态下的循环走步方法)

类型:循环走步 1 #include <iostream> 2 #include <sstream> 3 #include <cstdio> 4 #include <cstring> 5 #include <cmath> 6 #include <string> 7 #include <vector> 8 #include <set> 9 #include <cctype> 10 #include &

The Dole Queue UVA - 133

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily cho

uva133 The Dole Queue ( 约瑟夫环的模拟)

题目链接: 啊哈哈,选我选我 思路是: 相当于模拟约瑟夫环,仅仅只是是从顺逆时针同一时候进行的,然后就是顺逆时针走能够编写一个函数,仅仅只是是走的方向的标志变量相反..还有就是为了(pos+flag+n-1)%n+1的妙用... 题目:  The Dole Queue  In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decid

uva The Dole Queue

题目如下: The Dole Queue  In a serious attempt to downsize (reduce) the dole queue, The NewNational Green Labour Rhinoceros Party has decided on the followingstrategy. Every day all dole applicants will be placed in a largecircle, facing inwards. Someone

The Dole Queue

Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu Submit cid=1036#status//A/0" class="ui-button ui-widget ui-state-default ui-corner-all ui-button-text-only" style="font-family:Verdana,Arial,sans-serif; font-si

Uva133 - The Dole Queue

题意 n个人围城一个环,逆时针编号1~n,A从1开始逆时针数K个,B从n顺时针数M个,被选中的1或2个人一次领救济金,输出顺序 思路 双向约瑟夫环,公式没推出来,用的模拟 总结 开始用的数组模拟链表写的,WA了,打算再改改.不知道为什么这道题卡了很久总不对. 模拟: 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 #include <algorithm> 5 using nam

&#183;读书笔记」 具体数学

头脑一热,然后买了<具体数学>,差点还买了英文版后来觉得自己英文太烂,还是决定购买的中文版书是前几天到的,从2014.8.1号开始看,坚持每天看一点,学习一点.为了监督自己,决定在这里开一贴,记录我的学习路程. 时间:2014.8.1  地点:家里 今天阅读的是本书的第一章,讲的是递归问题,也是算法的基础,当然这里主要讲的是数学.但是没办法,我是一名ACMer,必须要和程序紧密联系在一起.我觉得明天还需要花一天时间来看这章,需要解决下后面的习题以及再加深点体会. 第一章 递归问题 1.1 汉诺