HDU 1032 The 3n + 1 problem (这个题必须写博客)

The 3n + 1 problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22148    Accepted Submission(s): 8276

Problem Description

Problems
in Computer Science are often classified as belonging to a certain
class of problems (e.g., NP, Unsolvable, Recursive). In this problem you
will be analyzing a property of an algorithm whose classification is
not known for all possible inputs.

Consider the following algorithm:

1.      input n

2.      print n

3.      if n = 1 then STOP

4.           if n is odd then n <- 3n + 1

5.           else n <- n / 2

6.      GOTO 2

Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It
is conjectured that the algorithm above will terminate (when a 1 is
printed) for any integral input value. Despite the simplicity of the
algorithm, it is unknown whether this conjecture is true. It has been
verified, however, for all integers n such that 0 < n < 1,000,000
(and, in fact, for many more numbers than this.)

Given an input
n, it is possible to determine the number of numbers printed (including
the 1). For a given n this is called the cycle-length of n. In the
example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

Input

The
input will consist of a series of pairs of integers i and j, one pair
of integers per line. All integers will be less than 1,000,000 and
greater than 0.

You should process all pairs of integers and for
each pair determine the maximum cycle length over all integers between
and including i and j.

You can assume that no opperation overflows a 32-bit integer.

Output

For
each pair of input integers i and j you should output i, j, and the
maximum cycle length for integers between and including i and j. These
three numbers should be separated by at least one space with all three
numbers on one line and with one line of output for each line of input.
The integers i and j must appear in the output in the same order in
which they appeared in the input and should be followed by the maximum
cycle length (on the same line).

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174

Source

UVA

算法分析:

这道题拿出时间写过好几次,提交都WA了! 以为自己写的算法真的有问题!后来在刘汝佳写的书上又看到了这道题,于是又敲,

最后终于AC了!

此题有两个坑: 1,读入的n和m, 大小不确定需要判断是否交换。   2,假设说 n>m, 这是要交换n和m, 但是在输出的时候仍要

先输出先读入的大数n, 再输出小的m, 也就是没交换钱的顺序!

就因为这两点,这道简单题的题,我不知道错了多少遍!   并且还要注意一点,就是n*3+1是否会超出int类型!

Accepted的代码:

#include <stdio.h>
#include <string.h>
#include <math.h>

long long cnt;
int max;

void jishu(int dd)
{
    long long ff=dd;
    cnt++;
    while(ff>1)
    {
        if(ff%2==1)
          ff=3*ff+1;
        else
          ff/=2;
        cnt++;
    }

    if(cnt>max)
    {
      max=cnt;
    }
    cnt=0;
}
int main()
{
    int n, m;
    int i, j;
    while(scanf("%d %d", &n, &m)!=EOF)
    {
        cnt=0;
        max=0;
        printf("%d %d ", n, m );
        if(n>m)
        {
            n=n^m; m=m^n; n=n^m;
        }
        for(i=n; i<=m; i++)
        {
            jishu(i);
        }
        printf("%d\n", max );
    }
    return 0;
}
时间: 2024-10-08 17:27:58

HDU 1032 The 3n + 1 problem (这个题必须写博客)的相关文章

hdu 1032 The 3n + 1 problem (打表)

The 3n + 1 problem Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 26353    Accepted Submission(s): 9784 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1032 Problem Description Problems in Comp

HDU 1032.The 3n + 1 problem【注意细节】【估计数据不强】【8月21】

The 3n + 1 problem Problem Description Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classificat

HDU 1032.The 3n + 1 problem【注意细节】【预计数据不强】【8月21】

The 3n + 1 problem Problem Description Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classificat

HDU 1032 The 3n + 1 problem【递归】

/* 中文题目 3n+1问题 中文翻译-大意 当一个数n是奇数的时候变成3*n+1,为偶数的时候变成n/2 解题思路:区间内每个数逐个求解 难点详解:如何逐个计算每个数的次数,选用while循环,还有就是将此时的 i 值赋给data,用于while循环的条件.最后再将这一个数运算次数累加在一起 关键点:理解题意 解题人:lingnichong 解题时间:2014-06-03 09:40:39 解题体会:没有告诉你那个大那个小,要先比较一下数,是个陷阱 */ The 3n + 1 problem

HDU 1032 [The 3n + 1 problem] 暴力模拟

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1032 题目大意:给出i,j,要求输出i j之间"3N+1"的循环次数的最大值. 关键思想:暴力,模拟.可以优化,因为某些大数在进行操作时,会变为已经求过的小数,之后的循环次数已求过. 代码如下: //between i,j 模拟,暴力 #include <iostream> #include <algorithm> using namespace std; int

题解报告:hdu 1032 The 3n + 1 problem

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1032 解题思路:这道题的意思就是输入一个区间i,j找出这里面的最长周期:周期是这样子:当这个数(不为1)是奇数时就变为3*n+1,为偶数时就变为n/2,并且用sum来计数周期,直到n为1就跳出.(水题!!!注意杭电oj出题的一些坑) AC代码: 1 #include<bits/stdc++.h> 2 using namespace std; 3 int main() 4 { 5 int a,b,s

(HDU/UVA)1032/100--The 3n + 1 problem(3n+1问题)

描述计算机科学中的问题通常被归类为属于某一类问题(例如,NP,不可解,递归).在这个问题中,您将分析算法的属性,该算法的分类对于所有可能的输入都是未知的. 考虑下面的算法: 1.输入n 2.输出n 3.如果n = 1,则停止 4.如果n是奇数,则n=3n + 1 5.否则n=n / 2 6.返回第2步 给定输入22,将输出以下序列的数字22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 据推测,使用上述算法任何输入值将终止(当输出1时).尽管算法简单,但是不知道

Hdu oj 1032 The 3n + 1 problem

题目:点击打开链接 分析:注意细节. #include<stdio.h> int a1[1000010]; int calcue(int x) { int len=1; while(x!=1) { if(x%2==0) { x=x/2; len+=1; } if(x==1) return len; if(x%2==1) { x=3*x+1; len+=1; } if(x==1) return len; } return len; } int main() { int m,n; while(~s

HDOJ 1032 The 3n + 1 problem(水)

[题意]:获得最大循环长度. [注意]:题目并不是一定按照第一二个数小于等于第二个数输入.如果不是,需要交换..虽然这种数据感觉很无聊不过在题目中有提示的,The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).