Easier Done Than Said? 【杭电-1039】

/*

Easier Done Than Said?

Problem DescriptionPassword security is a tricky thing. Users prefer simple passwords

that are easy to remember (like buddy), but such passwords are often insecure. Some

sites use random computer-generated passwords (like xvtpzyo), but users have a hard

time remembering them and sometimes leave them written on notes stuck to their computer.

One potential solution is to generate "pronounceable" passwords that are relatively secure

but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department,

and it‘s your job to test the generator and make sure that the passwords are acceptable. To

be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for ‘ee‘ or ‘oo‘.

(For the purposes of this problem, the vowels are ‘a‘, ‘e‘, ‘i‘, ‘o‘, and ‘u‘; all other letters

are consonants.) Note that these rules are not perfect; there are many common/pronounceable words

that are not acceptable.

InputThe input consists of one or more potential passwords, one per line, followed by a line

containing only the word ‘end‘ that signals the end of the file. Each password is at least one

and at most twenty letters long and consists only of lowercase letters.

OutputFor each password, output whether or not it is acceptable, using the precise format shown

in the example.

Sample Input

a

tv

ptoui

bontres

zoggax

wiinq

eep

houctuh

end

Sample Output

<a> is acceptable.

<tv> is not acceptable.

<ptoui> is not acceptable.

<bontres> is not acceptable.

<zoggax> is not acceptable.

<wiinq> is not acceptable.

<eep> is acceptable.

<houctuh> is acceptable.

*/

#include<stdio.h>

#include<string.h>

#define N 25

int fun(char p){

if(p==‘a‘||p==‘e‘||p==‘i‘||p==‘o‘||p==‘u‘)

return 1;

return 0;

}

int gun(int a[],int len){

int i,t;

int flag=0;

for(i=0;i<len-2;i++){

t=a[i]+a[i+1]+a[i+2];

if((t==0)||(t==3)){

flag=1;

break;

}

}

return flag;

}

int hun(char s[]){

int i,len;

int flag=0;

len=strlen(s);

for(i=0;i<len-1;i++){

if((s[i]==s[i+1])&&((s[i]!=‘e‘)&&(s[i]!=‘o‘))){

flag=1;

break;

}

}

return flag;

}

int main(){

char str[N]={0};

scanf("%s",str);

while(strcmp(str,"end")){

int count=0;

int a[20]={0};

int len=0;

len=strlen(str);

//while(scanf("%s",str),str!="end"){

for(int i=0;i<len;i++){

if(fun(str[i])){

a[i]=1;

if(!count)  count=1;

}

else       a[i]=0;

}

if(!count)        printf("<%s> is not acceptable.\n",str);

else if(gun(a,len))

printf("<%s> is not acceptable.\n",str);

else if(hun(str))

printf("<%s> is not acceptable.\n",str);

else               printf("<%s> is acceptable.\n",str);

scanf("%s",str);

}

return 0;

}

Easier Done Than Said? 【杭电-1039】

时间: 2024-11-11 09:17:44

Easier Done Than Said? 【杭电-1039】的相关文章

Easier Done Than Said? 【杭电-1039】 附题

/* Easier Done Than Said? Problem DescriptionPassword security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xv

杭电ACM分类

杭电ACM分类: 1001 整数求和 水题1002 C语言实验题——两个数比较 水题1003 1.2.3.4.5... 简单题1004 渊子赛马 排序+贪心的方法归并1005 Hero In Maze 广度搜索1006 Redraiment猜想 数论:容斥定理1007 童年生活二三事 递推题1008 University 简单hash1009 目标柏林 简单模拟题1010 Rails 模拟题(堆栈)1011 Box of Bricks 简单题1012 IMMEDIATE DECODABILITY

杭电1212--Big Number

Big Number Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 5961    Accepted Submission(s): 4167 Problem Description As we know, Big Number is always troublesome. But it's really important in our

杭电ACM题目分类

杭电ACM题目分类 基础题:1000.1001.1004.1005.1008.1012.1013.1014.1017.1019.1021.1028. 1029.1032.1037.1040.1048.1056.1058.1061.1070.1076.1089.1090.1091.1092. 1093.1094.1095.1096.1097.1098.1106.1108.1157.1163.1164.1170.1194.1196. 1197.1201.1202.1205.1219.1234.123

【转】对于杭电OJ题目的分类

[好像博客园不能直接转载,所以我复制过来了..] 1001 整数求和 水题1002 C语言实验题——两个数比较 水题1003 1.2.3.4.5... 简单题1004 渊子赛马 排序+贪心的方法归并1005 Hero In Maze 广度搜索1006 Redraiment猜想 数论:容斥定理1007 童年生活二三事 递推题1008 University 简单hash1009 目标柏林 简单模拟题1010 Rails 模拟题(堆栈)1011 Box of Bricks 简单题1012 IMMEDI

Big Number------HDOJ杭电1212(大数运算)

Problem Description As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B. To make the problem easier, I promise that B will be smaller than 100000. Is it t

杭电 HDU ACM 1212 Big Number

Big Number Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5606    Accepted Submission(s): 3903 Problem Description As we know, Big Number is always troublesome. But it's really important in ou

杭电 HDU 1164 Eddy&#39;s research I

Eddy's research I Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7117    Accepted Submission(s): 4268 Problem Description Eddy's interest is very extensive, recently  he is interested in prime

hdu 1016 Prime Ring Problem DFS解法 纪念我在杭电的第一百题

Prime Ring Problem Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 29577    Accepted Submission(s): 13188 Problem Description A ring is compose of n circles as shown in diagram. Put natural num