[LOJ 1008] Fibsieve`s Fantabulous Birthday

A - Fibsieve`s Fantabulous Birthday

Time Limit:500MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Fibsieve had a fantabulous (yes, it‘s an actual word) birthday party this year. He had so many gifts that he was actually thinking of not having a party next year.

Among these gifts there was an N x N glass chessboard that had a light in each of its cells. When the board was turned on a distinct cell would light up every second, and then go dark.

The cells would light up in the sequence shown in the diagram. Each cell is marked with the second in which it would light up.

(The numbers in the grids stand for the time when the corresponding cell lights up)

In the first second the light at cell (1, 1) would be on. And in the 5th second the cell (3, 1) would be on. Now, Fibsieve is trying to predict which cell will light up at a certain time (given in seconds). Assume that N is large enough.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case will contain an integer S (1 ≤ S ≤ 1015) which stands for the time.

Output

For each case you have to print the case number and two numbers (x, y), the column and the row number.

Sample Input

3

8

20

25

Sample Output

Case 1: 2 3

Case 2: 5 4

Case 3: 1 5

题意:给出一张图,以及一个点,求出这个点的坐标

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
#define ll long long

ll n;

void solve()
{
    ll floor=(ll)sqrt(n);
    if(floor*floor!=n) floor++; //确定层数
    ll dir=floor&1;             //确定方向,0表示左右下,1表示下上左
    ll num=n-((floor-1)*(floor-1)); //当前层序号
    if(dir==0)
    {
        if(num<=floor)
        {
            printf("%lld %lld\n",num,floor);
        }
        else
        {
            num=floor-(num-floor);
            printf("%lld %lld\n",floor,num);
        }
    }
    else
    {
        if(num<=floor)
        {
            printf("%lld %lld\n",floor,num);
        }
        else
        {
            num=floor-(num-floor);
            printf("%lld %lld\n",num,floor);
        }
    }
}
int main()
{
    int T,iCase=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lld",&n);
        printf("Case %d: ",iCase++);
        solve();
    }
    return 0;
}
时间: 2024-08-09 02:04:48

[LOJ 1008] Fibsieve`s Fantabulous Birthday的相关文章

Lihht OJ ---Fibsieve`s Fantabulous Birthday(找规律,数学)

1008 - Fibsieve`s Fantabulous Birthday http://www.lightoj.com/volume_showproblem.php?problem=1008 1008 - Fibsieve`s Fantabulous Birthday   PDF (English) Statistics Forum Time Limit: 0.5 second(s) Memory Limit: 32 MB Fibsieve had a fantabulous (yes, i

LightOJ 1008

1008 - Fibsieve`s Fantabulous Birthday Fibsieve had a fantabulous (yes, it's an actual word) birthday party this year. He had so many gifts that he was actually thinking of not having a party next year. Among these gifts there was an N x N glass ches

lightoj Beginners Problems

很多以前写的丑代码 1000 - Greetings from LightOJ #include<math.h> #include<stdio.h> #include<stdlib.h> #include<string.h> int main(void) { int a,b,n,Case; scanf("%d",&n); Case=0; while(Case++,n--) { scanf("%d%d",&

light oj Beginners Problems

很多以前写的丑代码 1000 - Greetings from LightOJ #include<math.h> #include<stdio.h> #include<stdlib.h> #include<string.h> int main(void) { int a,b,n,Case; scanf("%d",&n); Case=0; while(Case++,n--) { scanf("%d%d",&

LightOJ Beginners Problems 部分题解

相关代码请戳 https://coding.net/u/tiny656/p/LightOJ/git 1006 Hex-a-bonacci. 用数组模拟记录结果,注意取模 1008 Fibsieve's Fantabulous Birthday. 找规律题,左边列是1 3平方 5平方......下边行是1 2平方 4平方......,找到当前数被包夹的位置,然后处理一下位置关系,注意奇偶. 1010 Kinghts in Chessboard. 规律题,对于m,n大于2的情况下,使用交叉放置的方法

Light 1008

H - 字 Time Limit:500MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu Submit Status Practice LightOJ 1008 Description Fibsieve had a fantabulous (yes, it's an actual word) birthday party this year. He had so many gifts that he was actually

LightOJ1008---Fibsieve`s Fantabulous Birthday (规律)

Fibsieve had a fantabulous (yes, it's an actual word) birthday party this year. He had so many gifts that he was actually thinking of not having a party next year. Among these gifts there was an N x N glass chessboard that had a light in each of its

1008. 数组元素循环右移问题 (20)

1008. 数组元素循环右移问题 (20) 一个数组A中存有N(N>0)个整数,在不允许使用另外数组的前提下,将每个整数循环向右移M(M>=0)个位置,即将A中的数据由(A0 A1--AN-1)变换为(AN-M -- AN-1 A0 A1--AN-M-1)(最后M个数循环移至最前面的M个位置).如果需要考虑程序移动数据的次数尽量少,要如何设计移动的方法? 输入格式:每个输入包含一个测试用例,第1行输入N ( 1<=N<=100).M(M>=0):第2行输入N个整数,之间用空格

杭电女生赛1001 1002 1003 1005 1008 hdu6023 6024 6025 6027 6030

代码先贴这里 #include "iostream" #include "string.h" #include "stack" #include "queue" #include "string" #include "vector" #include "set" #include "map" #include "algorithm&quo