(并查集) hdu 2473

Junk-Mail Filter

Time Limit: 15000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6389    Accepted Submission(s): 2025

Problem Description

Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.

Input

There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 105 , 1 ≤ M ≤ 106), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.

Output

For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.

Sample Input

5 6
M 0 1
M 1 2
M 1 3
S 1
M 1 2
S 3

3 1
M 1 2

0 0

Sample Output

Case #1: 3
Case #2: 2

Source

2008 Asia Regional Hangzhou

对于并查集

#include<iostream>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<cstdlib>
#include<cstdio>
#include<set>
using namespace std;
#define maxn 1000010
set<int> S;
int n,m,fa[maxn],id[maxn];
char s[2];
int find(int x)
{
      if(x!=fa[x])
            fa[x]=find(fa[x]);
      return fa[x];
}
void Union(int x,int y)
{
      int fx,fy;
      fx=find(x),fy=find(y);
      if(fx!=fy)
      {
            fa[fx]=fy;
      }
}
int main()
{
      int tt,a,b,cas=1;
      while(scanf("%d%d",&n,&m)!=EOF)
      {
            if(n==0&&m==0)
                  break;
            for(int i=0;i<=n;i++)
                  fa[i]=i,id[i]=i;
            int k=n+1;
            for(int i=0;i<m;i++)
            {
                  scanf("%s",s);
                  if(s[0]==‘M‘)
                  {
                        scanf("%d%d",&a,&b);
                        Union(id[a],id[b]);
                  }
                  else if(s[0]==‘S‘)
                  {
                        scanf("%d",&tt);
                        id[tt]=k;
                        fa[id[tt]]=id[tt];
                        k++;
                  }
            }
            S.clear();
            for(int i=0;i<n;i++)
            {
                  S.insert(find(id[i]));
            }
            printf("Case #%d: %d\n",cas,S.size());
            cas++;
      }
      return 0;
}

  

元素中删除操作,另开一个数组映射一下就ok

时间: 2024-08-14 11:52:46

(并查集) hdu 2473的相关文章

并查集 -- HDU 1232 UVALA 3644

并查集: 1 int pa[maxn],Rank[maxn]; 2 ///初始化 x 集合 3 void make_set(int x) 4 { 5 pa[x]=x; 6 Rank[x]=0; 7 } 8 ///递归查找 x 所在的集合 9 int find_set(int x) 10 { 11 if(pa[x]!=x) pa[x]=find_set(pa[x]); 12 return pa[x]; 13 } 14 ///更新根节点,如果不更新可能会暴栈 15 void mix(int x,in

集合问题 离线+并查集 HDU 3938

题目大意:给你n个点,m条边,q个询问,每条边有一个val,每次询问也询问一个val,定义:这样条件的两个点(u,v),使得u->v的的价值就是所有的通路中的的最长的边最短.问满足这样的点对有几个. 思路:我们先将询问和边全部都按照val排序,然后我们知道,并查集是可以用来划分集合的,所以我们就用并查集来维护每一个集合就行了. //看看会不会爆int!数组会不会少了一维! //取物问题一定要小心先手胜利的条件 #include <bits/stdc++.h> using namespac

并查集 hdu 1856

More is better Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others) Total Submission(s): 16863    Accepted Submission(s): 6205 Problem Description Mr Wang wants some boys to help him with a project. Because the projec

分组并查集 hdu 1829

A Bug's Life Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 10063    Accepted Submission(s): 3288 Problem Description Background Professor Hopper is researching the sexual behavior of a rare

(枚举+并查集) hdu 1598

find the most comfortable road Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4096    Accepted Submission(s): 1768 Problem Description XX星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure---超级

(并查集) hdu 4750

Count The Pairs Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)Total Submission(s): 952    Accepted Submission(s): 422 Problem Description   With the 60th anniversary celebration of Nanjing University of Science

(并查集) hdu 3038

How Many Answers Are Wrong Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2856    Accepted Submission(s): 1100 Problem Description TT and FF are ... friends. Uh... very very good friends -_____

(并查集) hdu 3635

Dragon Balls Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3443    Accepted Submission(s): 1342 Problem Description Five hundred years later, the number of dragon balls will increase unexpecte

(并查集) hdu 3461

Code Lock Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)Total Submission(s): 1308    Accepted Submission(s): 471 Problem Description A lock you use has a code system to be opened instead of a key. The lock contai