poj 3259

Wormholes










Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 28499   Accepted: 10302

Description

While exploring his many farms, Farmer John has discovered a number of
amazing wormholes. A wormhole is very peculiar because it is a one-way path that
delivers you to its destination at a time that is BEFORE you entered the
wormhole! Each of FJ‘s farms comprises N (1 ≤ N ≤ 500) fields
conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths,
and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at
some field, travel through some paths and wormholes, and return to the starting
field a time before his initial departure. Perhaps he will be able to meet
himself :) .

To help FJ find out whether this is possible or not, he will supply you with
complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will
take longer than 10,000 seconds to travel and no wormhole can bring FJ back in
time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F
farm descriptions follow.
Line 1 of each farm: Three space-separated
integers respectively: N, M, and W
Lines
2..M+1 of each farm: Three space-separated numbers (S,
E, T) that describe, respectively: a bidirectional path
between S and E that requires T seconds to traverse.
Two fields might be connected by more than one path.
Lines
M+2..M+W+1 of each farm: Three space-separated
numbers (S, E, T) that describe, respectively: A one
way path from S to E that also moves the traveler back
T seconds.

Output

Lines 1..F: For each farm, output "YES"
if FJ can achieve his goal, otherwise output "NO" (do not include the
quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

题意:John的农场里field块地,path条路连接两块地,hole个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。我们的任务是知道会不会在从某块地出发后又回来,看到了离开之前的自己。

思路:bellman_ford。由于存在负权边,Dijkstra便不能用了。题目简化下,就是看图中有没有负权环,有的话John可以无限次走这个环,使得时间一定能得到一个负值。所以有的存在负环话就是可以,没有的话就是不可以了。

#include <iostream>
#include <cstdio>
using namespace
std;
#define fMax 505
#define eMax 5205
#define wMax 99999

struct A
{
    int sta,end,time;
}edge[eMax];

int point_num,edge_num,dict[fMax];

bool bellman_ford()
{
   for(int
i=2;i<=point_num;i++)
     
dict[i]=wMax;
   for(int i=1;i<=point_num;i++)
  
{
       bool
fals=0;
       for(int
j=1;j<=edge_num;j++)
      
{
           int
v=edge[j].sta;
          
int
u=edge[j].end;
          
int
w=edge[j].time;
          
if(dict[v]>dict[u]+w)
          
{
              
dict[v]=dict[u]+w;
              
fals=1;
          
}
      
}
      
if(!fals)
       break;
  
}
   for(int
j=1;j<=edge_num;j++)
      
{
           int
v=edge[j].sta;
          
int
u=edge[j].end;
          
int
w=edge[j].time;
          
if(dict[v]>dict[u]+w)
          
{
              
dict[v]=dict[u]+w;
              
return 0;
          
}
      
}
       return 1;
}

int main()
{
    int farm;
   
scanf("%d",&farm);
    while(farm--)
   
{
        int
field,path,hole;
        scanf("%d %d
%d",&field,&path,&hole);
       
int s,e,t,k=0;
        for(int
i=1;i<=path;i++)
       
{
           
scanf("%d %d
%d",&s,&e,&t);
           
edge[++k].sta=s;
           
edge[k].end=e;
           
edge[k++].time=t;
           
edge[k].sta=e;
           
edge[k].end=s;
           
edge[k].time=t;
       
}
        for(int
i=1;i<=hole;i++)
       
{
           
scanf("%d %d
%d",&s,&e,&t);
           
edge[++k].sta=s;
           
edge[k].end=e;
           
edge[k].time=-t;
       
}
       
point_num=field;
       
edge_num=k;
       
if(!bellman_ford())
       
printf("YES\n");
       
else
        printf("NO\n");

}
    return 0;

}

poj 3259,布布扣,bubuko.com

时间: 2024-08-06 19:52:15

poj 3259的相关文章

POJ 3259 Wormholes SPFA算法题解

本题其实也可以使用SPFA算法来求解的,不过就一个关键点,就是当某个顶点入列的次数超过所有顶点的总数的时候,就可以判断是有负环出现了. SPFA原来也是可以处理负环的. 不过SPFA这种处理负环的方法自然比一般的Bellman Ford算法要慢点了. #include <stdio.h> #include <string.h> #include <limits.h> const int MAX_N = 501; const int MAX_M = 2501; const

ACM: POJ 3259 Wormholes - SPFA负环判定

POJ 3259 Wormholes Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu Description While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way pa

[2016-04-03][POJ][3259][Wormholes]

时间:2016-04-03 20:22:04 星期日 题目编号:[2016-04-03][POJ][3259][Wormholes] 题目大意:某农场有n个节点,m条边(双向)和w个虫洞(单向),(走虫洞可以回到过去的时间),问能否和过去的自己相遇 分析: 题目意思就是给定一个带负权的图,问是否存在负圈, spfa_bfs spfa_dfs bellman_ford #include <vector> #include <queue> #include <algorithm&

POJ 3259 Wormholes(SPFA)

Description While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Eac

【POJ 3259】Wormholes

[POJ 3259]Wormholes 判断负环--BellMan/SPFA 代码如下 BellMan-Ford #include <cstdio> #include <cstring> #define INF 0x3f3f3f3f using namespace std; typedef struct Edge { int u,v,w; }Edge; Edge eg[5555]; int dis[555],n,tp; bool BellMan() { memset(dis,INF

poj 3259(bellman最短路径)

Wormholes Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 30169   Accepted: 10914 Description While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way p

[ACM] POJ 3259 Wormholes (bellman-ford最短路径,判断是否存在负权回路)

Wormholes Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 29971   Accepted: 10844 Description While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way p

POJ 3259 Wormholes Bellman题解

本题就是需要检查有没有负环存在于路径中,使用Bellman Ford算法可以检查是否有负环存在. 算法很简单,就是在Bellman Ford后面增加一个循环判断就可以了. 题目故事很奇怪,小心读题. #include <stdio.h> #include <string.h> #include <limits.h> const int MAX_N = 501; const int MAX_M = 2501; const int MAX_W = 201; struct E

POJ 3259 Wormholes (图论---最短路 Bellman-Ford || SPFA)

链接:http://poj.org/problem?id=3259 Description While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BE