TOJ-1111 MPI Maelstrom

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee‘s research advisor, Jack Swigert, has asked her to benchmark the new system.

``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,‘‘ Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.‘‘

``How is Apollo‘s port of the Message Passing Interface (MPI) working out?‘‘ Swigert asked.

``Not so well,‘‘ Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.‘‘

``Is there anything you can do to fix that?‘‘

``Yes,‘‘ smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.‘‘

``Ah, so you can do the broadcast as a binary tree!‘‘

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don‘t necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.‘‘

Input

The input will describe the topology of a network
connecting n processors. The first line of the input will be n, the number of
processors, such that 1 ≤ n ≤ 100.

The rest of the input defines an adjacency matrix, A. The adjacency matrix is
square and of size n x n. Each of its entries will be either an integer or the
character x. The value of A(i,j) indicates the expense of sending a message
directly from node i to node j. A value of x for A(i,j) indicates that a message
cannot be sent directly from node i to node j.

Note that for a node to send a message to itself does not require network
communication, so A(i,i) = 0 for 1 ≤ i ≤ n. Also, you may assume that the
network is undirected (messages can go in either direction with equal overhead),
so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower
triangular portion of A will be supplied.

The input to your program will be the lower triangular section of A. That is,
the second line of input will contain one entry, A(2,1). The next line will
contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication
time required to broadcast a message from the first processor to all the other
processors.


Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35

Source: East Central
North America 1996

典型的迪杰斯特拉算法题目。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define MAX 110
#define INF 500000000
int a[MAX][MAX],d[MAX];//邻接矩阵和存始点到各点min距离的数组
void cmpdist(int n)//求始点到各点min距离
{
    bool cmpd[MAX];//从始点先到i点是否计算过
    cmpd[1] = true;
    d[1] = 0;
    for(int i = 2 ; i <= n ; i++)
    {
        d[i] = a[1][i] ;
        cmpd[i] = false ;
    }
    for(int i=1; i<=n; i++){
        int min = INF;
        int index = 0;
        for(int j=1; j<=n; j++){
            if(d[j] < min && !cmpd[j]){
                min = d[j];
                index = j;
            }
        }
        if(index == 0)
            break;
        cmpd[index] = true;
        for(int j = 1 ; j <= n ; j++)
        {
            if(d[j]>d[index]+a[index][j])
            {
                d[j] = d[index]+a[index][j] ;
            }
        }
    } 

}
int main()
{
    int n = 0 ;
    while(scanf("%d",&n) != EOF)
    {
        a[1][1] = 0 ;
        for(int i = 2 ; i <= n ; i++)
        {
            for(int j = 1 ; j < i ; j++)
            {
                char w[15] ;
                scanf("%s",w);
                if(w[0] != ‘x‘)
                    a[i][j] = a[j][i] = atoi(w) ;
                else
                    a[i][j] = a[j][i] = INF ;
            }
            a[i][i] = 0 ;
        }
        cmpdist(n);
        int ans = 0 ;
        for(int i = 2 ; i <= n ; i++)
        {
            if(d[i]>ans)
            {
                ans = d[i] ;
            }
        }
        printf("%d\n",ans) ;
    }

    return 0 ;
}

 

时间: 2025-01-07 20:05:34

TOJ-1111 MPI Maelstrom的相关文章

poj 1502 MPI Maelstrom Dijkstra算法的简单运用 ,呵呵,,我估计有很多人都没看懂什么意思,我也看了很久

MPI Maelstrom Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 5831   Accepted: 3621 Description BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchic

POJ 1502 MPI Maelstrom (最短路)

MPI Maelstrom Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 6329   Accepted: 3925 Description BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchic

MPI Maelstrom(poj1502)(迪杰斯特拉+atoi函数)

MPI Maelstrom Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 5637   Accepted: 3513 Description BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchic

MPI Maelstrom(East Central North America 1996)(poj1502)

MPI Maelstrom 总时间限制:  1000ms 内存限制:  65536kB 描述 BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor

POJ 1052 MPI Maelstrom

MPI Maelstrom Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 5547   Accepted: 3458 Description BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchic

POJ 1502 MPI Maelstrom [最短路 Dijkstra]

传送门 MPI Maelstrom Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 5711   Accepted: 3552 Description BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierar

POJ 1502 MPI Maelstrom (Dijkstra 模板题)

MPI Maelstrom Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 5877   Accepted: 3654 Description BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchic

poj 1502 MPI Maelstrom(最短路)

poj 1502 MPI Maelstrom Description BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swige

(简单) POJ 1502 MPI Maelstrom,Dijkstra。

Description BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to be