项目三

某公司有2栋办公楼,楼内各有2种类型的用户。2栋办公楼之间使用路由器进行互通,楼宇内各使用1块二层交换机把2种类型的用户连接起来。

请你按照下列要求完成公司需求。

1、两栋楼宇内的能够隔离两类人员的广播信息

2、两个楼宇之间能够互通信息(要求使用RIP实现)

所有网络产品均为Cisco

思路:对于每栋楼里的用户使用单臂路由使不同vlan间能够通信,然后运用rip协议是两个路由器相连的网络能够通信.拓扑图:

SW1


Switch>enable
Switch#configure terminal
Switch(config)#hostname SW1
SW1(config)#vlan 10
SW1(config-vlan)#name VLAN10
SW1(config-vlan)#exit
SW1(config)#vlan 20
SW1(config-vlan)#name VLAN20
SW1(config-vlan)#exit
SW1(config)#interface FastEthernet0/1
SW1(config-if)#switchport mode trunk
SW1(config-if)#exit
SW1(config)#interface FastEthernet0/2
SW1(config-if)#switchport access vlan 10
SW1(config-if)#exit
SW1(config)#interface FastEthernet0/11
SW1(config-if)#switchport access vlan 20
SW1(config-if)#

R1


Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface FastEthernet0/0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#int f0/0.10
R1(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up

R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip add 192.168.1.1 255.255.255.0
R1(config-subif)#exit
R1(config)#int f0/0.20
R1(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.20, changed state to up

R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip add 192.168.2.1 255.255.255.0
R1(config-subif)#end

R1#
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface Serial1/0
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface Serial1/0, changed state to up
clock rate 9600
R1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up

R1(config-if)#exit
R1(config)#route rip
R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.2.0
R1(config-router)#network 10.10.10.0
R1(config-router)#exit

R1(config)#interface Serial1/0
R1(config-if)#ip address 10.10.10.1 255.255.255.0

SW2


Switch>enable
Switch#configure terminal
Switch(config)#hostname SW2
SW2(config)#interface FastEthernet0/1
SW2(config-if)#switchport mode trunk
SW2(config-if)#exit
SW2(config)#vlan 30
SW2(config-vlan)#name VLAN30
SW2(config-vlan)#exit
SW2(config)#vlan 40
SW2(config-vlan)#name VLAN40
SW2(config-vlan)#exit
SW2(config)#interface FastEthernet0/2
SW2(config-if)#switchport access vlan 30
SW2(config-if)#exit
SW2(config)#interface FastEthernet0/11
SW2(config-if)#switchport access vlan 40

R2


Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface FastEthernet0/0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config-if)#
R2(config-if)#int f0/0.30
R2(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.30, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.30, changed state to up

R2(config-subif)#encapsulation dot1Q 30
R2(config-subif)#ip add 192.168.3.1 255.255.255.0
R2(config-subif)#exit
R2(config)#int f0/0.40
R2(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.40, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.40, changed state to up

R2(config-subif)#encapsulation dot1Q 40
R2(config-subif)#ip add 192.168.4.1 255.255.255.0
R2(config-subif)#end

R2#configure terminal
R2(config)#interface Serial1/0
R2(config-if)#no shutdown
R2(config-if)#clock rate 9600
This command applies only to DCE interfaces
R2(config-if)#
%LINK-5-CHANGED: Interface Serial1/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up
R2(config-if)#exit
R2(config)#route rip
R2(config-router)#network 192.168.3.0
R2(config-router)#network 192.168.4.0
R2(config-router)#network 10.10.10.0
R2(config-router)#exit

R2(config)#interface Serial1/0
R2(config-if)#ip address 10.10.10.2 255.255.255.0

pc0 ping pc1,pc2,pc3

时间: 2024-08-25 18:51:32

项目三的相关文章

android 实践项目三

android 实践项目三 本周我主要完成的任务是将代码进行整合,然后实现百度地图的定位与搜索功能.在这次实现的 图形界面如下: 在本周的工作中主要的实现出来定位与收索的功能,在地图中能实现了定位,显示当前的位置, 不知到为什么不显示地图,经过查找资料可能因为当前的SDK本版太高了,不匹配.所以在下周 图像的显示问题.下面是我的主要贴上我的布局代码 地图的布局: 本周的总结 做项目是学习知识最快的方式,即能让我们碰见各种问题,也让我们去解决各种问题.在项目中感觉自己 的水平有限,还需要更加努力的

综合项目三

综合项目三 项目背景: 我院107实验室是网络综合实验室,现有计算机若干台,使用一台二层交换机连接各台电脑.实验室出口是一块三层交换机,与1号楼的出口路由器相连.平时在实验室内,教师和学生能够相互通信.现发现部分同学实验课上偷偷上网.现在要求:实验课上老师和同学们能够通信,教师可以上网,同学们可以发送邮件等,不能访问www服务.假如你是107实验室管理员,请你完整以上要求. 计算机名 Ip 网关 掩码 Vlan SB F0/2 192.168.30.1/24 R1 F0/0 192.168.30

十一周 项目三 点类

#include<iostream> #include<Cmath> using namespace std; class Point //定义坐标点类 { public: Point():x(0),y(0) {}; Point(double x0, double y0):x(x0),y(y0){}; void PrintPoint(); //输出点的信息 double getx() { return x; } double gety() { return y; } protect

tomcat部署项目三种方法

1.直接把项目复制到Tomcat安装目录的webapps目录中,这是最简单的一种Tomcat项目部署的方法,也是初学者最常用的方法. 2.在tomcat安装目录中有一个conf文件夹,打开此文件夹,其中包含配置文件server.xml,打开配置文件,并在<host>和</host>之间插入如下语句. <Context    path="/hello"   docBase="F:\eclipse3.2\workspace\hello\WebRoot

个人项目三

五子棋 题目简介: 五子棋是一种两人对弈的纯策略型棋类游戏,通常双方分别使用黑白两色的棋子,下在棋盘直线与横线的交叉点上,先形成5子连线者获胜.棋具与围棋通用,起源于中国上古时代的传统黑白棋种之一.主要流行于华人和汉字文化圈的国家以及欧美一些地区.容易上手,老少皆宜,而且趣味横生,引人入胜:不仅能增强思维能力,提高提高智力,而且富含哲理,有助于修身养性.已在各个游戏平台有应用. 结对分工: 宋德彪:写实验报告 程普楠:找代码,测试 https://github.com/xiaoliulang02

MVC4商城项目三:分部视图在导航条上的应用

写了几天发觉大部分时间用在JS上了,本来想写个musicstore,却加了框架,然后又想用后台,然后又想用上bootstrapt,然后又想弄权限设计,然后又想………… 看来是想多了~ 好吧,最近把后台搭起来了,用了metronic.bootstrap, 真心很强大.功能很多,为了节约时间成本就在它上面改吧.先上图看看 框架演示地址:http://dreamsky.github.io/main/blog/metronic-bootstrap/index.html 下载地址:http://dream

使用IntelliJ Idea创建Maven项目(三)

使用IntelliJ Idea创建Maven项目(三) 原文地址:https://www.cnblogs.com/yankai1101/p/8469307.html

crm 系统项目(三) 自动分页

crm 系统项目(三) 自动分页 需求: 1. 做一个自动分页, 每15条数据1页 2. 让当前页数在中间显示 3. 上一页, 下一页 注意情况: 1.总页数 小于 规定显示的页数 2. 左右两边极值情况 3. 前后端传参,交互 user_list.py {% extends 'layout.html' %} {% block content %} <table class="table table-bordered table-hover"> <thead>

项目三. 基于图像压缩的视频监控系统

项目三. 基于图像压缩的视频监控系统 Sprint0-产品设计与规划 基于图像压缩的视频监控系统 1. 产品功能演示 在linux系统上运行程序,弹出登录界面,输入地址.端口信息,弹出视频监控界面,实时传出视频信息. 2. 功能模块分析 采集端: 图像采集子系统 图像编码子系统 传输子系统 主程序 监控端: 传输子系统 图像编码子系统 传输子系统 主程序 Sprint1-基于Epoll架构的采集端程序框架设计 第1课-Epoll机制精通 大纲: v  为什么用Epoll? 阻塞型IO与多路复用

Weblogic部署项目三种方式

在weblogic中部署项目通常有三种方式:第一,在控制台中安装部署:第二,将部署包放在domain域中autodeploy目录下部署:第三,使用域中配置文件config.xml 进行项目的部署. 控制台部署 1  启动weblogic服务,登录到weblogic控制台页面,输入用户名和密码,登录到控制台里面 2  点击左侧的部署 3  在右侧点击安装按钮,准备进行项目安装 4  看到路径输入框,可以在下面选择要部署的项目的位置 5  也可以直接输入要部署的包的位置,敲回车 6  点击下一步即可