hdu4081 次小生成树变形

http://acm.hdu.edu.cn/showproblem.php?pid=4081

Problem Description

During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other
kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi
Huang" means "the first emperor" in Chinese.

Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:

There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.

Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people‘s life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that
magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible,
but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the
total length of none magic roads.

Would you help Qin Shi Huang?

A city can be considered as a point, and a road can be considered as a line segment connecting two points.

Input

The first line contains an integer t meaning that there are t test cases(t <= 10).

For each test case:

The first line is an integer n meaning that there are n cities(2 < n <= 1000).

Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.

It is guaranteed that each city has a distinct location.

Output

For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.

Sample Input

2
4
1 1 20
1 2 30
200 2 80
200 1 100
3
1 1 20
1 2 30
2 2 40

Sample Output

65.00
70.00
/**
hdu4081 次小生成树变形
题目大意:给定n个城市,每个城市有ai个人,在这些城市间修路,已知可以免费修一条路,其他路费用为长度,求免费路连接城市人口和修路总费用比值的最大值
解题思路:我们要枚举每条路作为免费路的情况。可以先求出最小生成树sum,如果枚举的边在生成树上就(ai+a[j])/(sum-该边)。如果边不在生成树上
          (ai+aj)/(sum-mlen[i][j]) mlen是加上当前边到最小生成树后必然组成的环上除当前边外最大权值边的权值。其实就是一个次小生成树求解
*/
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
const int maxn=1010;
const double inf=1e14;

struct note
{
    int x,y,z;
}p[maxn];

double a[maxn][maxn],dis[maxn];
int pre[maxn],n;

int flag[maxn][maxn],vis[maxn];
double mlen[maxn][maxn];

double prim(int u)
{
    double sum=0;
    memset(flag,0,sizeof(flag));
    memset(vis,0,sizeof(vis));
    memset(mlen,0,sizeof(mlen));
    for(int i=1; i<=n; i++)
    {
        dis[i]=a[u][i];
        pre[i]=u;
    }
    vis[u]=1;
    for(int i=1; i<n; i++)
    {
        double minn=inf;
        int v=-1;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&dis[j]<minn)
            {
                v=j;
                minn=dis[j];
            }
        }
        if(v!=-1)
        {
            sum+=dis[v];
            flag[v][pre[v]]=flag[pre[v]][v]=1;
            vis[v]=1;
            for(int k=1; k<=n; k++)
            {
                if(vis[k]&&k!=v)
                {
                    mlen[v][k]=mlen[k][v]=max(mlen[k][pre[v]],dis[v]);
                }
                if(!vis[k]&&a[v][k]<dis[k])
                {
                    dis[k]=a[v][k];
                    pre[k]=v;
                }
            }
        }
    }
    return sum;
}

double lenth(int x,int y,int u,int v)
{
    return sqrt((x-u)*(x-u)+(y-v)*(y-v));
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d%d",&p[i].x,&p[i].y,&p[i].z);
        }
        for(int i=1; i<= n; i++)
        {
            a[i][i]=0;
            for(int j=i+1; j<=n; j++)
            {
                a[i][j]=a[j][i]=lenth(p[i].x,p[i].y,p[j].x,p[j].y);
            }
        }
        double sum=prim(1);
        double ans=-1;
        for(int i=1; i<=n; i++)
        {
            for(int j=i+1; j<=n; j++)
            {
                if(flag[i][j])
                    ans=max(ans,(p[i].z+p[j].z)/(sum-a[i][j]));
                else
                    ans=max(ans,(p[i].z+p[j].z)/(sum-mlen[i][j]));
            }
        }
        printf("%.2lf\n",ans);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-16 11:58:45

hdu4081 次小生成树变形的相关文章

HDU4081 Qin Shi Huang&#39;s National Road System【Kruska】【次小生成树】

Qin Shi Huang's National Road System Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3979    Accepted Submission(s): 1372 Problem Description During the Warring States Period of ancient China(4

HDU4081 Qin Shi Huang&#39;s National Road System(次小生成树)

枚举作为magic road的边,然后求出A/B. A/B得在大概O(1)的时间复杂度求出,关键是B,B是包含magic road的最小生成树. 这么求得: 先在原图求MST,边总和记为s,顺便求出MST上任意两点路径上的最长边d[i][j]. 当(u,v)是magic road时, 如果它在原本的MST上,则B就等于s-原(u,v)的权,而原(u,v)的权其实就是d[u][v]: 如果它不在原本的MST上,则B就等于s-d[u][v]+0. 总之就是一个式子:B=s-d[u][v]. 于是,在

hdu4081 Qin Shi Huang&#39;s National Road System 次小生成树

先发发牢骚:图论500题上说这题是最小生成树+DFS,网上搜题解也有人这么做.但是其实就是次小生成树.次小生成树完全当模版题.其中有一个小细节没注意,导致我几个小时一直在找错.有了模版要会用模版,然后慢慢融会贯通.我要走的路还长着啊. 讲讲次小生成树的思想吧.首先,在prim算法中做一些改变,求出任意两点(u,v)路径之间的最大权值,并记录,记为maxe[u][v].运行遍prim算法.枚举每一条边,如果该边是属于最小生成树的边,则ratio=(value(u) +value(v) ) /( a

HDU4081 Qin Shi Huang&#39;s National Road System 【次小生成树】

Qin Shi Huang's National Road System Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3395    Accepted Submission(s): 1189 Problem Description During the Warring States Period of ancient China(4

最小生成树 次小生成树 hdu4081

A - Qin Shi Huang's National Road System Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Description During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China --

HDU-4081.Qinshihuang&#39;sNationalRoadSystem(次小生成树变种)

Qin Shi Huang's National Road System Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 10874    Accepted Submission(s): 3846 Problem Description During the Warring States Period of ancient China(4

hdu 4081 次小生成树

简单说下思想(这里引用自http://blog.csdn.net/jarily/article/details/8883858) /* *算法引入: *设G=(V,E,w)是连通的无向图,T是图G的一棵最小生成树; *如果有另一棵树T1,满足不存在树T',ω(T')<ω(T1),则称T1是图G的次小生成树; * *算法思想: *邻集的概念:由T进行一次可行交换得到的新的生成树所组成的集合,称为树T的邻集,记为N(T); *设T是图G的最小生成树,如果T1满足ω(T1)=min{ω(T')|T'∈

最小瓶颈路与次小生成树

简介: 最小生成树是图论里面一类经典问题,可以有很多种变形,其中最小瓶颈路和次小生成树就是两种比较经典的变形.最小瓶颈路就是在两个结点之间求一条最长边最短的路径,而次小生成树则是所有生成树中权值排名第二的生成树(可以和最小生成树相等).下面我们分别来看看这两个问题. 最小瓶颈路: 给定一个加权无向图,并给定无向图中两个结点u和v,求u到v的一条路径,使得路径上边的最大权值最小.这个问题可以稍微加强一下,即求很多对结点之间的最小瓶颈路. 无向图中,任意两个结点的最小瓶颈路肯定在最小生成树上.因此,

Ural 1416 Confidential,次小生成树

不严格次小生成树. 注意图可能不连通. #include <cstdio> #include <cstring> #include <algorithm> #include <vector> using namespace std; const int maxn = 505; const int INF = 1e7; bool vis[maxn]; int d[maxn]; int pre[maxn]; int Max[maxn][maxn]; int g[