Description
In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:
Every even number greater than 4 can be
written as the sum of two odd prime numbers.
For example:
8 = 3 + 5. Both 3 and 5 are odd prime numbers.
20 = 3 + 17 = 7 + 13.
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.
Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)
Anyway, your task is now to verify Goldbach’s conjecture for all even numbers less than a million.
Input
The input will contain one or more test cases.
Each test case consists of one even integer n with 6 <= n < 1000000.
Input will be terminated by a value of 0 for n.
Output
For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying “Goldbach’s conjecture is wrong.”
Sample Input
8
20
42
0
Sample Output
8 = 3 + 5
20 = 3 + 17
42 = 5 + 37
题意很简单,验证哥德巴赫猜想,一个偶数是否能被两个素数相加,如果能输出两者差最大的两个,(从2开始寻找即可,如果遇到满足条件的break退出循环)如果不能找到满足条件的两个数输出“Goldbach’s conjecture is wrong.”
因为数据不大,所以利用素数筛选法事先打一遍表即可。代码如下
#include<iostream>
#include<stdio.h>
#include<queue>
#include<stack>
#include<algorithm>
#include<string.h>
#include<string>
#include<math.h>
using namespace std;
bool num[1000005];
int main()
{
memset(num,true,sizeof(num));
for(int i=2;i<=1000000;i++)
{
if(num[i])
{
for(int j=i*2;j<=1000000;j+=i)
{
num[j]=false;
}
}
}
int n;
while(scanf("%d",&n),n)
{
int t1=0,t2=0;
for(int i=2;i<=1000000;i++)
{
if(num[i]&&num[n-i])
{
t1=i;
t2=n-i;
break;
}
}
if(!t1&&!t2)
{
printf("Goldbach‘s conjecture is wrong.\n");
}
else
{
printf("%d = %d + %d\n",n,t1,t2);
}
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。
POJ 2262 Goldbach's Conjecture(素数筛选法)