实验名称:简单的三层交换配置路由
实验拓扑:
实验需要:
1、按图中所示配置设网络备vlan,IP地址
2、能够使各pc互相ping通。
实验步骤:
1、配置终端设备:
pc1-pc5按照拓扑图中所示配置各个pc的ip地址。
网关配置为 192.168.x.254
pc6配置为 192.168.7.1/24 网关为192.168.7.254
2、配置网络设备
#配置交换设备(Lsw1)
1、创建vlan
vlan 1
vlan 2
vlan 3
2、配置端口模式
interface g0/0/1
port link-type access
interface g0/0/2
port link-type access
interface g0/0/3
port link-type access
3、将端口加入特定vlan
interface gi0/0/1
port default vlan 1
interface gi0/0/2
port default vlan 2
interface gi0/0/3
port default vlan 3
4、配置交换机之间的互联链路(trunk)
interface gi0/0/24
port link-type trunk
port trunk allow-pass vlan all
#配置交换设备(Lsw2)
1、创建vlan
vlan 4
vlan 5
2、配置端口模式
interface g0/0/1
port link-type access
interface g0/0/2
port link-type access
3、将端口加入特定vlan
interface gi0/0/1
port default vlan 4
interface gi0/0/2
port default vlan 5
4、配置交换机之间的互联链路(trunk)
interface gi0/0/24
port link-type trunk
port trunk allow-pass vlan all
#配置路由设备(Lsw3)
1、配置交换机之间的互联链路
interface gi0/0/1
port link-type trunk
port trunk allow-pass vlan all
interface gi0/0/2
port link-type trunk
port trunk allow-pass vlan all
2、创建对应的 valn
vlan 1
vlan 2
vlan 3
vlan 4
vlan 5
vlan 6
3、配置每个vlan对应的svi接口(每个vlan的网关IP地址)
interface vlan 1
undo shutdown
ip address 192.168.1.254 255.255.255.0
interface vlan 2
undo shutdown
ip address 192.168.2.254 255.255.255.0
interface vlan 3
undo shutdown
ip address 192.168.3.254 255.255.255.0
interface vlan 4
undo shutdown
ip address 192.168.4.254 255.255.255.0
interface vlan 5
undo shutdown
ip address 192.168.6.254 255.255.255.0
interface vlan 6
undo shutdown
ip address 192.168.6.1 255.255.255.0
4、配置24端口模式,并加入vlan6
interface g0/0/24
port link-type access
port default vlan 6
5、设置浮动静态路由
ip route-static 192.168.7.0 255.255.255.0 192.168.6.2
#配置路由器设备(AR1)
1、配置两个端口的IP地址
interface g0/0/0
ip address 192.168.7.254 255.255.255.0
no shutdown
interface g0/0/1
ip address 192.168.6.2 255.255.255.0
no shutdown
2、配置浮动静态路由
IP route-static 0.0.0.0 0.0.0.0 192.168.6.1
注意:路由用交换机LSW3中,与路由器连接的端口一定要加入到一个新vlan中,并配置vlan网关的ip地址。
验证:
互相都ping通。
为pc1 ping pc6的结果。
原文地址:http://blog.51cto.com/14029008/2318141
时间: 2024-09-28 01:59:34