POJ 2769 Reduced ID Numbers (同余)

Reduced ID Numbers

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 9153   Accepted: 3675

Description

T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 106-1. T. Chur finds this range of SINs too large for identification
within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.

Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain
one SIN. The SINs within a group are distinct, though not necessarily sorted.

Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.

Sample Input

2
1
124866
3
124866
111111
987651

Sample Output

1
8

题目大意:给G个学生的学号,求最小的m,使得每个学生的学号对m取余都不相等。

很明显,此题一定有解,范围[G,MAX_SIN],所以直接枚举就行,然后用is[] 数组判重。

#include <stdio.h>
#include <string.h>

const int maxn=1000000+10;

bool is[maxn];
int a[330];

int main()
{
	int T,n,i,m;
	scanf("%d",&T);
	while(T--){
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		for(m=n;;m++){
			for(i=0;i<m;i++) is[i]=0;
			for(i=0;i<n;i++){
				if(!is[a[i]%m]) is[a[i]%m]=1;
				else break;
			}
			if(i==n) break;
		}
		printf("%d\n",m);
	}
	return 0;
}
时间: 2024-07-29 08:03:01

POJ 2769 Reduced ID Numbers (同余)的相关文章

POJ 2769 Reduced ID Numbers 同余定理

Reduced ID Numbers Time Limit: 2000MS Memory Limit: 65536K Total Submissions: 8989 Accepted: 3610 Description T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an

poj 2769 Reduced ID Numbers(memset使用技巧)

Description T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 106-1. T. Chur finds this range of SINs too larg

POJ 2769 Reduced ID Numbers

思路: 枚举 Reduced ID Numbers Time Limit: 2000MS Memory Limit: 65536K Total Submissions: 8847 Accepted: 3552 Description T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s

解题报告 之 POJ2769 Reduced ID Numbers

解题报告 之 POJ2769 Reduced ID Numbers Description T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 10 6-1. T. Chu

POJ2769 Reduced ID Numbers【同余定理】

题目链接: http://poj.org/problem?id=2769 题目大意: 有N个学生,每个学生有一个唯一的学生证号(0~10^6),但是为了学生证号的范围有点大, 所以希望找到一个最小的正整数M,使得所有学生的学生证号对模M均不同余.那么问题来 了:这个M是多少. 思路: 将M从1开始测试,把所有学生证号对M取余的结果存起来,如果发现有相同的结果,就增 大M的值继续测试,直到满足所有学生的学生证号对M均不同余. AC代码: #include<iostream> #include&l

Reduced ID Numbers (memset 的关键用处)

Description T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 106-1. T. Chur finds this range of SINs too larg

POJ 1995 Raising Modulo Numbers (快速幂模板)

Raising Modulo Numbers Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 4938   Accepted: 2864 Description People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, oth

poj 1651 http://poj.org/problem?id=1651

http://poj.org/problem?id=1651Multiplication Puzzle Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 6188   Accepted: 3777 Description The multiplication puzzle is played with a row of cards, each containing a single positive integer. Dur

POJ 2769

http://poj.org/problem?id=2796 题意:求n个数的和乘以这n个数中的最小值的积最大的数,以及其范围. 思路:求每一个数两边的比其大的数的和,再乘以这个数.还有一个范围,用单调栈找以及记录. 这个题和2559差不多,就是多了一个对数字的求和. 1 #include <stdio.h> 2 #include <iostream> 3 #include <stack> 4 5 #define x 100010 6 7 using namespace