POJ 3628 Bookshelf 2 0/1背包和DFS两种解法

题目链接:POJ 3628 Bookshelf 2

Bookshelf 2

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7462   Accepted: 3436

Description

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the
sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for
the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal ‘excess‘ height between
the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B

* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input

5 16
3
1
3
5
6

Sample Output

1

Source

USACO 2007 December Bronze

题意

书架高度为b,n头奶牛叠罗汉,要你找几头奶牛叠加是高度大于b,要求高出的大小尽可能小,求解高出的最小的可能性。

思路1:

n的值不大,可考虑dfs搜索加剪枝,思路清晰,但是剪枝很重要不然就2的20次方了。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int a[30], cn[30], n, b, minex;
void dfs(int x, int sum)
{
    if(sum + cn[n] - cn[x] < b) return; //已经不可能到达书架顶端了
    if(sum >= b)
    {
        if(minex > sum-b) minex = sum-b;
        return;
    }
    dfs(x+1, sum);
    dfs(x+1, sum+a[x+1]);
}
int main()
{
    while(~scanf("%d%d", &n, &b))
    {
        for(int i = 1; i <= n; i++)
            scanf("%d", &a[i]);
        cn[0] = 0;
        for(int i = 1; i <= n; i++)
            cn[i] += cn[i-1]+a[i];
        minex = 10000000;
        dfs(0, 0);
        printf("%d\n", minex);
    }
    return 0;
}

思路2:

0/1背包,把奶牛的总高度加起来减去b就是背包容量,尽可能装满这个背包,最后结果是背包容量减去最大值。

注意奶牛高度加起来很大,要开很大的数组,用memset会超内存,所以还是for循环吧。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int dp[20000010];
int main()
{
    int n, b, h[22];
    while(~scanf("%d%d", &n, &b))
    {
        int sum = 0;
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &h[i]);
            sum += h[i];
        }
        int v = sum-b;
        //memset(dp, sizeof(dp));   memset会超内存啊
        for(int i = 0; i <= v; i++)
            dp[i] = 0;
        for(int i = 1; i <= n; i++)
            for(int j = v; j >= h[i]; j--)
                dp[j] = max(dp[j], dp[j-h[i]]+h[i]);
        printf("%d\n", v-dp[v]);
    }
    return 0;
}

POJ 3628 Bookshelf 2 0/1背包和DFS两种解法

时间: 2024-10-12 13:22:35

POJ 3628 Bookshelf 2 0/1背包和DFS两种解法的相关文章

POJ 3628 Bookshelf 2【01背包】

题意:给出n头牛的身高,以及一个书架的高度,问怎样选取牛,使得它们的高的和超过书架的高度最小. 将背包容量转化为所有牛的身高之和,就可以用01背包来做=== 1 #include<iostream> 2 #include<cstdio> 3 #include<cstring> 4 #include<algorithm> 5 #define maxn 2000005 6 using namespace std; 7 int dp[maxn],h[50]; 8

poj 3628 Bookshelf 2 基本01背包

题目大意:FJ有n头奶牛,和一个高为h的架子,给出每头奶牛高度,求使奶牛叠加起来超过架子的最低高度是多少. 题目思路:求出奶牛叠加能达到的所有高度,并用dp[]保存,最后进行遍历,找出与h差最小的dp[]即所求答案. #include<cstdio> #include<stdio.h> #include<cstdlib> #include<cmath> #include<iostream> #include<algorithm> #i

POJ 3628 Bookshelf 2 (01背包)

Bookshelf 2 Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 7496   Accepted: 3451 Description Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available

POJ 3628 Bookshelf 2 题解

本题解法很多,因为给出的数据特殊性故此可以使用DFS和BFS,也可以使用01背包DP思想来解. 因为一般大家都使用DFS,这里使用很少人使用的BFS,缺点是比DFS更加耗内存,不过优点是速度比DFS快. 当然也比DFS难写点: int N, B; int Height[21]; inline int mMin(int a, int b) { return a > b? b : a; } inline int mMax(int a, int b) { return a < b? b : a; }

POJ 1515 Street Directions --一道连通题的双连通和强连通两种解法

题意:将一个无向图中的双向边改成单向边使图强连通,问最多能改多少条边,输出改造后的图. 分析: 1.双连通做法: 双连通图转强连通图的算法:对双连通图进行dfs,在搜索的过程中就能按照搜索的方向给所有边定向,其中桥不能改造,只能保留双向边. 代码: #include <iostream> #include <cstdio> #include <cstring> #include <cmath> #include <cstdlib> #includ

destoon6.0最新动、静 两种页面判断会员是否登录

最新动.静 两种页面 判断 会员是否登录加在尾巴模板中 <script type="text/javascript"> if(get_cookie('auth')) { $('.xh_dl')[0].className = 'xh_dl_no'; $('.xh_dl_2_no')[0].className = 'xh_dl_2'; } </script> 模板 <div class="xh_dl">未登录前的样式</div&

poj 3628 Bookshelf 2

Bookshelf 2 Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 10981   Accepted: 4860 Description Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only availabl

poj 1837 Balance (0 1 背包)

Balance Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 10326   Accepted: 6393 题意:给你n个挂钩g个砝码  以及n个挂钩的距离天平中心距离(负的代表左边正的代表右边)g个砝码的重量. 要求输出能够令天平平衡的方法种类 解题思路     http://user.qzone.qq.com/289065406/blog/1299341345  非常具体 #include<iostream> #i

[ActionScript 3.0] AS3.0 模拟套索工具抠图的两种方法

方法之一:遮罩法 package com.fylibs.tools { import flash.display.Bitmap; import flash.display.BitmapData; import flash.display.DisplayObject; import flash.display.Shape; import flash.display.Sprite; import flash.events.MouseEvent; import flash.geom.Matrix; i