poj 2406 Power Strings 【kmp】

Power Strings

Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 37564   Accepted: 15532

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined
in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

Waterloo local 2002.07.01

分析:

查找最大序列数。

代码:

#include<cstdio>
#include<cstring>
const int max= 1000100;
char str[max];
int p[max];
int cnt;
int len;
void getp()
{
	 len=strlen(str);
	int i=0,j=-1;
	p[0]=-1;
	while(i<len)
	{
		if(j==-1||str[i]==str[j])
		{
			i++,j++;
			p[i]=j;
		}
		else j=p[j];
	}
}
int main()
{
	while(scanf("%s",str)!=EOF)
	{
		if(strcmp(str,".")==0)
		break;
		getp();
		cnt=1;
//		for(int i=0;i<len;i++)
//		printf("%d ",p[i]);
		if(len%(len-p[len])==0)
		cnt=len/(len-p[len]);
		printf("%d\n",cnt);
	}
	return 0;
}

版权声明:博主情人,外人误碰!!!

时间: 2024-10-14 09:04:03

poj 2406 Power Strings 【kmp】的相关文章

poj 2406 Power Strings【KMP】

点击打开题目 Power Strings Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 33548   Accepted: 13935 Description Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b =

poj 2406 Power Strings 【KMP的应用】

Power Strings Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 33595   Accepted: 13956 Description Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "

PKU 2406:Power Strings 【KMP】

Power Strings Time Limit : 6000/3000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other) Total Submission(s) : 70   Accepted Submission(s) : 27 Problem Description Given two strings a and b we define a*b to be their concatenation. For example,

POJ2406 Power Strings 【KMP】

Power Strings Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 31388   Accepted: 13074 Description Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "

poj 2406 Power Strings(KMP求循环次数)

题目链接:http://poj.org/problem?id=2406 Description Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, e

poj 2406 Power Strings(kmp循环节)

题目链接:http://poj.org/problem?id=2406 题目大意:如果n%(n-next[n])==0,则存在重复连续子串,长度为n-next[n]. 例如:      a    b    a    b    a    b next:-1   0    0    1    2    3    4 next[n]==4,代表着,前缀abab与后缀abab相等的最长长度,这说明,ab这两个字母为一个循环节,长度=n-next[n]; 1 #include <iostream> 2

POJ 2406 Power Strings(kmp)

Language: Default Power Strings Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 33335   Accepted: 13852 Description Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def"

POJ - 2406 - Power Strings (KMP)

Power Strings Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 34601   Accepted: 14319 Description Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "

POJ 2406 Power Strings 简单KMP

Power Strings Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 33389   Accepted: 13869 Description Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "