poj1129 Channel Allocation 染色问题

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby
repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels.

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of
channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet
starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input.

Following the number of repeaters is a list of adjacency relationships. Each line has the form:

A:BCDH

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line
has the form

A:

The repeaters are listed in alphabetical order.

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross.

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels
is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 

问题模型:
给出一幅连通图 每个字母代表一块区域 每行的冒号右边代表与该区域连通的区域    要求相邻的区域填充不同的颜色  问最少填几种颜色

代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int map[30][30];         //是否连通
int color[30];           //该区域填的第几种颜色
int ans;
int tt,t;
bool ok(int a,int b)
{
    for(int i=0;i<t;i++)
    {
        if(map[i][a]==1&&b==color[i])          //与其连通的区域 如果有第b种颜色  则该区域不能填第b种颜色
            return false;
    }
    return true;
}
void dfs(int a,int colornum)
{
    if(tt==1)
        return;
    if(a>=t)
    {
        tt=1;
        return;
    }
    for(int i=1;i<=colornum;i++)
    {
        if(ok(a,i))
         {
             color[a]=i;
        dfs(a+1,colornum);            //填下一区域
            color[a]=0;
         }
    }
    if(tt==0)
    {
        ans++;
        dfs(a,colornum+1);             //未填充完 加一种颜色
    }
}
int main()
{
    char q[55];
    int m,n,i,j,k;
    while(cin>>t&&t)
    {
        tt=0;
        memset(color,0,sizeof(color));
        memset(map,0,sizeof(map));
        for(j=1;j<=t;j++)
        {
            scanf("%s",q);
            for(i=2;i<strlen(q);i++)
            {
                map[q[0]-'A'][q[i]-'A']=1;
            }
        }
        ans=1;
        dfs(0,1);
        if(ans==1)
            printf("1 channel needed.\n");//注意单复数
        else
            printf("%d channels needed.\n",ans);
    }
    return 0;
}

暴力搜索。。

时间: 2024-07-29 16:52:07

poj1129 Channel Allocation 染色问题的相关文章

poj1129 Channel Allocation(染色问题)

题目链接:poj1129 Channel Allocation 题意:要求相邻中继器必须使用不同的频道,求需要使用的频道的最少数目. 题解:就是求图的色数,这里采用求图的色数的近似有效算法——顺序着色算法(实质是一种贪心策略:在给任何一个顶点着色时,采用其邻接顶点中没有使用的,编号最小的颜色). 注:中继器网络是一个平面图,即图中不存在相交的边. 看讨论后发现这组数据,AC代码没过orz: 6 A:BEF B:AC C:BD D:CEF E:ADF F:ADE 正确答案应该是3 : A(1)B(

快速切题 poj1129 Channel Allocation

Channel Allocation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 12334   Accepted: 6307 Description When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a s

poj1129 Channel Allocation DFS

题目 题意:给定N个节点,让你对其涂色,使其任何相邻的两个节点颜色不同. 思路: 1. 问题模型是着色问题,枚举颜色的个数, 每次枚举看可以完成全部点的着色. 2. 采用深搜,每一次当前色的种数深搜完毕就加1种,直到全部点都被着色完毕, 这样 从最少的开始深搜,结果出现肯定是最少的. 该题N<26,可以不用四色原理剪枝. 附上一发代码: 1 #include<cstdio> 2 #include<iostream> 3 #include<cstring> 4 #i

POJ1129 Channel Allocation

题意 给定一个无向图,用最少的颜色来涂色,使所有相邻的点颜色都不重复. 思路 数据很小,暴力即可.或者直接贪心(总是选择能选择的id最小的颜色),下面的代码就是贪心做的. 代码 #include <cstdio> #include <cstring> #include <algorithm> using namespace std; const int maxn = 30; const int INF = 1000000000; int cl[maxn]; int n;

POJ-1129 Channel Allocation (DFS)

Description When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repea

POJ 1129 Channel Allocation(暴力搜--涂色问题)

Channel Allocation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 13295   Accepted: 6806 Description When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a s

POJ 1129 Channel Allocation(DFS)

Channel Allocation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 13173   Accepted: 6737 Description When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a s

Channel Allocation (poj 1129 dfs)

Language: Default Channel Allocation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 12367   Accepted: 6325 Description When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that ever

Channel Allocation 贪心涂色

Channel Allocation 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 #include <cmath> 5 #include <algorithm> 6 #include <string> 7 #include <vector> 8 #include <set> 9 #include <map> 10