Uva 127 poj 1214 `Accordian'' Patience

 ``Accordian‘‘ Patience 

You are to simulate the playing of games of ``Accordian‘‘ patience, the rules for which are as follows:

Deal cards one by one in a row from left to right, not overlapping. Whenever the card matches its immediate neighbour on the left, or matches the third card to the left, it may be moved onto that card. Cards match if they are of the same suit or same rank. After making a move, look to see if it has made additional moves possible. Only the top card of each pile may be moved at any given time. Gaps between piles should be closed up as soon as they appear by moving all piles on the right of the gap one position to the left. Deal out the whole pack, combining cards towards the left whenever possible. The game is won if the pack is reduced to a single pile.

Situations can arise where more than one play is possible. Where two cards may be moved, you should adopt the strategy of always moving the leftmost card possible. Where a card may be moved either one position to the left or three positions to the left, move it three positions.

Input

Input data to the program specifies the order in which cards are dealt from the pack. The input contains pairs of lines, each line containing 26 cards separated by single space characters. The final line of the input file contains a # as its first character. Cards are represented as a two character code. The first character is the face-value (A=Ace, 2-9, T=10, J=Jack, Q=Queen, K=King) and the second character is the suit (C=Clubs, D=Diamonds, H=Hearts, S=Spades).

Output

One line of output must be produced for each pair of lines (that between them describe a pack of 52 cards) in the input. Each line of output shows the number of cards in each of the piles remaining after playing ``Accordian patience‘‘ with the pack of cards as described by the corresponding pairs of input lines.

Sample Input

QD AD 8H 5S 3H 5H TC 4D JH KS 6H 8S JS AC AS 8D 2H QS TS 3S AH 4H TH TD 3C 6S
8C 7D 4C 4S 7S 9H 7C 5D 2S KD 2D QH JD 6D 9D JC 2C KH 3D QC 6C 9S KC 7H 9C 5C
AC 2C 3C 4C 5C 6C 7C 8C 9C TC JC QC KC AD 2D 3D 4D 5D 6D 7D 8D TD 9D JD QD KD
AH 2H 3H 4H 5H 6H 7H 8H 9H KH 6S QH TH AS 2S 3S 4S 5S JH 7S 8S 9S TS JS QS KS
#

Sample Output

6 piles remaining: 40 8 1 1 1 1
1 pile remaining: 52

这题就是个模拟。每个pile都是个栈,用pos数组来记录位置和pile编号的关系。debug好久才发现stack,元素数组大小开小了。。。脑袋进水啦。。。提交的时候SE,uva格式和poj的不一样啊。。。
#include<cstdio>

struct card
{
   char R, s;//Rank,suit
   card(){}
   card(char R, char s):R(R),s(s){}
   bool operator == (const card& rhs) const {// match
      return R == rhs.R || s == rhs.s;
   }
};

struct Stack
{
   card ele[53];
   int Top;

   card* top(){ return ele+Top;}
   void pop(){Top--;}
   void push(const card& x){
      ele[++Top]  = x;
   }
}pile[52];

int pileSz;

int pos[52];//pos 2 pile

void Move(int p, int d)
{
   int id = pos[p], pid = pos[p-d];

   pile[pid].push(*pile[id].top());
   pile[id].pop();

   if(pile[id].Top == 0){
      pileSz--;
      for(int i = p; i < pileSz; i++)
         pos[i] = pos[i+1];
   }
}

bool check()
{
   int move3 = -1;
   for(int i = 3;i < pileSz; i++) {
      if( *pile[pos[i]].top() == *pile[pos[i-3]].top()) { move3 = i; break; }
   }
   int move1 = -1;
   for(int i = 1;i < pileSz; i++) {
      if( *pile[pos[i]].top() == *pile[pos[i-1]].top()) { move1 = i; break; }
   }

   if(!~move1 && !~move3) return false;

   if(~move1&&~move3){
      if(move1 < move3) Move(move1,1);
      else Move(move3,3);
   }
   else {
      if(~move1) Move(move1,1);
      else Move(move3,3);
   }

   return true;
}

bool read(){
   char buf[3];
   scanf("%s",buf);
   if(*buf == ‘#‘) return false;
   for(int i = 0; i < 52; i++) pos[i] = i;
   pileSz = 52;
   for(int i = 0; i < 52; i++) pile[i].Top = 0;

   pile[0].push(card(*buf,buf[1]));

   for(int i = 1; i < 52; i++) {
      scanf("%s",buf);
      pile[i].push(card(*buf,buf[1]));
   }

   return true;
}

int main()
{
 //  freopen("in.txt","r",stdin);
   while(read()){
      while(check());
   /* poj
      printf("%d piles remaining:",pileSz);
      for(int i = 0; i < pileSz; i++)
      printf(" %d",pile[pos[i]].Top);
   */
      if(pileSz>1){
         printf("%d piles remaining:",pileSz);
         for(int i = 0; i < pileSz; i++)
         printf(" %d",pile[pos[i]].Top);
      }
      else printf("1 pile remaining: 52");

      puts("");
   }
   return 0;
}
 

Uva 127 poj 1214 `Accordian'' Patience

时间: 2024-08-24 23:35:37

Uva 127 poj 1214 `Accordian'' Patience的相关文章

UVa 127 - &quot;Accordian&quot; Patience POJ 1214 链表题解

UVa和POJ都有这道题. 不同的是UVa要求区分单复数,而POJ不要求. 使用STL做会比较简单,这里纯粹使用指针做了,非常麻烦的指针操作,一不小心就错.调试起来还是非常费力的 本题理解起来也是挺费力的,要搞清楚如何模拟也不容易啊,读题要很仔细. 纯指针的操作挺快的吧.不过POJ 0ms,而UVa就0.2左右了. 三相链表: 1 只要有叠起来的牌,那么就使用一个down指针指向下面的牌就可以了. 2 使用双向链表,可以方便前后遍历. 3 记得有了更新牌之后,又要重新开始检查是否需要更新牌,这是

``Accordian&#39;&#39; Patience UVA 127

说说: 这道题难度其实并不但,但是比较繁琐,且细节容易被忽略.先分析一下游戏规则吧,知道游戏规则之后,问题自然而然就解决了.首先放着一行52个扑克牌堆(ps:输入的时候分两行输入)开始每堆只有一张牌,然后从左到右开始判断,若一张牌和左边第一张牌或者左边第三张牌的大小或者花色相同,则将该张牌放到那一对牌之上并且要求继续向左匹配,直到不能匹配为止.若某个堆一张牌都不剩了,则该堆不存在了,也就是说如果两堆相邻,则两堆的牌数都不能为0.最后按照这个规则,直到没有牌能够移动位置.(ps:移动是指顶层牌的移

UVa OJ 127 - &quot;Accordian&quot; Patience (“手风琴”纸牌)

UVa OJ 127 - "Accordian" Patience ("手风琴"纸牌) Time limit: 3.000 seconds 限时:3.000秒 Problem 问题 You are to simulate the playing of games of "Accordian" patience, the rules for which are as follows: 模拟玩一个"手风琴"纸牌游戏,规则如下: D

uva 127 &quot;Accordian&quot; Patience(手风琴纸牌)

用 栈 stack 来处理. 直接根据题目描述写就可以.不要忘记每组数据最后的清空栈堆. 题目大意: 给定52张的扑克牌,现在要求对扑克牌进行整理,对于每一张扑克牌,如果左边的第三张存在那么就去判断这一张是否和第三张满足花色或卡片值相同,如果满足则把这一张移动到左边的第三张,否则去判断左边的第一张是否和这一张满足条件:如果左边的第三张不存在那么只要去判断左边的第一张即可.最后输出剩下的扑克牌的堆数,并且输出每一堆的牌数. #include<stdio.h> #include<iostre

&quot;Accordian&quot; Patience UVA 127 (”手风琴“牌游戏)

"Accordian" Patience From:UVA, 127 Submit Time Limit: 3000 MS You are to simulate the playing of games of ``Accordian'' patience, the rules for which are as follows: Deal cards one by one in a row from left to right, not overlapping. Whenever th

ACM学习历程——UVA 127 &quot;Accordian&quot; Patience(栈;模拟)

Description  ``Accordian'' Patience  You are to simulate the playing of games of ``Accordian'' patience, the rules for which are as follows: Deal cards one by one in a row from left to right, not overlapping. Whenever the card matches its immediate n

uva ``Accordian&#39;&#39; Patience

题目如下: ``Accordian'' Patience You are to simulate the playing of games of ``Accordian'' patience, the rules for which are as follows: Deal cards one by one in a row from left to right, not overlapping. Whenever the card matches its immediate neighbour

``Accordian&#39;&#39; Patience

终于解决了一个忧伤好久的问题,严重拖了项目进度,深感惭愧!一直被一系列的问题所困扰,然后又只能自己一个人摸索,也是一段辛酸忧伤史,现在小结一下上个月在做二维码的过程中所碰到的问题以及解决办法,现在庆幸终于解决好了,终于能将这个功能告一段落,一下小结也是分享一下Unity的某些"坑",让同行少走弯路,起码在二维码这方面应该会有所启迪,欣慰的是接下来几天终于可以做自己应该做的事情了! 效果图: 先小结一下碰到的问题: 1.Unity工程屏幕方向与Android工程屏幕方向要一致的问题 本来

UVA 124 &amp; POJ 1270 Following Orders(拓扑排序)

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=60 http://poj.org/problem?id=1270 Following Orders Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 3806   Accepted: 1507 Description Or