[ACMcoder] A + B Problem II

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

解题思路

思路很简单,注意进位即可。

解题代码

//因为部分细节搞了半天:
//使用max要引用algorithm
//注意最后一个sample不能输出空行
#include <iostream>
#include <algorithm>
using namespace std;

int main()
{
    char n1[1001] = {0};
    char n2[1001] = {0};
    int total;
    //cin>>total;
    scanf("%d", &total);
    int outputindex = 0;
    while (outputindex < total)
    {
        //cin>>n1>>n2;
        scanf("%s %s", n1, n2);
        int len1 = 0;
        int len2 = 0;
        while (‘\0‘ != n1[len1])
            len1++;
        while (‘\0‘ != n2[len2])
            len2++;

        char n[1002] = {0};
        int index1 = len1 - 1;
        int index2 = len2 - 1;
        int index = max(index1, index2) + 1;
        char bit = 0;
        int num = 0;
        while (index1 >= 0 && index2 >= 0)
        {
            num = n1[index1] + n2[index2] - 48 + bit;
            if (num > 57)
            {
                n[index] = num - 10;
                bit = 1;
            }
            else
            {
                n[index] = num;
                bit = 0;
            }
            --index1;
            --index2;
            --index;
        }

        while (index1 >= 0)
        {
            num = n1[index1] + bit;
            if (num > 57)
            {
                n[index] = num - 10;
                bit = 1;
            }
            else
            {
                n[index] = num;
                bit = 0;
            }
            --index1;
            --index;
        }

        while (index2 >= 0)
        {
            num = n2[index2] + bit;
            if (num > 57)
            {
                n[index] = num - 10;
                bit = 1;
            }
            else
            {
                n[index] = num;
                bit = 0;
            }
            --index2;
            --index;
        }
        if (bit != 0)
        {
            n[index] = bit + ‘0‘;
        }

        char *p = n;
        while (‘\0‘ == *p)
            p++;
        ++outputindex;
        cout<<"Case "<<outputindex<<":"<<endl;
        cout<<n1<<" + "<<n2<<" = "<<p<<endl;

        if (outputindex != total)
            cout<<endl;
    }
    return 0;
}
时间: 2025-01-25 02:32:07

[ACMcoder] A + B Problem II的相关文章

杭电1023Train Problem II

地址:http://acm.hdu.edu.cn/showproblem.php?pid=1023 题目: Train Problem II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 7675    Accepted Submission(s): 4131 Problem Description As we all know the

Train Problem II 卡特兰裸题(入门题)

Train Problem II  题目大意:给你一个数n,表示有n辆火车,编号从1到n,从远方驶过来,问你有多少种出站的可能. 解题思路:模拟栈的问题而已.  卡特兰问题. 1 import java.math.*; 2 import java.util.*; 3 import java.io.*; 4 5 public class Main 6 { 7 static int MS=101; 8 public static void main(String[] args) 9 { 10 Sca

hdoj 1002 A + B Problem II

A + B Problem II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 242959    Accepted Submission(s): 46863 Problem Description I have a very simple problem for you. Given two integers A and B, you

【HDOJ 1002】A + B Problem II

A + B Problem II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 238517    Accepted Submission(s): 45969 Problem Description I have a very simple problem for you. Given two integers A and B, you

HDU 1002-A + B Problem II(大数类)

A + B Problem II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 215173    Accepted Submission(s): 41521 Problem Description I have a very simple problem for you. Given two integers A and B, yo

hdoj 1023 Train Problem II 【卡特兰】+【高精度】

题意:询问有多少种进站出站的顺序. 经典卡特兰.我对卡特兰目前的认识就是有n个1和n个-1,组成一个为2n的数列的方式有多少种.这就跟火车进站出站类似, 至于具体的卡特兰数的介绍,百度解释的很详细. 代码1(c语言): /* h(n) = h(n-1)*(4*n-2)/(n+1); */ #include <stdio.h> #include <string.h> #define M 110 int s[M][M] = {0}, b[M]; void init(){ s[1][0]

A + B Problem II(杭电1002)

/*A + B Problem II Problem Description I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. Input The first line of the input contains an integer T(1<=T<=20) which means the number of test case

HDU 1002 A + B Problem II(大整数相加)

A + B Problem II Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. Input The first line of the input c

hdu1002 A + B Problem II(大数题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1002 A + B Problem II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 230247    Accepted Submission(s): 44185 Problem Description I have a very sim