HDU 1518 Square 搜索

Square

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 11   Accepted Submission(s) : 5

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input

The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

Output

For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".

Sample Input

3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5

Sample Output

yes
no
yes
#include<iostream>
#include<cstring>
using namespace std;

int v[23],n,flag;
int a[23],sum;

void dfs(int p,int ans,int t)
{
	if(ans==sum/4)
	{
		p++;
		if(p==4)
		{
			flag=1;
			return ;
		}
		else ans=0;
		t=0;
	}

	if(flag)   return ;
	for(int i=t;i<n;i++)
		if(!v[i] && a[i]+ans<=sum/4)
		{
			v[i]=1;
			dfs(p,ans+a[i],i);
			v[i]=0;
		}
}

int main()
{
	int T;
	cin>>T;
	while(T--)
	{
		cin>>n;
		int max;
		max=sum=0;
		for(int i=0;i<n;i++)
		{
			cin>>a[i];
			sum += a[i];
			if(max<a[i])   max=a[i];
		}

		if(sum%4!=0 || max>sum/4)
			cout<<"no\n";
		else
		{
			memset(v,0,sizeof(v));
			flag=0;
			dfs(0,0,0);
			if(flag)   cout<<"yes\n";
			else     cout<<"no\n";
		}
	}

	return 0;
}

HDU 1518 Square 搜索

时间: 2024-11-25 22:13:19

HDU 1518 Square 搜索的相关文章

hdu 1518 Square (dfs搜索可参考poj1011)

Square Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8589    Accepted Submission(s): 2784 Problem Description Given a set of sticks of various lengths, is it possible to join them end-to-end

hdu 1518 Square(深搜dfs)

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1518 --------------------------------------------------------------------------------------------------------------------------------------------

hdu 1518 Square(深搜+剪枝)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1518 题目大意:根据题目所给的几条边,来判断是否能构成正方形,一个很好的深搜应用,注意剪枝,以防超时! 1 #include <iostream> 2 #include <cstdio> 3 #include<algorithm> 4 #include <cstring> 5 using namespace std; 6 int ap[30],visit[30]

hdu 1518 Square

Problem Description Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square? Input The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number

hdu 1518 Square 深搜,,,,花样剪枝啊!!!

Square Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9588    Accepted Submission(s): 3127 Problem Description Given a set of sticks of various lengths, is it possible to join them end-to-end

HDU 1518 Square (DFS+剪枝)

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square? Input The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M intege

杭电 1518 Square (深搜)(回溯)

http://acm.hdu.edu.cn/showproblem.php?pid=1518 Square Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8343    Accepted Submission(s): 2706 Problem Description Given a set of sticks of various

hdu 1518(dfs)

参考页面: http://www.yuanjiaocheng.net/CSharp/Csharp-keys.html http://www.yuanjiaocheng.net/CSharp/csharp-interface.html http://www.yuanjiaocheng.net/CSharp/Csharp-operators.html http://www.yuanjiaocheng.net/CSharp/Csharp-if-else.html http://www.yuanjiao

hdu 1398 Square Coins(母函数|完全背包)

http://acm.hdu.edu.cn/showproblem.php?pid=1398 题意:有价值为1^2,2^2....7^2的硬币共17种,每种硬币都有无限个.问用这些硬币能够组成价值为n的钱数共有几种方案数. 母函数: #include <stdio.h> #include <iostream> #include <map> #include <set> #include <stack> #include <vector>