poj1995 Raising Modulo Numbers【高速幂】

Raising Modulo Numbers

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 5500   Accepted: 3185

Description

People are different. Some secretly read magazines full of interesting girls‘ pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment
was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow:

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players
including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players‘ experience it is possible to increase the difficulty by choosing higher numbers.

You should write a program that calculates the result and is able to find out who won the game.

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be
divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression

(A1B1+A2B2+ ... +AHBH)mod M.

Sample Input

3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132

Sample Output

2
13195
13
#include<stdio.h>
#include<string.h>
int ksm(long long a,long long b,long long n)
{
	long long ans=1;
	while(b)
	{
		if(b&1)
			ans=ans*a%n;
			//写成ans*=a%n不行...输出错误
		a=a*a%n;
		b>>=1;
	}
	return ans;
}
int main()
{
	int z,h,m,u,i;
	scanf("%d",&z);
	while(z--)
	{
		int sum = 0;
		scanf("%d",&m);
		scanf("%d",&h);
		while(h--)
		{
			scanf("%d%d",&u,&i);
			sum += ksm(u,i,m);
			sum %= m;
		}
		printf("%d\n",sum);
	}
	return 0;
}

/*************************************************************/

#include<stdio.h>
#include<string.h>
int main()
{
	long long z,h,m,a,b,ans;
	scanf("%lld",&z);
	while(z--)
	{
		int sum = 0;
		scanf("%lld",&m);
		scanf("%lld",&h);
		while(h--)
		{
			scanf("%lld%lld",&a,&b);
			ans = 1;
			while(b)
			{
				if(b&1)
				ans=ans*a%m;
				a=a*a%m;
				b>>=1;
			}
			sum += ans;
			sum %= m;
		}
		printf("%d\n",sum%m);
	}
	return 0;
}

时间: 2024-07-30 11:34:21

poj1995 Raising Modulo Numbers【高速幂】的相关文章

POJ1995 Raising Modulo Numbers(快速幂)

POJ1995 Raising Modulo Numbers 计算(A1B1+A2B2+ ... +AHBH)mod M. 快速幂,套模板 /* * Created: 2016年03月30日 23时01分45秒 星期三 * Author: Akrusher * */ #include <cstdio> #include <cstdlib> #include <cstring> #include <cmath> #include <ctime> #

POJ1995:Raising Modulo Numbers(快速幂取余)

题目:http://poj.org/problem?id=1995 题目解析:求(A1B1+A2B2+ ... +AHBH)mod M. 大水题. #include <iostream> #include <stdio.h> #include <string.h> #include <algorithm> #include <math.h> using namespace std; int n,mod,sum; int main() { int

POJ1995 Raising Modulo Numbers

Raising Modulo Numbers Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 6373   Accepted: 3760 Description People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, oth

POJ 1995 Raising Modulo Numbers (快速幂模板)

Raising Modulo Numbers Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 4938   Accepted: 2864 Description People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, oth

poj Raising Modulo Numbers 快速幂模板

Raising Modulo Numbers Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 8606   Accepted: 5253 Description People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, oth

poj1995 Raising Modulo Numbers (快速幂,挑战有模版,纪念一下A的第一道快速幂)

/*快速幂,时间复杂度,数据范围*/ #include <iostream> #include <stdio.h> #include <string.h> using namespace std; long long a, b; int n, m; int sum, res; typedef long long ll; ll mod_pow(ll x, ll y, int z) { res = 1; while(y > 0){ if(y & 1) res

POJ1995 Raising Modulo Numbers【整数快速幂】

题目链接: http://poj.org/problem?id=1995 题目大意: N个人在一起玩游戏,每个人默写两个数字Ai.Bi,在同一个时间公开给其他玩家看.游戏的目的是 为了看谁能够在最快的时间求出所有的Ai^Bi的和对M取模的值.那么问题来了:你能够快速算出 (A1B1+A2B2+ ... +AHBH)mod M 的值吗? 思路: 用二分整数快速幂算法计算出每一个Ai^Bi,然后依次相加取模. AC代码: #include<iostream> #include<algorit

Raising Modulo Numbers ---- 快速幂

Time Limit: 1000MS Memory Limit: 30000K Total Submissions: 5087 Accepted: 2959 Description People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and

POJ 1995 Raising Modulo Numbers (快速幂)

题意: 思路: 对于每个幂次方,将幂指数的二进制形式表示,从右到左移位,每次底数自乘,循环内每步取模. #include <cstdio> typedef long long LL; LL Ksm(LL a, LL b, LL p) { LL ans = 1; while(b) { if(b & 1) { ans = (ans * a) % p; } a = (a * a) % p; b >>= 1; } return ans; } int main() { LL p, a