HDU1301 Jungle Roads【Prim】

Jungle Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4554    Accepted Submission(s): 3341

Problem Description

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The
Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads,
even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through
I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet,
capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to
villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road.
Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more
than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute
time limit.

Sample Input

9

A 2 B 12 I 25

B 3 C 10 H 40 I 8

C 2 D 18 G 55

D 1 E 44

E 2 F 60 G 38

F 0

G 1 H 35

H 1 I 35

3

A 2 B 10 C 40

B 1 C 20

0

Sample Output

216

30

题目大意:给你一个用前N个村庄,村庄用字母表的前N个字母表示,接下来N-1行

表示第字母X与其相连的村庄数目,及其相连的村庄字母和两个村庄的距离,求最小

生成树。

思路:Prim模板题。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;

int G[110][110],vis[110],low[110];

void Prim(int N)
{
    memset(vis,0,sizeof(vis));
    int ans = 0;
    vis[1] = 1;
    int pos = 1;
    for(int i = 1; i <= N; i++)
    {
        if(i != pos)
            low[i] = G[pos][i];
    }

    for(int i = 1; i < N; i++)
    {
        int Min = 0xffffff0;
        for(int j = 1; j <= N; j++)
        {
            if(!vis[j] && low[j] < Min)
            {
                Min = low[j];
                pos = j;
            }
        }
        ans += Min;
        vis[pos] = 1;
        for(int j = 1; j <= N; j++)
        {
            if(!vis[j] && low[j] > G[pos][j])
                low[j] = G[pos][j];
        }
    }

    printf("%d\n",ans);

}
int main()
{
    int N,x,y,d,s;
    while(scanf("%d",&N) && N)
    {
        for(int i = 1; i <= N; i++)
            for(int j = 1; j <= N; j++)
                G[i][j] = 0xffffff0;
        for(int i = 0; i < N*(N-1)/2; i++)
        {
            scanf("%d%d%d%d",&x,&y,&d,&s);
            if(s == 0)
                G[x][y] = G[y][x] = d;
            else
                G[x][y] = G[y][x] = 0;
        }
        Prim(N);
    }

    return 0;
}
时间: 2024-08-25 17:25:41

HDU1301 Jungle Roads【Prim】的相关文章

HDU1301 Jungle Roads【Prim】【最小生成树】

Jungle Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4591    Accepted Submission(s): 3371 Problem Description The Head Elder of the tropical island of Lagrishan has a problem. A burst o

HDU 1301:Jungle Roads【Prim】

  Jungle Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5516    Accepted Submission(s): 3981 Problem Description The Head Elder of the tropical island of Lagrishan has a problem. A burst

HDU1301 Jungle Roads 【最小生成树Prim】

Jungle Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4268    Accepted Submission(s): 3120 Problem Description The Head Elder of the tropical island of Lagrishan has a problem. A burst o

HDU1102 Constructing Roads【Prim】

Constructing Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 14897    Accepted Submission(s): 5677 Problem Description There are N villages, which are numbered from 1 to N, and you should

hdu1301 Jungle Roads (Prim)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1301 依旧Prim............不多说了 1 #include<iostream> 2 #include<cstdio> 3 #include<algorithm> 4 5 using namespace std; 6 7 #define MAX 'Z'+5 8 #define inf 99999999 9 10 int map[MAX][MAX],node[MA

hdoj-1301 Jungle Roads 【最小生成树】

题目:http://acm.hdu.edu.cn/showproblem.php?pid=1301 题目可长 而且还是英文  没必要一字一句的去读题  可以根据下面的输入输出和图来搞清题意 题意:有n个村庄,村庄间有公路,公路保护费用太高,不得已维护某些公路,但必须保证每个村庄间畅通.问最少要维护的道路长度 这一题主要将表示村庄的字符转化为数字,存入表示两村庄间关系的结构体中即可. #include<cstdio> #include<cstring> #include<alg

POJ--2421--Constructing Roads【最小生成树】

链接:http://poj.org/problem?id=2421 题意:n个村庄,告诉你任两个村庄间距离,要建一些路使得任两个村庄都可以互相到达,需要使花费最小,其中有q条路已经建了,求最小花费. 把已经建的路的权值改为0,再prim就行了.kruskal做的话,把建好的路用并查集合并,再kruskal就行了 #include<cstring> #include<string> #include<fstream> #include<iostream> #i

HDOJ 1233 还是畅通工程 【最小生成树】+【prim】

题意:... 策略:最最典型的prim算法. 代码: #include<stdio.h> #include<string.h> #define INF 0x3f3f3f3f #define MAXN 105 int map[MAXN][MAXN], di[MAXN], vis[MAXN]; int n; int prim() { int i, j, min, pos; memset(vis, 0, sizeof(vis)); memset(di, 0, sizeof(di)); p

HDU1162 Eddy&#39;s picture【Prim】

Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7231    Accepted Submission(s): 3656 Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to