hdu 1297 Children’s Queue

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 10540    Accepted Submission(s): 3390

Problem Description

There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single.
In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like

FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM

Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?

 

Input

There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)

 

Output

For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.

 

Sample Input

1
2
3

 

Sample Output

1
2
4

 

递推+大数:

分男女生考虑,设共有n个人。       //f(n)表示当有n个人的时候合法序列的个数,ak表示第k个人

1.当a1为男生时,有f(n-1)种可能。

2.当a1是女生时,a2必为女生.

  1)当a1、a2都为女生时,a3为男生,有f(n-3)种可能。

  2)当a1、a2、a3都为女生,a4为男生时,有f(n-4)种可能。

  ......  

  以此类推     // 下式中f(1)表示n全为女生时那种情况,规定f(0) = 1。

故有 f(n) = f(n-1) + f(n-3) + f(n-4) + f(n-5) + f(n-6) + ... + f(1) + f(0) + 1; //(1)式

又 f(n-2) =          f(n-3) +          f(n-5) + f(n-6) + ... + f(1) + f(0) + 1; //(2)式

由以上两式((1)式-(2)式)得 f(n) = f(n-1) + f(n-2) + f(n-4)

import java.math.BigInteger;
import java.util.Scanner;
public class pp {
	public static void main(String[] args)
	{
		Scanner cin=new Scanner(System.in);
		BigInteger a[]=new BigInteger[1001];
		a[0]=BigInteger.valueOf(1);
		a[1]=BigInteger.valueOf(1);
		a[2]=BigInteger.valueOf(2);
	    a[3]=BigInteger.valueOf(4);
		  for(int i=4;i<=1000;i++)
			//a[i]=(a[i-1].multiply(BigInteger.valueOf(2))).subtract(a[i-3]);
			  a[i]=(a[i-1].add(a[i-2])).add(a[i-4]);
		while(cin.hasNext())
		{
	      int n=cin.nextInt();
		  System.out.println(a[n]);
		}
	}
}

hdu 1297 Children’s Queue

时间: 2024-08-19 16:17:56

hdu 1297 Children’s Queue的相关文章

HDU 1297 Children’s Queue (递推、大数相加)

Children’s Queue Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 17918    Accepted Submission(s): 5976 Problem Description There are many students in PHT School. One day, the headmaster whose na

HDOJ/HDU 1297 Children’s Queue(推导~大数)

Problem Description There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one

HDOJ 1297 Children’s Queue

JAVA大数.... Children's Queue Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 10390    Accepted Submission(s): 3333 Problem Description There are many students in PHT School. One day, the headmas

hdoj 1297 Children’s Queue 【高精度】【递推】

题意:有n个人,每一个人可以是男孩也可以是女孩,要求每个女孩不能单独一个,也就是一个女孩的左右紧挨的位置至少要有一个女孩.问这样的队列有几个. 分析:设f(n)是n的排列的数目,这时候来一个人: 一:如果是男孩,那么f(n ) = f(n-1) 二:如果是女孩,如果前n-2是合法的,那么f(n) = f(n-2):如果前n-2不合法的,那么n-2队列的末尾两个同学肯定是男+女,那么再加上后来的女孩,又合法了,此时f(n) = f(n-4); 综上:f(n) = f(n-1)+f(n-2)+f(n

(hdu step 3.1.7)Children’s Queue(求n个人站在一起有m个人必须是连在一起的方案数)

在写题解之前给自己打一下广告哈~..抱歉了,希望大家多多支持我在CSDN的视频课程,地址如下: http://edu.csdn.net/course/detail/209 题目: Children's Queue Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 853 Accepted Submission(s): 479   Problem

Children’s Queue(递推)

Children's Queue Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 12101    Accepted Submission(s): 3953 Problem Description There are many students in PHT School. One day, the headmaster whose n

Children’s Queue(hdu1297+递推)

Children’s Queue Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 12101 Accepted Submission(s): 3953 Problem Description There are many students in PHT School. One day, the headmaster whose name is

(递推 大整数) Children’s Queue hdu1297

Children's Queue Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 16006    Accepted Submission(s): 5337 Problem Description There are many students in PHT School. One day, the headmaster whose n

hdu Children’s Queue

http://acm.hdu.edu.cn/game/entry/problem/show.php?chapterid=3&sectionid=1&problemid=10 1 #include <cstdio> 2 #include <cstring> 3 #include <algorithm> 4 #define maxn 300000 5 using namespace std; 6 7 int n; 8 int a[1001][500]; 9