POJ 3335 Rotating Scoreboard(半平面交 多边形是否有核 模板)

题目链接:http://poj.org/problem?

id=3335

Description

This year, ACM/ICPC World finals will be held in a hall in form of a simple polygon. The coaches and spectators are seated along the edges of the polygon. We want to place a rotating scoreboard somewhere in the hall such that a spectator sitting anywhere
on the boundary of the hall can view the scoreboard (i.e., his line of sight is not blocked by a wall). Note that if the line of sight of a spectator is tangent to the polygon boundary (either in a vertex or in an edge), he can still view the scoreboard. You
may view spectator‘s seats as points along the boundary of the simple polygon, and consider the scoreboard as a point as well. Your program is given the corners of the hall (the vertices of the polygon), and must check if there is a location for the scoreboard
(a point inside the polygon) such that the scoreboard can be viewed from any point on the edges of the polygon.

Input

The first number in the input line, T is the number of test cases. Each test case is specified on a single line of input in the form n x1 y1 x2 y2 ... xn yn where n (3
≤ n ≤ 100) is the number of vertices in the polygon, and the pair of integers xi yi sequence specify the vertices of the polygon sorted in order.

Output

The output contains T lines, each corresponding to an input test case in that order. The output line contains either YES or NO depending on whether the scoreboard can be placed inside the hall conforming to the problem conditions.

Sample Input

2
4 0 0 0 1 1 1 1 0
8 0 0  0 2  1 2  1 1  2 1  2 2  3 2  3 0

Sample Output

YES
NO

Source

Tehran 2006 Preliminary

PS:

顺时针给出点!

求是否有核!

逆时针给出仅仅要反一下输入就好了:http://blog.csdn.net/u012860063/article/details/41145157

代码例如以下:

#include <cstdio>
#include <cmath>
#include <iostream>
using namespace std;
#define eps 1e-8
const int MAXN=10017;
int n;
double r;
int cCnt,curCnt;//此时cCnt为终于分割得到的多边形的顶点数、暂存顶点个数
struct point
{
    double x,y;
};
point points[MAXN],p[MAXN],q[MAXN];//读入的多边形的顶点(顺时针)、p为存放终于分割得到的多边形顶点的数组、暂存核的顶点

void getline(point x,point y,double &a,double &b,double   &c) //两点x、y确定一条直线a、b、c为其系数
{
    a = y.y - x.y;
    b = x.x - y.x;
    c = y.x * x.y - x.x * y.y;
}
void initial()
{
    for(int i = 1; i <= n; i++)p[i] = points[i];
    p[n+1] = p[1];
    p[0] = p[n];
    cCnt = n;//cCnt为终于分割得到的多边形的顶点数。将其初始化为多边形的顶点的个数
}
point intersect(point x,point y,double a,double b,double c) //求x、y形成的直线与已知直线a、b、c、的交点
{
    double u = fabs(a * x.x + b * x.y + c);
    double v = fabs(a * y.x + b * y.y + c);
    point pt;
    pt.x=(x.x * v + y.x * u) / (u + v);
    pt.y=(x.y * v + y.y * u) / (u + v);
    return  pt;
}
void cut(double a,double b ,double c)
{
    curCnt = 0;
    int i;
    for(i = 1; i <= cCnt; ++i)
    {
        if(a*p[i].x + b*p[i].y + c >= 0)q[++curCnt] = p[i];// c因为精度问题,可能会偏小。所以有些点本应在右側而没在。
        //故应该接着推断
        else
        {
            if(a*p[i-1].x + b*p[i-1].y + c > 0) //假设p[i-1]在直线的右側的话。
            {
                //则将p[i],p[i-1]形成的直线与已知直线的交点作为核的一个顶点(这种话,因为精度的问题,核的面积可能会有所降低)
                q[++curCnt] = intersect(p[i],p[i-1],a,b,c);
            }
            if(a*p[i+1].x + b*p[i+1].y + c > 0) //原理同上
            {
                q[++curCnt] = intersect(p[i],p[i+1],a,b,c);
            }
        }
    }
    for(i = 1; i <= curCnt; ++i)p[i] = q[i];//将q中暂存的核的顶点转移到p中
    p[curCnt+1] = q[1];
    p[0] = p[curCnt];
    cCnt = curCnt;
}
void solve()
{
    //注意:默认点是顺时针,假设题目不是顺时针,规整化方向
    initial();
    for(int i = 1; i <= n; ++i)
    {
        double a,b,c;
        getline(points[i],points[i+1],a,b,c);
        cut(a,b,c);
    }
    /*
    假设要向内推进r。用该部分取代上个函数
    for(int i = 1; i <= n; ++i){
    Point ta, tb, tt;
    tt.x = points[i+1].y - points[i].y;
    tt.y = points[i].x - points[i+1].x;
    double k = r / sqrt(tt.x * tt.x + tt.y * tt.y);
    tt.x = tt.x * k;
    tt.y = tt.y * k;
    ta.x = points[i].x + tt.x;
    ta.y = points[i].y + tt.y;
    tb.x = points[i+1].x + tt.x;
    tb.y = points[i+1].y + tt.y;
    double a,b,c;
    getline(ta,tb,a,b,c);
    cut(a,b,c);
    }*/
    /*   //多边形核的面积
    double area = 0;
    for(int i = 1; i <= curCnt; ++i)
    area += p[i].x * p[i + 1].y - p[i + 1].x * p[i].y;
    area = fabs(area / 2.0);
    	*/
}
/*void GuiZhengHua(){
//规整化方向。逆时针变顺时针。顺时针变逆时针
for(int i = 1; i < (n+1)/2; i ++)
swap(points[i], points[n-i]);
}*/
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i = 1; i <= n; i++)//逆时针反一下从n->1就好了
        {
            scanf("%lf%lf",&points[i].x,&points[i].y);
        }
        points[n+1] = points[1];
        solve();
        if(cCnt < 1)
            printf("NO\n");//无核
        else
            printf("YES\n");//有核
    }
    return 0;
}
时间: 2024-11-11 19:15:41

POJ 3335 Rotating Scoreboard(半平面交 多边形是否有核 模板)的相关文章

POJ 3335 Rotating Scoreboard 半平面交求多边形内核

题目大意:多边形求内核模板题 思路:半平面交,我用的是O(nlogn)的半平面交,但是有一个问题,就是当多边形内核是一个点的时候,半平面交所得到的答案是空集合,但是输出应该是yes,实在没有什么好的解决方法,最后只能把所有直线向右移动,然后在求内核.但是这样做eps的不同取值有的时候能A有的时候不能A.有没有什么好的解决方法啊!!!求解答啊!!! CODE: #include <cmath> #include <cstdio> #include <cstring> #i

poj 3335 Rotating Scoreboard(半平面交)

Rotating Scoreboard Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 6420   Accepted: 2550 Description This year, ACM/ICPC World finals will be held in a hall in form of a simple polygon. The coaches and spectators are seated along the ed

POJ 3335 Rotating Scoreboard(半平面交 模板)

题目链接:http://poj.org/problem?id=3335 Description This year, ACM/ICPC World finals will be held in a hall in form of a simple polygon. The coaches and spectators are seated along the edges of the polygon. We want to place a rotating scoreboard somewher

POJ 3335 Rotating Scoreboard(半平面交求多边形核)

题目链接 题意 : 给你一个多边形,问你在多边形内部是否存在这样的点,使得这个点能够看到任何在多边形边界上的点. 思路 : 半平面交求多边形内核. 半平面交资料 关于求多边形内核的算法 什么是多边形的内核? 它是平面简单多边形的核是该多边形内部的一个点集,该点集中任意一点与多边形边界上一点的连线都处于这个多边形内部.就是一个在一个房子里面放一个摄像 头,能将所有的地方监视到的放摄像头的地点的集合即为多边形的核. 如上图,第一个图是有内核的,比如那个黑点,而第二个图就不存在内核了,无论点在哪里,总

POJ 3130 How I Mathematician Wonder What You Are!(半平面相交 多边形是否有核 模板)

题目链接:http://poj.org/problem?id=3130 Description After counting so many stars in the sky in his childhood, Isaac, now an astronomer and a mathematician uses a big astronomical telescope and lets his image processing program count stars. The hardest pa

POJ 1279 Art Gallery 半平面交 多边形的核

题意:求多边形的核的面积 套模板即可 #include <iostream> #include <cstdio> #include <cmath> #define eps 1e-18 using namespace std; const int MAXN = 1555; double a, b, c; int n, cnt; struct Point { double x, y; double operator ^(const Point &b) const {

POJ 3335 Rotating Scoreboard

题目大意:同   POJ3130 解题思路:同   POJ3130 POJ3130解题报告:点此进入 注意:两个题给出点的顺序不一样.不要老是抄模版(我不会告诉你我就是这么做的). 下面是代码: #include <set> #include <map> #include <queue> #include <math.h> #include <vector> #include <string> #include <stdio.h

poj 3384 Feng Shui 半平面交的应用 求最多覆盖凸多边形的面积的两个圆 的圆心坐标

题目来源: http://poj.org/problem?id=3384 分析: 用半平面交将多边形的每条边一起向"内"推进R,得到新的多边形(半平面交),然后求多边形的最远两点. 代码如下: const double EPS = 1e-10; const int Max_N = 105 ; struct Point{ double x,y; Point(){} Point(double x, double y):x(x),y(y){} Point operator - (Point

POJ 1279 Art Gallery 半平面交求多边形核

第一道半平面交,只会写N^2. 将每条边化作一个不等式,ax+by+c>0,所以要固定顺序,方便求解. 半平面交其实就是对一系列的不等式组进行求解可行解. 如果某点在直线右侧,说明那个点在区域内,否则出现在左边,就可能会有交点,将交点求出加入. //#pragma comment(linker, "/STACK:16777216") //for c++ Compiler #include <stdio.h> #include <iostream> #inc