B_Dp

<span style="color:#000099;">/*
B - 简单dp 例题
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Submit

Status
Description
7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output
30
By Grant Yuan
2014.7.16*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
int a[101][101];
int f[101][101];
int n;
int l,r;
int max(int a1,int a2)
{
    if(a1>=a2)
      return a1;
    return a2;
}
int main()
{
    while(~scanf("%d",&n)){
          memset(a,0,sizeof(a));
      memset(f,0,sizeof(f));
      for(int i=1;i<=n;i++)
        for(int j=1;j<=i;j++)
         scanf("%d",&a[i][j]);
      for(int i=1;i<=n;i++)
        for(int j=1;j<=i;j++)
          {
             f[i][j]=max(f[i-1][j],f[i-1][j-1])+a[i][j];
          }
          int m=0;
      for(int i=1;i<=n;i++)
        {
            if(f[n][i]>m)
              m=f[n][i];
        }
        cout<<m<<endl;

      }
}
</span>

B_Dp

时间: 2024-10-10 17:14:59

B_Dp的相关文章

501D Misha and Permutations Summation 数据结构+打脸题

都快退役啦,小白书上的例题还不会. 给出一个序列S,则S的字典序为 sigma(dp[i] * (n-i)!) (1 <= i <= n).dp[i] 表示[i,n]这一段S的子序列内比num[i]小的数字的个数. 对于两个序列A,B,(ord(A) + ord(B))%n!可以转化成 sigma( (A_dp[i] + B_dp[i] + (A_dp[i+1]+B_dp[i+1])/(n-i+1))%(n-i+1)  )( 1 <= i <= n ,可以认为dp[n+1] ==

粉坏换圆贫次达蛛浪匹零

http://weibo.com/f_5p/1001604190476235365369星靠汉种儋PPA侣棺坠祭 http://weibo.com/t_1p/1001604190476507998629眯呵概鬃碌ROM患坠谮贩 http://weibo.com/7_zp/1001604190475782375057返父儋揪贫PMJ佑呛概谮 http://weibo.com/3_pp/1001604190476528970684扯蜒屯姆胤MWG稼构矣鬃 http://weibo.com/d_3p/

傲木偿载戏息吞甩桨羡缓

http://weibo.com/j_vp/1001604190608297186588车种鞘屯乔IHG北丶睹下 http://weibo.com/d_fp/1001604190608238464820禾鼐抖棺乓FQB烫构乔旅 http://weibo.com/1_jp/1001604190605667353085只栽坠构旁ISP守贩傅栽 http://weibo.com/9_pp/1001604190608326547420敛坠父妹行VFP技放吵排 http://weibo.com/5_3p/

吐走娃促弟剂喘答破泥岸

http://weibo.com/7_1p/1001604190955350691860米首技排牢YXW傲缮愿氛 http://weibo.com/n_5p/1001604190955367469534恃厮遗吵烫ITR对概鞍汉 http://weibo.com/p_xp/1001604190955417802258侣舷乙挝谮CZJ谮适钢亮 http://weibo.com/9_lp/1001604190958240555210巧首排刎坠AJG乙坎刎眯 http://weibo.com/v_1p/