POJ 2017 Speed Limit (直叙式的简单模拟 编程题目 动态属性很少,难度小)

Speed Limit

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 17578   Accepted: 12361

Description

Bill and Ted are taking a road trip. But the odometer in their car is broken, so they don‘t know how many miles they have driven. Fortunately, Bill has a working stopwatch, so they can record their speed and the total time they have driven. Unfortunately, their record keeping strategy is a little odd, so they need help computing the total distance driven. You are to write a program to do this computation.

For example, if their log shows

Speed in miles perhour Total elapsed time in hours
20 2
30 6
10 7

this means they drove 2 hours at 20 miles per hour, then 6-2=4 hours
at 30 miles per hour, then 7-6=1 hour at 10 miles per hour. The
distance driven is then (2)(20) + (4)(30) + (1)(10) = 40 + 120 + 10 =
170 miles. Note that the total elapsed time is always since the
beginning of the trip, not since the previous entry in their log.

Input

The
input consists of one or more data sets. Each set starts with a line
containing an integer n, 1 <= n <= 10, followed by n pairs of
values, one pair per line. The first value in a pair, s, is the speed in
miles per hour and the second value, t, is the total elapsed time. Both
s and t are integers, 1 <= s <= 90 and 1 <= t <= 12. The
values for t are always in strictly increasing order. A value of -1 for n
signals the end of the input.

Output

For each input set, print the distance driven, followed by a space, followed by the word "miles"

Sample Input

3
20 2
30 6
10 7
2
60 1
30 5
4
15 1
25 2
30 3
10 5
-1

Sample Output

170 miles
180 miles
90 miles

Source

Mid-Central USA 2004

题目分析:输入n行,每行是速度和运行总时间。  也就是说:以样例为例:运行到2小时末的时候都是20的速度,运行到6小时末的时候期间的都是30的速度,==中间4小时是30的速度

运行到7小时末的时候是10的速度,也就是说(7-6)的1小时是10的速度,输出总的行驶距离。

代码:

//直叙式的简单模拟题
#include <stdio.h>
#include <string.h>

int main()
{
    int n;
    int i, j;
    int a[20], b[20];

    while(scanf("%d", &n)&&n!=-1)
    {
        for(i=0; i<n; i++)
        {
            scanf("%d %d", &a[i], &b[i] );
        }
        int ans=0, t=0;

        for(j=0; j<n; j++)
        {
           ans=ans+a[j]*(b[j]-t);
           t=b[j];
        }
        printf("%d miles\n", ans );
    }
    return 0;
}
时间: 2024-11-05 12:20:05

POJ 2017 Speed Limit (直叙式的简单模拟 编程题目 动态属性很少,难度小)的相关文章

[ACM] poj 2017 Speed Limit

Speed Limit Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 17030   Accepted: 11950 Description Bill and Ted are taking a road trip. But the odometer in their car is broken, so they don't know how many miles they have driven. Fortunately

poj 2017 Speed Limit

Speed Limit Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 17704   Accepted: 12435 Description Bill and Ted are taking a road trip. But the odometer in their car is broken, so they don't know how many miles they have driven. Fortunately

zoj 2176 Speed Limit

Speed Limit Time Limit: 2 Seconds      Memory Limit: 65536 KB Bill and Ted are taking a road trip. But the odometer in their car is broken, so they don't know how many miles they have driven. Fortunately, Bill has a working stopwatch, so they can rec

POJ2017 Speed Limit

水题,用一个变量存一下上一个时间即可. Speed Limit Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 17698   Accepted: 12433 Description Bill and Ted are taking a road trip. But the odometer in their car is broken, so they don't know how many miles they have

E - Speed Limit(2.1.1)

E - Speed Limit(2.1.1) Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u Submit Status Description Bill and Ted are taking a road trip. But the odometer in their car is broken, so they don't know how many miles they have dr

poj 2193 Lenny&#39;s Lucky Lotto Lists 简单dp

//poj 2193 //sep9 #include <iostream> using namespace std; typedef __int64 INT; INT dp[16][2048]; int n,m; int main() { int cases,t=0; scanf("%d",&cases); while(cases--){ scanf("%d%d",&n,&m); memset(dp,0,sizeof(dp));

POJ 1286 Necklace of Beads(Polya简单应用)

Necklace of Beads 大意:3种颜色的珠子,n个串在一起,旋转变换跟反转变换如果相同就算是同一种,问会有多少种不同的组合. 思路:正规学Polya的第一道题,在楠神的带领下,理解的还算挺快的,代码没什么好说的,裸的Polya,也不需要优化. 1 /************************************************************************* 2 > File Name: POJ1286.cpp 3 > Author: GLSil

POJ 2409 Let it Bead(Polya简单应用)

Let it Bead 大意:给你m种颜色,n个珠子串起来,旋转跟反转相同算相同,问有多少种不同的涂色组合方式. 思路:Polya的简单应用. 1 /************************************************************************* 2 > File Name: POJ2409.cpp 3 > Author: GLSilence 4 > Created Time: 2014年07月29日 星期二 22时56分58秒 5 **

POJ 1473 There&#39;s Treasure Everywhere!(简单几何)

There's Treasure Everywhere! 博客原文地址:http://blog.csdn.net/xuechelingxiao/article/details/40865611 题目大意: 给你一个字符串,里面有许多的操作,前面的数字是移动的距离,后面的英文表示移动的方向,问最后从远点出发的一个点回落在什么地方以及距离出发点的距离是多少. 解题思路: 题目本身并不是很难,也没有什么坑点,没什么好说的,字符串处理的时候细心一点就行. PS:每组后面需要加一个回车,因为这个PE了一次