判断是不是闰年

<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
    <title></title>
    <script type="text/javascript">
        //定义函数
        function isLeapYear(year)
        {
            //判断闰年的条件
            if((year%4==0)&&(year%100!=0)||(year%400==0))
            {
                return year+"年是闰年";
            }
            else
            {
                return year+"年不是闰年";
            }
        }
        //调用函数
        document.write(isLeapYear(2015));
    </script>
</head>
<body>
</body>
</html>

时间: 2024-10-03 13:38:42

判断是不是闰年的相关文章

武汉科技大学ACM :1002: 零起点学算法28——判断是否闰年

Problem Description 输入年份,判断是否闰年 Input 输入一个整数n(多组数据) Output 如果是闰年,输出yes,否则输出no(每组数据一行) Sample Input 2000 Sample Output yes 我的代码: 1 #include<stdio.h> 2 int main() 3 { 4 int year; 5 while(scanf("%d",&year)!=EOF) 6 { 7 8 if((year%4==0 &

1121: 零起点学算法28——判断是否闰年

1121: 零起点学算法28--判断是否闰年 Time Limit: 1 Sec  Memory Limit: 64 MB   64bit IO Format: %lldSubmitted: 3988  Accepted: 2204[Submit][Status][Web Board] Description 输入年份,判断是否闰年 Input 输入一个整数n(多组数据) Output 如果是闰年,输出yes,否则输出no(每组数据一行) Sample Input 2000 Sample Out

shell整理(31)===判断平年闰年和嵌套循环的小例子

题目(一) 有1 2 3 4 四位数,任意组合有多少种互不相同且无重复的数字,分别是什么? shell代码如下: #!/bin/bash for i in `seq 4` do for x in `seq 4` do for y in `seq 4 ` do [ $x -eq $i  ] && continue [ $x -eq $y  ] && continue [ $i -eq $y  ] && continue echo $i$x$y done don

c语言判断平年/闰年

要求: 用户输入年份之后,判断输入的是平年还是闰年 #include<stdio.h> #include<stdlib.h> #include<string.h> intmain(void) { //定义变量 int year = 0; int temp = 0; int temp1 = 0; //提示用户输入年份 printf("请输入年份:"); scanf("%d",&year); //首先判断当前的年份是否为整百或

作业3.输入一个年份,判断是闰年还是平年

1 using System; 2 using System.Collections.Generic; 3 using System.Linq; 4 using System.Text; 5 6 namespace ConsoleApplication1 7 { 8 class 闰平年 9 { 10 static void Main(string[] agre) 11 { 12 Console.Write("请输入一个年份:"); 13 string a = Console.ReadL

0910输入一个年月日,判断是否闰年,输入几月几日,输出是今年的第几天

Console.Write("输入年:"); int year = int.Parse(Console.ReadLine()); Console.Write("输入月:"); int month = int.Parse(Console.ReadLine()); Console.Write("输入日:"); int day = int.Parse(Console.ReadLine()); bool isok = false;//用来记录日期是否正确

try判断是不是闰年

static void Main(string[] args) { while (true) { string rn = Console.ReadLine(); string s = ""; try { DateTime rn1 = Convert.ToDateTime(rn + "-2-29"); s = "年是闰年"; } catch (Exception) { s = "年不是闰年"; } finally { Conso

32.零起点学算法26——判断是否闰年

#include<stdio.h> int main() { int n; while(scanf("%d",&n)!=EOF) { if(((n%4==0)&&(n%100!=0))||(n%400==0)) printf("yes\n"); else printf("no\n"); } return 0; } 原文地址:https://www.cnblogs.com/Estwind/p/9751149.ht

判断是否为闰年?

<?php $year = 305205;  //$year = mt_rand(2000,4000); //产生随机数的函数 //判断是闰年 if(($year%4==0 )&&($year%100!=0)||($year%400==0)) {     echo "这是一个闰年"; } else{     echo "这不是一个闰年!"; } //判断不是闰年 if(!($year%4==0 )&&($year%100!=0)