HDOJ 5015 233 Matrix

构造矩阵+快速幂

233 Matrix

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 344    Accepted Submission(s): 231

Problem Description

In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333... (it means
a0,1 = 233,a0,2 = 2333,a0,3 = 23333...) Besides, in 233 matrix, we got ai,j = ai-1,j +ai,j-1( i,j ≠ 0). Now you have known a1,0,a2,0,...,an,0, could you tell
me an,m in the 233 matrix?

Input

There are multiple test cases. Please process till EOF.

For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 109). The second line contains n integers, a1,0,a2,0,...,an,0(0 ≤ ai,0 < 231).

Output

For each case, output an,m mod 10000007.

Sample Input

1 1
1
2 2
0 0
3 7
23 47 16

Sample Output

234
2799
72937

Hint


Source

2014 ACM/ICPC Asia Regional Xi‘an Online

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

typedef long long int LL;

const LL MOD=10000007LL;

int n,m;
LL a[20];

struct Matrix
{
	int x,y;
	LL matrix[12][12];
	Matrix()
	{
		x=y=0;
		memset(matrix,0,sizeof(matrix));
	}
};

void init(Matrix& m)
{
	m.x=m.y=n+2;
	for(int i=0;i<m.x-2;i++)
		for(int j=i;j<m.y-1;j++)
			m.matrix[i][j]=1;
	m.matrix[m.x-2][m.y-2]=10;
	m.matrix[m.x-1][m.y-1]=m.matrix[m.x-2][m.y-1]=1;
}

Matrix CHENGFA(Matrix& a,Matrix& b)
{
	int n=a.x;
	Matrix ret;
	ret.x=ret.y=n;
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<n;j++)
		{
			LL temp=0;
			for(int k=0;k<n;k++)
			{
				temp=(temp+(a.matrix[i][k]*b.matrix[k][j])%MOD)%MOD;
			}
			ret.matrix[i][j]=temp%MOD;
		}
	}
	return ret;
}

Matrix MatrixQuickPow(Matrix m,int k)
{
	Matrix e;
	int n=m.x;
	e.x=e.y=n;
	for(int i=0;i<n;i++) e.matrix[i][i]=1;
	while(k)
	{
		if(k%2)
			e=CHENGFA(e,m);
		m=CHENGFA(m,m);
		k/=2;
	}
	return e;
}

int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(int i=n-1;i>=0;i--)
			scanf("%lld",a+i);
		a[n]=233; a[n+1]=3;
		Matrix M,ED;
		init(M);
		ED=MatrixQuickPow(M,m-1);
		LL ans=0;
		for(int i=0;i<n+1;i++)
		{
			LL temp=0;
			for(int j=0;j<n+2;j++)
			{
				temp=(temp+(ED.matrix[i][j]*a[j])%MOD)%MOD;
			}
			ans=(ans+temp)%MOD;
		}
		printf("%I64d\n",ans);
	}
	return 0;
}
时间: 2024-11-10 16:26:46

HDOJ 5015 233 Matrix的相关文章

HDU 5015 233 Matrix(西安网络赛I题)

HDU 5015 233 Matrix 题目链接 思路:矩阵快速幂,观察没一列,第一个和为左边加最上面,第二个可以拆为左边2个加最上面,第三个可以拆为为左边3个加最上面,这样其实只要把每一列和每一列右边那列的233构造出一个矩阵,进行矩阵快速幂即可 代码: #include <cstdio> #include <cstring> typedef long long ll; const int N = 15; const int MOD = 10000007; int n, m; s

hdu 5015 233 Matrix (矩阵高速幂)

233 Matrix Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 749    Accepted Submission(s): 453 Problem Description In our daily life we often use 233 to express our feelings. Actually, we may s

HDU - 5015 233 Matrix (矩阵构造)

Problem Description In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be

HDU 5015 233 Matrix(矩阵快速幂)

Problem Description In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be

hdu 5015 233 Matrix

233 Matrix Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 392    Accepted Submission(s): 262 Problem Description In our daily life we often use 233 to express our feelings. Actually, we may s

hdu 5015 233 Matrix(最快的搞法)

233 Matrix Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 191    Accepted Submission(s): 125 Problem Description In our daily life we often use 233 to express our feelings. Actually, we may s

hdu 5015 233 Matrix (矩阵快速幂)

233 Matrix Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 749    Accepted Submission(s): 453 Problem Description In our daily life we often use 233 to express our feelings. Actually, we may s

hdu 5015 233 Matrix(构造矩阵)

http://acm.hdu.edu.cn/showproblem.php?pid=5015 因为是个二维的递推式,当时没有想到可以这样构造矩阵.从列上看,当前这一列都是由前一列递推得到.根据这一点来构造矩阵.令b[i]代表第i列,是一个(n+2)*1的矩阵,即b[1] = [1,233......],之所以在加了两行,是要从前一个矩阵b[i-1]得到b[i]中的第二个数2333...,再构造一个转换矩阵a,它是一个(n+2)*(n+2)的矩阵,那么a^(m-1) * b就是第m列. /* a矩

hdu 5015 233 Matrix (矩阵快速幂)

题意: 有一种矩阵,它的第一行是这样一些数:a  0,0 = 0, a 0,1 = 233,a 0,2 = 2333,a 0,3 = 23333... 除此之外,在这个矩阵里, 我们有 a i,j = a i-1,j +a i,j-1( i,j ≠ 0).现在给你 a 1,0,a 2,0,...,a n,0, 你能告诉我a n,m 是多少吗? n,m(n ≤ 10,m ≤ 10 9)输出 a n,m mod 10000007. 思路:首先我们观察n和m的取值范围,会发现n非常小而m却非常大,如果