HDU 3947 Assign the task

http://acm.hdu.edu.cn/showproblem.php?pid=3974

Problem Description

There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody‘s boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.

Input

The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

"C x" which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)

Output

For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.

Sample Input

1
5
4 3
3 2
1 3
5 2
5
C 3
T 2 1
C 3
T 3 2
C 3

Sample Output

Case #1:
-1
1
2

代码:

#include <bits/stdc++.h>
using namespace std;

const int maxn = 1e5 + 10;
int T, N;
int head[maxn];
int cnt, tot;
int st[maxn], en[maxn];
bool used[maxn];

struct Edge {
    int to, nx;
}edge[maxn];

struct Node {
    int val;
    int l, r;
    int lazy;
}node[maxn * 4];

void init() {
    cnt = 0;
    tot = 0;
    memset(head, -1, sizeof(head));
}

void addedge(int u, int v) {
    edge[tot].to = v;
    edge[tot].nx = head[u];
    head[u] = tot ++;
}

void dfs(int u) {
    cnt ++;
    st[u] = cnt;
    for(int i = head[u]; i != -1; i = edge[i].nx)
        dfs(edge[i].to);
    en[u] = cnt;
}

void Update_Same (int r, int v) {
    if(r) {
        node[r].val = v;
        node[r].lazy = 1;
    }
}

void push_down(int r) {
    if(node[r].lazy) {
        Update_Same(r * 2, node[r].val);
        Update_Same(r * 2 + 1, node[r].val);
        node[r].lazy = 0;
    }
}

void Build(int i, int l, int r) {
    node[i].l = l;
    node[i].r = r;
    node[i].val = -1;
    node[i].lazy = 0;
    if(l == r) return ;
    int mid = (l + r) / 2;
    Build(i * 2, l, mid);
    Build(i * 2 + 1, mid + 1, r);
}

void update(int i, int l, int r, int v) {
    if(node[i].l == l && node[i].r == r) {
        Update_Same(i, v);
        return;
    }
    push_down(i);
    int mid = (node[i].l + node[i].r) / 2;
    if(r <= mid) update(i * 2, l, r, v);
    else if(l > mid) update(i * 2 + 1, l, r, v);
    else {
        update(i * 2, l, mid, v);
        update(i * 2 + 1, mid + 1, r, v);
    }
}

int query(int i, int u) {
    if(node[i].l == u && node[i].r == u)
        return node[i].val;
    push_down(i);
    int mid = (node[i].l + node[i].r) / 2;
    if(u <= mid) return query(i * 2, u);
    else return query(i * 2 + 1, u);
}

int main() {
    scanf("%d", &T);
    for(int t = 1; t <= T; t ++) {
        printf("Case #%d:\n", t);
        int u, v;
        memset(used, false, sizeof(used));
        init();
        scanf("%d", &N);
        for(int i = 1; i < N; i ++) {
            scanf("%d%d", &u, &v);
            used[u] = true;
            addedge(v, u);
        }
        for(int i = 1; i <= N; i ++) {
            if(!used[i]) {
                dfs(i);
                break;
            }
        }
        Build(1, 1, cnt);
        char op[10];
        int M;
        scanf("%d", &M);
        while(M --) {
            scanf("%s", op);
            if(op[0] == ‘C‘) {
                scanf("%d", &u);
                printf("%d\n", query(1, st[u]));
            } else {
                scanf("%d%d", &u, &v);
                update(1, st[u], en[u], v);
            }
        }
    }
    return 0;
}

  线段树 模板题 链表存图 区间修改单点查询 今天小目标之一把这个搞清楚可以自己写粗来

何生枷锁

原文地址:https://www.cnblogs.com/zlrrrr/p/10682631.html

时间: 2024-10-29 15:16:51

HDU 3947 Assign the task的相关文章

HDU 3974 Assign the task 并查集/图论/线段树

Assign the task Time Limit: 1 Sec  Memory Limit: 256 MB 题目连接 http://acm.hdu.edu.cn/showproblem.php?pid=3974 Description There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the l

HDU 3974 Assign the task(树 并查集)

题意  公司中有n个员工  除了boss  每个员工都有自己的上司  自己下属的下属也是自己的下属  当给一个员工分配任务时  这个员工会把任务也分配到自己的所有下属   每个员工都只做最后一个被分配的任务  对于每个C x  输出员工x正在做的任务  没有就输出-1 把员工的关系数建成类似并查集的结构  把每个直接分配任务的员工的任务和任务分配时间保存起来  查询时只要找这个员工所有父节点中最晚分配的任务 #include <bits/stdc++.h> using namespace st

HDU 3974 Assign the task(并查集)

Problem Description There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, an

HDU 3974 Assign the task(线段树)

描述There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordin

HDU 3974 Assign the task

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3974 解题思路:深搜设置时间戳,然后线段树上更新查询即可. 第一次写,还算顺利(尽管wa了两发). 代码: 1 const int maxn = 5e4 + 5; 2 //静态链表前向星保存图 3 struct Edge{ 4 int to, next; 5 int val; 6 }; 7 int head[maxn], tot; 8 Edge edges[maxn]; 9 //dfs 时间戳 -

hdu 3974 Assign the task(线段树)

题目链接 http://acm.hdu.edu.cn/showproblem.php?pid=3974 题意:给定一棵树,50000个节点,50000个操作,C x表示查询x节点的值,T x y表示更新x节点及其子节点的值为y 大致把边存一下那一棵树来举例子 2 3 5 4 1 例如像这样的一棵树,可以将2->1,3->2,4->3,1->4,5->5按照dfs序来编号,然后用线段树进行区间修改,稍微想一想 应该都会了. #include <iostream> #

HDU 3974 Assign the task(dfs编号+线段树成段更新)

题意:给定点的上下级关系,规定如果给i分配任务a,那么他的所有下属.都停下手上的工作,开始做a. 操作 T x y 分配x任务y,C x询问x的当前任务: Sample Input 1 5 4 3 3 2 1 3 5 2 5 C 3 T 2 1 C 3 T 3 2 C 3 Sample Output Case #1: -1 1 2 思路: 利用dfs深度优先遍历重新编号,使一个结点的儿子连续.然后成段更新. 2:1-5 5:2-2 3:3-5 1:4-4 4:5-5 #include<iostr

HDU 3974 Assign the task(dfs时间戳+线段树成段更新)

题意:给定点的上下级关系,规定假设给i分配任务a.那么他的全部下属.都停下手上的工作,開始做a. 操作 T x y 分配x任务y,C x询问x的当前任务: Sample Input 1 5 4 3 3 2 1 3 5 2 5 C 3 T 2 1 C 3 T 3 2 C 3 Sample Output Case #1: -1 1 2 思路: 利用dfs深度优先遍历又一次编号.使一个结点的儿子连续. 然后成段更新. 代码: #include<iostream> #include<cstdio

HDU 3974 Assign the task 简单搜索

根据Rex 的思路才知道可以这么写. 题目意思还是很好理解的,就是找到当前雇员最近的任务. 做法是,可以开辟一个 tim 变量,每次有雇员得到昕任务时候 ++tim 然后取寻找最近的任务的时候写一个搜索就可以 核心代码: while(num != -1){ num = a[num].leader; if(ttime < a[num].time){ ans = a[num].work; ttime = a[num].time; } } Source code: //#pragma comment(